Jump to content
  • 0

VW 2015 in MacOS High Sierra, strange problems

Bengt Nilsson


Hi all,


I recently upgraded my MacOS to the latest version, High Sierra.

I now revisited an older VW project, and I see some unexpected things.


1) I can no longer access Edit Revision Data in the Sheet Border object, as described in the Help. Simply no such button anymore.

2) Section views in my Sheet layer are empty, only the dimensions remain. The render "update" button is red in the Object Info for the viewport, and it does not change when I press it, still red, and still no viewport content. Regular (non-section) viewports behave as they should. In the View menu, there is no longer any Create Section View, as described in Help.


I refer to the Help pages, since these particular items you do not so often, and I tend to forget how to do things.

This may or may not have anything at all to do with my OS upgrade, but it is still strange and not as I remember it.






Link to comment

8 answers to this question

Recommended Posts

  • 0

I think I know what's going on with #1.


If you're using VW 2018 and opening up a project started in an earlier version, then the Sheet Border issue is normal and not related to the High Sierra update.  Update the Sheet Border object and it will create a new sheet border / title block that will be editable.



Link to comment
  • 0

I just got an iMac 27 2017 with 256 SSD. it came with 10.13, High Sierra.

I have VW 2015 sp 4 

I don't seem to have these problems . it loads, sheet sections work (in a small test)

I wonder why? since VW says 2015 is not compatible with High Sierra..

will I get other problems?


any idea? 

Link to comment
  • 0

I just tried to install VW2015 Professional version, which I have at home, to my university Mac at my work, where I have VW 2015 Edu.

I needed the Pro at work so I could edit the designs I share with myself using Dropbox. As we know, a VW Edu document cannot be opened by VW Pro.

Anyway this was the background.

The install failed in the sense that it could not find the USB HASP hardware lock, I tried a lot of things but no solution. There was light in the USB dongle, so it was not a driver issue.

At home I had VW 2015 already installed when I upgraded to High Sierra, and there it works, in some sense, except for the problems I reported.

After a discussion with my local VW supplier about a possible solution, we agreed that this was probably the "unsupported" issue with VW2015 and High Sierra.


So finally, I decided to upgrade and I now have VW2018 Edu at work and VW2018 Pro at home, and the problem is in the past. 

There will probably be new problems I am sure, but they will have to be dealt with as they come.

Link to comment
  • 0

Thank you for your response!

So I guess I need to look further to see what problems will come up.

some 2015 users can't even get it to load, I wonder why I can.


One thing is my new iMac is all SSD .(256 Gigs) 

reading around, I note that one of the distinguishing factors of High Sierra is


"When you install macOS High Sierra on the Mac volume of a solid-state drive (SSD) or other all-flash storage device, that volume is automatically converted to APFS. Fusion Drives, traditional hard disk drives (HDDs), and non-Mac volumes aren't converted. "


I don't really understand  how the new APFS works, but I wonder if the fact that my iMac is all SSD

has something to do with my success with 2015 on High Sierra? 


continuing to test.  


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...