Jump to content
Ben Wingrove

Excluding objects from Worksheets not working!

Recommended Posts

I use a worksheet on my front page to inventory all used fixtures, video elements, truss and soft goods.

Sometimes we have to create multiple versions of an object to show different positions, I tried to attach a record to the extra objects called "Hide from Inventory" thinking that if I include a criteria in the worksheet for the record "Hide from Inventory" not being present it would be a quick way of excluding extra objects without having to constantly re edit the worksheet.

Alas it did not work, is there another way to accomplish this or am I going about this the wrong way? I have included a screen grab of my worksheet Criteria, there are 12 screen objects, 6 have the "Hide from Inventory" record attached, 6 do not!

 

Thanks

 

B

 

5a1b202da9c54_ScreenShot2017-11-26at12_09_53PM.thumb.png.fe44abdfa429fe9bb81d0a0a82e365c3.png

Share this post


Link to post

It seems to work for me.  Have you tried unchecking Design Layer Viewports in the criteria?

 

 

Share this post


Link to post

@Ben WingroveDid you get this to work? If not, you may need to manually edit the criteria instead of using the criteria builder. My understanding is that by default the same types of criteria are OR'd together. It appears you need an AND instead. This can be done manually, but not with the criteria builder.

Share this post


Link to post

@Pat StanfordI still have had no luck, I thought it might have something to do with the “or” “and” syntax.

I tried editing it manually but it kept defaulting to the criteria builder settings, I will try clearing out the builder and just doing it manually in the header.

 

 

Share this post


Link to post

Can you post the file so we can take a look? Or at least post the database row criteria formula. Right click on the header row and choose Edit Criteria. Click into the Forumula bar, select everything and copy and paste here.

Share this post


Link to post

The header is 

=DATABASE((INOBJECT & INSYMBOL & (R IN ['VS4-LED']) & (('VS4-LED'.'ConfRef'='Overall Dimensions and Spacing') | ('Hide From Inventory'.'Hidden'=FALSE)) & (L<>'*UNUSED*')))

5a206161b6829_ScreenShot2017-11-30at11_51_31AM.thumb.png.f2ae48aba422305fb9bbd001fbdd9eb3.png

Share this post


Link to post

Pat is better at parsing these things than I am.  But I think it currently reads something like this.

 

An object meets the criteria if it meets all of the following conditions.

 

1.  Record VS40-LED is attached

2.  The field 'VS4-LED'.'ConfRef' = ' Overall Dimensions and Spacing  OR  the field 'Hide From Inventory'.'Hidden' = FALSE

3.  Layer is not *UNUSED*

 

I think if you change the '|' to '&' it will do what you want.

 

To change it get to the edit criteria like where you took your screen shot.  Hit Cancel.  Now you can edit the criteria directly in the data bar.

Share this post


Link to post

Changing the "|" to "&" didn't help!

The problem may be that I am only attaching the "Hide From Inventory" Record to things I want to hide, so if it is set to only show HIDDEN as FALSE it may be confusing it!!

Share this post


Link to post

OK So I took @michaelk's idea of changing the '|' to '&' but instead i told it to search for the "Hide from Inventory' record to not be present instead of the actual field value.

That worked :D

 

Only problem now is if someone unchecked the "HIDDEN" field value instead of removing the record all together it won't work ¬¬

 

At least it will get me off to a start.

 

It is a shame you can't add user fields to built in objects, I added a Show In Inventory checkbox to the Lighting Device Objects (Spotlight) and that works like a charm.

 

5a208097e064e_ScreenShot2017-11-30at2_04_45PM.thumb.png.b88deaedb79dff3f1a27ba7cc68a08f5.png

5a208097e064e_ScreenShot2017-11-30at2_04_45PM.thumb.png.b88deaedb79dff3f1a27ba7cc68a08f5.png

Share this post


Link to post

There are 10 "User Fields in the Lighting device record format that you can use for things like that.

 

 

 

Share this post


Link to post

 

2 minutes ago, michaelk said:

There are 10 "User Fields in the Lighting device record format that you can use for things like that.

 

 

 

@michaelk I Know, thats what I used for the Lighting Devices but alas there is no such functionality for Truss, Soft Goods, Video elements etc.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...