Jump to content
Developer Wiki and Function Reference Links Read more... ×
willofmaine

Marionette Objects Relentlessly Reset

Recommended Posts

I finally perfected a Marionette object so that it works mostly quite well... in VW 2017.  Success!  Especially, having removed the "ordering numbers" from the input nodes, it's possible to change just one parameter in the OIP without having ALL of the parameters (including the one just changed...) reset to the Marionette object's default values.  Occasionally there will be inexplicable results after changing a parameter, but just entering the edit mode of the object, exiting, and staring at the script for a while (it takes a long time to exit the edit mode...) will fix it. 

 

So then I implemented my Marionette object in a project, by including it within symbols.  And it turns out that it ALWAYS takes about 20 seconds to exit the edit mode of a symbol that includes a (or at least this) Marionette object.  After a gruelling day yesterday, turns out 20 seconds is a long time...  To edit the three modes (2D, 3D, Wall Hole Component) of a symbol requires at least a minute of non-productive time, which, evidently, really adds up when there are like twenty or so symbols, many of which end up being edited several times.

 

So I finally installed VW 2018 SP2 and figured I'd give VW 2018 a try.  Hallelujah!  Exiting symbols is reasonably fast (a little over a second)!  Finally some progress...   ...'til I duplicate a symbol and try changing just one of the parameters of the Marionette object in that symbol... at which point the Marionette object resets to ALL its default values... ugh.  Why does the same Marionette object reset itself in 2018, but not in 2017?  In 2018, when creating an object node, there's an option to deselect "Reset On Move" so that Marionette objects "reset only on parameter changes."  Is there a way to make it so that they don't reset at all?  Often I just want to duplicate a Marionette object and then just change one or two parameters, without having to go through and redefine ALL of the parameters all over again, each and every time...

Share this post


Link to post

What you're talking about when duplicating is a bug. It's semi elusive, but I've gotten around it by exporting BACK to 2017 and then reopening in 2018.

 

As for the "Reset on Move" checkbox, this doesn't reset parameter values. This only redraws the geometry. The state of that checkbox won't help you with the bug mentioned above.

 

If you share a file with the offending Marionette object or send it to me privately, I can attach it to the bug in our tracking system.

Share this post


Link to post

Thanks Marissa, I'm glad to hear it's a bug and not just me.  I'll upload a file or two once I get some things sorted out.  Thanks!  Will

 

 

 

Edited by willofmaine

Share this post


Link to post

I tried exporting a VW 2018 version of my project file back to 2017, and reopened it again with 2018, as you suggested above, but, that didn't seem to help; the Marionette objects still completely reset when just a single parameter is changed.  (This Marionette object was developed in 2017, and only found its way to 2018 a couple of nights ago...).
 

 

Edited by willofmaine

Share this post


Link to post

Hi Marissa,

 

It was a bit of an ordeal getting my Marionette object to work in 2018 but, finally, here's a file that I think you can attach to the resetting bug in your tracking system.

 

In this file there are about 12 different hybrid door symbols.  Each consists of some 2D components including the ID tag (linked to a data record), a door PIO, and the 3D Marionette object.  The purpose of the Marionette object is to use molding profiles for the door trim.  All of the Marionette objects in all of the different symbols use the same network, which is saved as a symbol (and which in turn uses a couple more wrapped network symbols).

 

Except for textures, I can change the parameters of any of the Marionette objects in any of these symbols, and only the parameters that I change in the OIP actually change, as expected.  Though textures do seem to randomly change, but at least they can be changed back to what they should be without further issue.  After the textures are re-established in any one symbol, they're subsequently fine.

 

So, the (or at least some of the...) discrete issues are as follows (I think they're all related to this resetting bug):

 

(Between each of the procedures described below, I close the file without saving it)

 

1.) Textures randomly changing as described above;

2.) If in the Resource Manager you duplicate one of the door symbols, place it in the drawing, edit it, and change any of the parameters of its Marionette object, ALL of the object's parameters reset to the network's defaults (except for textures, which seem to behave entirely randomly);

3.) If you edit the underlying network symbol ("Network-Object-Door-Trim") DIRECTLY via the Resource Manager (NOT by editing one of the door symbols), the Marionette objects in the symbols do NOT reset, EXCEPT that textures get messed up (and I just noticed this: if you open the file, render in OpenGL, edit one of the doors with dark wood trim, and select the Marionette object, in the OIP "Glass Clear" is listed as the texture, even though the dark wood is what has actually rendered...).

4.) If you edit any one of the door symbols, and then edit the Marionette object (i.e., double-click to access it's script, not just make changes in the OIP), ALL of the Marionette objects in ALL of the symbols will reset to the Marionette object's defaults.

 

In editing the network or Marionette object, it's not actually necessary to make any changes; just entering the editing mode counts as an "edit" as described above.

 

Well, hopefully at least some of that's helpful in your trying to track down this bug...  Part of my ordeal in going from 2017 to 2018 is that I thought I'd be tricky and take advantage 2017's lack of a resetting issue to change all the Marionette's defaults to be project-specific (without affecting the symbols already in the file), so that in 2018 I'd have fewer parameters to change every time a reset occurred.  But it took me a long while to finally figure out that, once in 2018, I had to rescale the network to get beyond a nearly endless series of issues and error messages (that whole scaling thing and its disconnected wires seems to be at the core of a lot of Marionette misery... (https://forum.vectorworks.net/index.php?/topic/53415-network-mess/)).  And, of course, rescaling the network required editing the symbol... so that in the end all of my Marionette objects reset and had to be updated anyway!!

 

Thanks, Will   VWIS117

 

17-Marionette_Objects_Reset_in_VW2018-Purged-046W.vwx

Share this post


Link to post

:( This is just making me really unhappy.  Not to mentioned the massive time investment I have in Marionette, which I guess I finally need to accept as a complete waste.

 

Having somehow survived the transition of Marionette to Vectorworks 2018, all has been fine for a few weeks.  A few times I've duplicated and created new symbols, and when I changed any of the parameters for the Marionette object, ALL of the parameters reset.  Fine; it's a known bug, and all of my parameters are as project-specific as possible, so that I only have to update just a few parameters for any one specific door.  Otherwise, there's been no weird behavior.  Until tonight.

 

Tonight, I went to change the parameters of one of the Marionette objects, and its profiles flipped.  Why?!?  See attached.  I have NOT touched the profile symbols.  I have NOT touched the Marionette scripts.  And at this point, I very much don't want to edit the scripts because then ALL of about 30 Marionette objects in their 30 symbols will RESET to defaults.  I've restarted Vectorworks, which didn't help.  What in the World else would suddenly and randomly introduce a new issue into a previously working Marionette object??

 

18-Profiles_Flip-1708-062W.mov

Edited by willofmaine

Share this post


Link to post

Hi @willofmaine,

 

I have exactly the same problem, and it is the main reason that I do not introduce the Marionette in my Office Workflow.

 

Do not make any sense every time you copy or even modify some value in the Marionette Object, it will completely RESET the object.

The mane reason of Marionette should be to reduce time on repetitive tasks, and with these BUGs it does exactly the opposite.

 

Marionette is very INSTABLE and it’s impossible to work in a system like this.

 

I HOPPE the VECTORWORKS team take a deep improve an the this systems, because as it is now, is no good. All other major companies as Autodesk, Maxon have similar sistems more stable.

 

A STABLE Marionette system is my which for 2018 (early 2018)

 

I hope

 

Have a nice 2018 

Share this post


Link to post

Hi @Nuno Antunes,

 

Yep, I agree with everything you've said.  I've officially abandoned Marionette - - - for the second time.  Maybe I'll try it yet again in a couple of years.  Or three or four.  Extremely disappointing.

 

Let me know if your wish for a stable Marionette comes true in 2018!

Share this post


Link to post

@Nuno Antunes  I've been having lots of success with Marionette in Vectorworks 2018, with only a few snags that necessitate work-arounds.  Hopefully it will be even better in 2019... good luck!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×