Jump to content
  • 0
DCapp

Border Margins Not Adjustable

Question

Hey all,

 

So now that i have the title block mostly figured out, i am having a problem with the margins on the border. I want to adjust the size of the margins, however no matter what i try it defaults back to 1" when i exit the title block. I have tried every method of this i can with the same result. Anyone had similar problems?

Share this post


Link to post

14 answers to this question

Recommended Posts

  • 0

Are you on Mac or PC?

 

If your on mac try setting up a custom size in the page setup under printer setup and  go into custom sizes.  

 

Here you can set up a page with the margin you desire.

 

Note: based on the vectorworks guidence you should always be using "one printer page" and have horizontal and vertical set 1 to 1.

 

 Its not very intuitive, but keep at it you will find what you need. Make sure to set your height and width as well for the desired paper size, also your scale on the page setup dialogue will need to be determined as well.

5a142b243d38a_ScreenShot2017-11-21at8_33_15AM.thumb.png.691fd8c33b246747a85477f8a6297f72.png5a142ab3200f1_ScreenShot2017-11-21at8_31_18AM.thumb.png.4968489616bac3c7881126d28ccd70fd.png5a142a4cb853a_ScreenShot2017-11-21at8_29_34AM.thumb.png.cb8a8a15026618d4dea276005f61a0d5.png

Edited by HEengineering

Share this post


Link to post
  • 0
12 hours ago, DCapp said:

Hey all,

 

So now that i have the title block mostly figured out, i am having a problem with the margins on the border. I want to adjust the size of the margins, however no matter what i try it defaults back to 1" when i exit the title block. I have tried every method of this i can with the same result. Anyone had similar problems?

I've had some inconsistency with the margins. Sometimes the setting takes, other times it doesn't. My titleblocks are converted from VW2017 so this may be part of the problem. However I do think there is something going on with setting the margins.

Kevin

 

Share this post


Link to post
  • 0

On a Mac, but I'm not refering to the page margins, the border margins, or how wide it is. Set in the border settings, default is 1". I'm trying to set to .5", i use a grid, but it just wont stay.

Share this post


Link to post
  • 0
14 hours ago, DCapp said:

Hey all,

 

So now that i have the title block mostly figured out, i am having a problem with the margins on the border. I want to adjust the size of the margins, however no matter what i try it defaults back to 1" when i exit the title block. I have tried every method of this i can with the same result. Anyone had similar problems?

Are you putting in the units as well? E.g. 0.5 in

When I don't put in the units (even if they are the same as the document) then the margins don't hold, you may need to use the document units and not paper units (e.g. document in meters, then use meters as unit for the margins as well, because using mm does not always seem to work)

Share this post


Link to post
  • 0

Two things I noticed:

1. You did not change to the selection tool, so the border tool is still active

2. The margins should update in the preview but they don't, however if you look at the drawing border to be inserted by the still active border you can see it did update the margins for the drawing border to be inserted.

Can you retry changing the margins by switching to the selection tool first after placing a border (and in the process make the border tool inactive) and then use the object info palette to change the border margins?

Share this post


Link to post
  • 0

No luck. Still doing the same thing. I also checked the "Grid Marker Line Length" and it to constantly resets to 1" after being changed. I also tried lowering the text size in the grid in the hopes maybe it was just trying to make room for the text, and still doing the same thing.

 

Oh yeah, and I started with a stock Spotlight template, so the template should (in theory) be clear of any relics from previous drawings.

Edited by DCapp

Share this post


Link to post
  • 0

Hey, for anyone who's following I just figured it out!! (Yes, I am very proud of myself here.)

 

So after going nuclear and uninstalling and reinstalling, i noticed the problem relates to units. I setup some of my template standards, including the border (I had to know!) Worked just fine. I then continued setting up my template and got to setting up how I like units. Since I work in live events i turn off all fractions and decimals in units, as an inch of variance is nothing in scale to what I do, and it eats up time. As soon as I set units with no decimals i tried again and i cant set margins less then 1", if i throw a single decimal place in the rounding and BOOM, I'm back in business!

 

So guessing I'm working to the tenth now...

 

Is this worth submitting as a bug? and if so how in the world do i do that?

Share this post


Link to post
  • 0

It works fine on my windows version as long as I make sure to use units with the numbers, so in theory it should at least work with a drawing border only (i.e. no title block template used) and it does in your screencast for the border to be inserted so one would expect it would also work for the already inserted border if you switch to the selection tool first and then try to update it.

 

Can you post a file with the problematic drawing border here, then I can try to update the border width to see if it works on Windows, if it does then it might be a (VW) Mac issue. There have been several VW issues lately that seem to affect only those on a Mac.

Share this post


Link to post
  • 0

The problem here seems to be units precision. If your document units' precision is set to 1, the Title Block Border will round the 0.5 to 1 right away and that is why the margin is not changing. As a workaround, you could set units' precision to 0.1 and it should update correctly. We are going to investigate this issue further more.

 

Best Regards,

Nikolay Zhelyazkov

Share this post


Link to post
  • 0
41 minutes ago, Nikolay Zhelyazkov said:

The problem here seems to be units precision. If your document units' precision is set to 1, the Title Block Border will round the 0.5 to 1 right away and that is why the margin is not changing. As a workaround, you could set units' precision to 0.1 and it should update correctly. We are going to investigate this issue further more.

 

Just changed my unit precision to a lower number to try out and then I run into the same issue a @DCapp of the title border margins not updating properly as it rounds to the closest value (in my case zero).

 

Edit (added question) @Nikolay ZhelyazkovThen out of curiousity, why does it show properly in the video for the drawing border to be inserted even though it does not update the preview in the OIP? It gave me the impression that it should work regardless of set unit precision as that should be a display issue. e.g. When I set a precision of .1 and type .25 for an object dimension it gets rounded to .3 in the dialog. When I afterwards set the precision to .001 the OIP will show .250 and not .3 for the object, so it should not affect the actual drawing/modification of the objects.

Edited by Art V

Share this post


Link to post
  • 0
6 hours ago, Nikolay Zhelyazkov said:

The problem here seems to be units precision. If your document units' precision is set to 1, the Title Block Border will round the 0.5 to 1 right away and that is why the margin is not changing. As a workaround, you could set units' precision to 0.1 and it should update correctly. We are going to investigate this issue further more.

 

Best Regards,

Nikolay Zhelyazkov

I would consider this a bug from a user perspective. Working on a Sheet Layer is different than working in the design layers and as such, you will almost always be working with smaller increments on a page.

Kevin

Share this post


Link to post
  • 0
5 hours ago, Kevin McAllister said:

I would consider this a bug from a user perspective. Working on a Sheet Layer is different than working in the design layers and as such, you will almost always be working with smaller increments on a page.

Kevin

I agree, which is why I asked that question, as the units precision rounding should not override typed in dimensions, only the displayed value should be rounded in that case. It does affect drawing objects from start click to finish click, but that is not the case here.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×