Jump to content
Alan61

Teigha Library Error on Export - The file could not be opened

Recommended Posts

I'm trying to export from VW 2014 to create a 2012 DWG file and I get a "Teigha Library Error - The file could not be opened".

I have rebooted and only opened Vectorworks and I still get the error.

I also deleted all previous DWG export folders previous exports had produced but were empty.

I'm running Windows 10.

I've even tried copying just the design layer I want to export to a new file, but I still get the error.

 

Can anyone help or point me in the right direction.

I've searched the community board.

Share this post


Link to post

I see a few similar cases from 2014, but I don't see any fixed for 2014 specifically, looks like it was resolved only in later versions. If you send me the file in a direct message I can attempt an export here with a later version but still to DWG 2012.

Share this post


Link to post

Thanks Jim. I sent it to a colleague who has the exact same setup as I do with VW 2014 and Windows 10 and he managed to export it fine, so now I'm confused but we at least we have a work around.

Share this post


Link to post

Do your user account or the folder you were trying to export to have anything unusual in their names? Anything other than the standard english alphanumeric characters? I have seen that cause similar problems on occasion, but that is a wild guess at best.

Share this post


Link to post

The folders have _ (underscore) in the name and the file has , (comma) in the name.

I just tried it again but exporting to my desktop and it worked fine.

I tried it another time but to the directory with the underscore and it worked fine.

So I think it is the deep directory structure that causes the problem.

 

Good one. :-)

 

Share this post


Link to post

Hi @Alan61 and @JimW

 

I just had a session with a user getting this error and discovered a cause that might be as-yet unreported. I'm posting this to add to the (small) list of conditions responsible for this error message: 

 

One of the directories/folders in the file address used a huge number of characters (43). We shortened the name and all file exports worked thereafter.

 

It might be worth noting that when the directory/folder name was long, some Sheet Layers exported successfully sometimes but one Sheet Layer never did. After shortening the directory/folder name they all exported 100% of the time.  

  • Like 1

Share this post


Link to post

If it helps anyone for the future I also had a long filename trying to save to a folder with commas (on a network share) which threw up the Teigha Library error.  After keeping the long filename (48 characters) but switching to a folder without commas on my desktop, it worked fine

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×