Jump to content
  • 1
Taproot

Skylight Bug

Question

We've found some challenges with transitioning from 2017-2018.  Today it's skylights.

 

Create a roof, insert a standard Velux skylight symbol from the default libraries and then display in 3D.

It looks good, normal, etc.

 

Then create a viewport to display the roof with said skylight.  Even with every class turned on, the skylight disappears.

Return to the drawing layer and it's back.  Enough back and forthing and the skylight will eventually disappear on the drawing layer as well.  It's still there ... mousing over it will reveal it's lines but for all practical purposes it's invisible.  It's not a class visibility issue so ....?

 

The problem persists in a new empty file.

 

Drawing

5a04e2b74699c_DrawingLayer.png.7115a248ed9974a956a5f0077c917564.png

 

Viewport

Viewport.png.dc620355f2bb583d84c9d9c261ee43fc.png

 

Drawing (after a while)...

5a04e3202f93d_DrawingLayerafteraWhile.png.70125492e279f3ac2f41f28bab145661.png

 

Using 2018 service pack #1

Mac Pro ....

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0
3 hours ago, rgcn said:

I have run into this problem today

 

Have you updated to SP2? It included a fix for this roof issue

Share this post


Link to post
  • 0

I thought this might be classes but you say they are turned on (in the VP?)

 

Can you confirm - this is a new 2018 file, or is it something created in 17 and now opened in 18? - Just so we have the complete background to this.

 

I can't replicate this. Can you upload the file? (or a test)

Edited by Gadzooks
can't spell!

Share this post


Link to post
  • 0

Gadzooks,

 

Yes, all classes are turned on in the VP.  Our template was created prior to 2018 and brought forward.

I've tried this in a new blank file as well, and the problem persists.  I'll attach it to this note.

 

Thanks for looking into it.

 

Skylight.vwx

Share this post


Link to post
  • 0

Taproot - Thanks, your file was what it needed. Mind you - Thats a few hours I'll never get back.

 

I tried all sorts components/textures/classes you name it I think Ive got through the lot. Bottom line - I think its a bug.

 

If I create a roof your skylight sits in and displays in the VP. There's certainly nothing wrong with the skylight so its the roof.

 

It seems using a roof face is the issue. To test I also created a 4 part (default) roof and then adjusted the sides to leave it mono pitched as your roof face - and this works fine. I obviously also tried a roof face from scratch and that had the same fault.

 

As an extra - I exported your file as v2017 and opened it with 2017 - No issue so this appears to be something introduced in 2018.

 

Interestingly (possibly for the VW boffins) if you then open the v2017 file in 2018 its happy with 'roofs' coming full circle, but can't resolve your roof face at all and makes a mess of it - resizing and moving.

 

For the moment I think you'll have to stop using roof faces (with bound symbols) and try to get by with roofs or maybe a work around is just to punch the hole first and then place a skylight 'by hand'. I didn't try that, but I would imagine it will work as the skylight won't be a roof face element anymore.

 

Hope this helps. Others might find a different cause.

Share this post


Link to post
  • 0
19 hours ago, Gadzooks said:

..........maybe a work around is just to punch the hole first and then place a skylight 'by hand'. I didn't try that,.......

 

Thought I would test this out and as I thought it does give what you want in the VP. It doesn't really take much time to follow this process.

 

If you want you can still place the symbol but choose to check the box 'do not insert symbol' (another misleading instruction) this will at least create the correct hole size for you.

 

5a08339eb1819_ScreenShot2017-11-12at11_36_57.thumb.png.123c0c37d79a8e39325645b182d86a58.png

 

You'll still have to deal with the 'clunky' offset options if you need to move the hole slightly, but you do gain the option to cut the hole with your choice of vert/splayed/square edges which is a nice touch.

 

Still needs fixing though (unless I've missed something).

 

I think you should submit to Bugs.

Share this post


Link to post
  • 0

Gadzooks!

 

Thanks for taking the time to confirm this and develop a work around. 

I think we'll follow your advice for now and either just clip a hole in the roof slope or use the skylight tool to do it.

 

I think the "troubleshooting" forum where this is posted is designed for bug submittal.  Let me know if you know something different.

Share this post


Link to post
  • 0

HTH - I'm learning too!

 

You could use the link below this thread

 

Support > Bug Submit.

 

But I think what's asked for is a bit of a 'faff' considering the detail a lot of threads have gone through before we raise it with VW boffins. It would be easier to just use a thread reference, but I'm not aware the system exists. 

 

 

Share this post


Link to post
  • 0
Just now, Gadzooks said:

But I think what's asked for is a bit of a 'faff' considering the detail a lot of threads have gone through before we raise it with VW boffins. It would be easier to just use a thread reference, but I'm not aware the system exists. 


it is REALLY annoying to use and we plan to improve it. Apologies for it being necessary in the meantime, working on something better.

Share this post


Link to post
  • 0

I have run into this problem today.  I see if I export to 2017, the skylight shows up in elevations, and sections.

 

Rob

Share this post


Link to post
  • 0
5 hours ago, Taproot said:

I'll install SP#2.

 

Sorry Taproot - I should have copied you. 

 

Hope it works OK  for you. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...