Jump to content
Tom Klaber

"-" Needs to be considered when arranging classes alphabetically.

Recommended Posts

To me this is a bug.

 

But the class list does not recognize a "-" as a character - which messes up the list something fierce.

 

For example, I have these classes:

 

  1. E-Circuits
  2. E-Lighting Fixtures
  3. E-Outlets
  4. E-Switches

 

This is how I would expect them to be listed.  BUT Here is how they are actually listed:

 

  1. E-Circuits
  2. E-Lighting Fixtures
  3. EL-1_.05-FAR
  4. EL-2_.13-LIGHT
  5. EL-3_.18_NEAR
  6. EL-4_.25_STRONG
  7. EL-5_.35_CUT
  8. EL-6-.7_GRADE CUT
  9. E-Outlets
  10. E-Switches

 

So VW is clearly ignoring dashes when it creates this list - no good. 

Share this post


Link to post

I assume this is in non-hierarchical view and in hierarchical view they show correctly?

 

Still, it is not how it should handle dashes, this definitely seems a bug to me.

Share this post


Link to post

I can't duplicate your Els sorting into the middle of the Es. Can you post a small file with those classes so we can take a look?

 

Many years ago (perhaps Minicad 7 or VW8), the idea of hierarchical classes was added. At that time the design decision was that to create a hierarchical class you would use a dash to separate the different parts. Not the best design decision, but a reasonable one 15 years ago. Not so reasonable today. BUT, this is so ingrained in so many drawings around the world, that it will be difficult to change the behavior and use of the dash.

 

Work around:  only the use of the en-dash (short) - caused the hierarchical display. For most uses you can use the em-dash (long) – as a separator and you will not get the hierarchical display.

 

Now, I know what comes next "But my customer has specified the names and I have to use them." OK, then do as Art suggests and turn off Hierarchical. Or use em-dashes and I will write you a script that you can use to rename all the classes to en-dashes for export and then rename back to em-dashes for in-house use.

 

I agree there should be a better way, but it has to be a way that does not screw all the people who using the existing functionality.

 

 

Share this post


Link to post

I now realize I am only seeing it when I go to the Veiwport Class Visibility Settings.  Make a viewport and check the class list there.

Share this post


Link to post

Still not seeing it. I created all of the classes in your list by copy/paste into new classes. 

 

In the Navigation Palette, Organization Dialog Box, and the Viewport Class Properties dialog box, the EL always are separated from the E.

 

BUT, if I change the en-dash in E-Outlets and E-Switches to an em-dash, then I get what you are seeing.

 

 

Share this post


Link to post
5 minutes ago, Pat Stanford said:

BUT, if I change the en-dash in E-Outlets and E-Switches to an em-dash, then I get what you are seeing.

 

Interesting.

So that would also mean that the wrong thing would also prevent from proper hierarchical display .

 

BTW,

which of both would be the NumBlock minus,

in case I would run into sorting problems ?

 

And as always,

I repeat that I would like to set other separators, like "blank" or "underscore"

Share this post


Link to post
1 hour ago, Tom Klaber said:

What is the difference between and en and em dash?

 

1 hour ago, zoomer said:

which of both would be the NumBlock minus,

 

The en  dash has the with of the character N (uppercase) and em dash has the width of the character M (uppercase)  (typographically speaking).

 

The minus sign on our keyboard is the hyphen.

EN-dash is slightly wider than the hyphen and the EM-dash is slightly wider than the EN-dash.

 

Often the minus key is both hyphen and N-dash, when typing in e.g. Word you can sometimes notice minus sign gets replaced by a slightly wider dash, which is the en dash if there as a space before and after the dash and the em dash if it links two words (i.e. no space around the words and dash)

Share this post


Link to post

Art is correct. On the Mac, the em-dash is created using Option-Dash. the en-dash, just the dash or minus sign with no modifier.

Share this post


Link to post

There are 3 characters to be aware of when typing "dashes": - Hyphen (also called Dash or Minus Sign), – en dash, and — em dash.

 

In Western Mac OS encoding (single byte characters):

Hyphen, ASCII 45, Hex(2D), Hyphen key

en dash, ASCII 208, Hex(D0), Option-Hyphen key

em dash, ASCII 209, Hex(D1), Shift-Option-Hyphen key

 

In Western Windows Latin 1 encoding (single byte characters):

Hyphen, ASCII 45, Hex(2D), Hyphen key

en dash, ASCII 150, Hex(96), type Alt-0150

em dash, ASCII 151, Hex(97), type Alt-0151

 

In UTF-8 the Hyphen (Dash, or Minus Sign) is still #45, but the en dash and em dash are multibyte characters; Hex E2 80 93, and Hex E2 80 94, respectively.

 

Art mentions, "Often the minus key is both hyphen and N-dash", as seen in Word. Actually Word substitutes an en dash for a hyphen when a hyphen is typed, and that is a user preference that can be set, like substituting "smart quotes" for the singlequote and doublequote characters.

 

I'm not sure if this helps, but VW sees all three of these characters as being different and will sort them accordingly.

 

Raymond

Share this post


Link to post
11 hours ago, MullinRJ said:

There are 3 characters to be aware of when typing "dashes": - Hyphen (also called Dash or Minus Sign), – en dash, and — em dash.

 

I started working with computers in 1990, so it took me 27 years to learn this...

 

11 hours ago, MullinRJ said:

but VW sees all three of these characters as being different and will sort them accordingly.

 

So VW seems to be the nitpicker among CAD programs.... ;)

 

Edited by halfcouple

Share this post


Link to post

I am on windows and just use the _/- key next to the zero key.  What one is that - I think its the hyphen and the minus key '-' is on the number pad.  

 

Anycase - VW should see my next to zero key dash - it does other places - only in the viewport class visibility dialog am I getting the weird sorting. 

 

Can we BUG this?  Should be an easy fix.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...