Jump to content
  • 0
RussU

Really Cross with VW now.

Question

Ok. Big rant and massive plead for help.

 

File started to get large and then something unusual happened, which I've flagged long ago but still hasn't been addressed.

Normals are reversed on geometry, making the hidden line VPs look rediculous.

 

Performance dropped massively after replacing the symbols and trying to bug hunt. Had rediculous amounts of clipping of gfx in 3d views. Near and far geometry not displaying, zoom in a bit too far (like 50m away) and everything vanishes. Tried all the gfx compatibility options before I began running out of time.

Performance kept dropping, tried everything I knew before resorting to  heavy measures.

Removed vw preferences, as explained in previous posts... And it's asked me to re-enter the serial number. They're not held on this site or on the machines unfortunately. It stops people pinching serials.

 

Logged into VSS to get my VW designer 2017 serial, and it's not available as I don't have prividges as I chose not to update my VSS due to too many problems with the software.

UK support only open in office hours.

can't use a trial version of 2018, as I don't want to be locked into upgrading when the problem is resolved, and I don't have access to my software now.

Skyping into Middle East at 4am to present months of work to the board of directors and I'm utterly screwed. Lost 6 hours today, will lose the job altogether in the morning.... and have been working on it since January all in the run up to this date.

 

Why I'm cross?

I flagged flipped normals ages ago. not fixed

I flagged VSS not showing older licence numbers ages ago. not fixed

I paid a lot of money for software which still doesn't work.

I'm about to lose a contract worth 7 figures and I will get sued by my client.

not able to discover my serial online, in files, in registery or anything, and I'm very savvy in that respect.

 

 

Edited by RussU

Share this post


Link to post

13 answers to this question

Recommended Posts

  • 0

Do not post any Serials in public, as the might be burned now.

 

It is just 11 Minutes since you posted.

If@JimWsees this I am sure he could help in some way in a reasonable time frame.

If it is only by a temporary 30 day serial or such.

 

 

And you are not the only one who cares about correct face orientation and rants about this since years.

 

 

 

Share this post


Link to post
  • 0

Well, it's not the whole serial... just version and customer numbers in that.

I understand about the security of such items, but thank you for your concern. Have edited it out anyway as a precaution... they should get my customer number from my profile anyway.

 

A very handy UK man has loaned me a serial number to get me running tonight, and I owe him big time...  but.... even after prefs reset.... the normals issue and file performance is still there.

 

I'm annoyed because everything in my message has been flagged for so very long and nothing's been done!

 

I appreciate your support. The users are, as always, fantastic.

Edited by RussU
  • Like 1

Share this post


Link to post
  • 0

I think its good that its gone, as I am not sure which is the really interesting part of such a number.

Yes, lags or refresh issues are not what you wish when deadline near.

 

But it could be that the new Symbols to replace contain much more complex geometry (?)

Many of us have experienced lags with Symbol/Style replacement or editing.

But beside VW 2018 does not run worse than 2017 for me.

 

Fine that at least the Serial thing was solved or shifted.

Share this post


Link to post
  • 0

Well, in engineering models I have several levels of detail in my symbols, set by classes.

When looking at a general arrangement, I have low detail, and a nice quick re-draw. But zooming into the detail I switch on the high level of detail.

 

I developed up this symbol set in VW2015, and have never had an issue with it before.

The thing that broke this file was importing a 2016 file into 2017 and then copying and pasting one of last year's unique components into the 2017 file. Totally broke everything instantly.

 

These issues have been flagged by many, including yourself for years. The reversed normals is insane... I even tried to load a vwbackup file to get the "regenerating 3d geometry" message... but nope. Months of work... toileted.

 

I'm so pleased that those people that pay the ransom get the fixes, but in the UK we've always had a non-negotiation policy on such things. That being said, I am currently installing a trial of 2018, to see if these problems are fixed in that environment.

Share this post


Link to post
  • 0

Extrudes lower face's normals corrected ?

I don't think so.

As far as I remember I checked that again with VW 2018.

And I don't think that will ever be corrected or even is not possible

to correct in VW.

 

You can pack Extrudes into Add Solids Containers where you really need

correct face orientation. That will of course not work for PIO's like Stairs,

Windows (especially their glass panes), Slabs and such.

You need to repair everything in a 3D App, like by Optimize + Align Tools in

C4D or similar.

Edited by zoomer

Share this post


Link to post
  • 0

Well,

Installed 2018

got the SP1

 

And guess  what.... the problems are fixed. I'll put some screen grabs of two things in 2017... one extrudes and compound solids, the other a PIO staircase... look at it. Completely unacceptable.

But in 2018, it's fixed.

Will they implement these fixes back into 2017? Lets see.

 

VW_0000_Layer 2.jpg

VW_0001_Layer 1.jpg

Share this post


Link to post
  • 0

Hmmh,

have to look at this again.

But I am pretty sure that the latest project was already SP1.

And my Extrudes have 1 face flipped as always.

 

Also my DWG ACIS Solid Exports have still these funny 6 times tesselations.

Tested a few hours ago. And Meshes from Wall PIOs not welded = separate Polygons.

Share this post


Link to post
  • 0
53 minutes ago, zoomer said:

Hmmh,

have to look at this again.

But I am pretty sure that the latest project was already SP1.

And my Extrudes have 1 face flipped as always.

 

Also my DWG ACIS Solid Exports have still these funny 6 times tesselations.

Tested a few hours ago. And Meshes from Wall PIOs not welded = separate Polygons.

Ah. Sorry. I’ve not checked the export.

 

i was talking about native geometry generated inside vw having thier normals flipped. I’ll check.

 

but... try this. If your program has sketchup import, try exporting to 3ds format and importing into sketch up. It’s very important to go to import options and tick “merge coplanar faces” or its horrid.

 

i know it’s an extra step but the geometry is sound and stitched/welded.

 

also worth remembering that vw uses the Siemens parasolid natively. So you could try stp and iges. They’re parasolid files. On occasion though the file sizes are gigantic so it’s not perfect.

 

if vw exports flipped normals they won’t be welded anyway, which ever way you try

Share this post


Link to post
  • 0

VW almost always fails at the deadline. Not sure why, but its definitely happened to me a number of times so I can sympathize. And its almost always the longstanding bugs that resurface as it fails. My arch nemesis is the scaled symbol (NURBS surfaces). Its time all these longstanding bugs were resolved for good.

 

Kevin

 

 

  • Like 3

Share this post


Link to post
  • 0
14 hours ago, Kevin McAllister said:

Its time all these longstanding bugs were resolved for good.

Totally agree with this and have made similar comments in the past.  I'd be happy as a VSS subscriber if they would devote one year to fix these things as well as ad some missing things and not bring in new shiny features or just one or two if they improve on existing working features.

 

It would still feel as money well spent on VW VSS as it is basically a maintenance subscription with bonuses in the form of extra libraries etc. and fixing these issue would definitely fall within the maintenance part of VSS.

 

Doing this would make VW an even more viable proposition for people. I've seen with other software that people tend to shy away from considering that software if such issues matter to them even if it works nicely with a lot of other things from which they would benefit and I doubt it would be different for VW.

  • Like 1

Share this post


Link to post
  • 0
15 hours ago, RussU said:

also worth remembering that vw uses the Siemens parasolid natively.

 

(That's what I took for granted when I bought VW after going through the feature list)

 

Yes, in certain objects.

Correct me if I am wrong,

that is true for Generic Solids, Add/Substract Solids, ... and even some PIOs like Roof Tool and such.

But not at all for PIO's like Walls, Windows, Doors, Stairs, ... or Extrudes, SubDs and all such things.

 

Generic or "Boolean" Solids export fine. So do Meshes.

It is the native VW geometry that causes export problems for me.

 

 

There were some improvements of how such geometry will be displayed inside VW over the last Versions.

Like Slab's or Stair's Cut Surfaces appearing in Clip Cube or Sections.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...