Jump to content
Zeno

4-16 rebounds problems

Recommended Posts

hello everyone,

 

I have already tried to see in a test render file how the new 2018 renderworks engine work. I also noticed that in the Indirect Light options Vectorworks now allows setting16 rebounds. But not 8.

 

So I'm in a little Trouble, because:

 

-with 4 rebounds I see some circle on textures (not very good to see)

- with 16 rebounds there are too many reflections and the results are not how I expect. Here is an area with no light or similar, but it looks in 16 rebounds mode like an overpowered light (see the arrows)

 

Can I fix this?

 

PS: the pictures are in low res (50 dpi)

 

4-16 rimbalzi.JPG

Share this post


Link to post

The odd splotchiness of the light along the ceiling and walls usually means you may have:

1) A light object or glowing texture touching another surface. This has to be hunted down manually.

2) Not enough sources of light. Often this is a problem in interior scenes with no windows to the exterior to let environment lighting in.

However, another relatively easy way to remedy this is to use the 4 bounces, but add one or two point lights at central points within the scene. Turn their brightness down to 10-30% with NO falloff, and have them set to not cast shadows. This will let you artificially increase light without having to alter too much existing geometry or add other actual visible light sources.

  • Like 1

Share this post


Link to post

Before adding more lights, see what happens if you go into your render style and in the lighting tab change the ambient color to black while using 16 bounces.  This will darken the scene but still give you smooth results.

 

In the mean time I too will be looking into using 8 bounces.

  • Like 1

Share this post


Link to post

Thank you all for the answers,

 

before continuing to changes I have another question if I can.

 

I like to use camera effects (exposure and depth of field) mainly for a reason: I like to have the scene's brightness control with some realistic settings.

 

But I understand that if I I use 4 or 16 rebounds, the entire scene changes drastically.

 

I would like to understand if theoretically is better to work with 4 or 16 rebounds, to leave this setting fixed and work to others parameters (light power, camera exposition, background, texture's quality and so..). Without this certainty, there are too many changes to think about.

 

Can I continue with this belief or is better to change my working method?

Share this post


Link to post

Personally I leave it at 16 bounces all the time now and just adjust the indirect lighting quality instead, it tends to give me smoother and more realistic light and as you are, I am often controlling brightness with Exposure rather than with the render style settings themselves.

  • Like 1

Share this post


Link to post

I have attached my own approach to lighting along with the renders, explanations, and project file.

 

There are many different ways to get lighting just the way you want.  My example only illustrates my own method.

Archive.zip

  • Like 2

Share this post


Link to post
23 minutes ago, JoshP said:

I have attached my own approach to lighting along with the renders, explanations, and project file.

 

There are many different ways to get lighting just the way you want.  My example only illustrates my own method.

Archive.zip

 

Very important information. Very grateful JoshP! I will learn and thoroughly on my work and I will repost my implementation. Thanks a lot one more time :-) 

Share this post


Link to post

So i started from step one.. but

 

i had some problems to set

 

1) heliodon power (between 10 and 300 are no differences, in spite of openGL effect... i don't understand why)

2) camera time exposure and ISO (400 ISO and 1/60s exposure time)

3) HDRI panoramic image's brightness (i need to set it very very low  to have a balanced image, only 5%)

 

here is the result of step one.. are the settings correct?

 

 

Schermata 2017-11-02 alle 00.38.45.png

Schermata 2017-11-02 alle 00.40.58.png

Schermata 2017-11-02 alle 00.40.14.png

Schermata_2017-11-02_alle_00_39_42.png

Share this post


Link to post

If you are rendering an interior use the interior indirect lighting setting.  The interior setting gives a hint to the renderer to do more work that helps these scenes.  Normal (4 bounces) does not try to tune the settings for an interior, and the Exterior setting would be inappropriate for interiors.  It is not just the number of bounces that are being adjusted there.

 

The odd glows are odd.  For example around the red chairs.  Are there extra lighting sources in this scene?  I would not mess around with using camera effects in that scene until the lighting is behaving well.  Adding camera effects will just add to the confusion.

  • Like 1

Share this post


Link to post

 

Thank you for the answer

 

5 hours ago, Dave Donley said:

If you are rendering an interior use the interior indirect lighting setting. 

 

i just tried to follow the JoshP steps and on the first step (OMG.. never stop learning :-D ) i

 

had some problems because i had see that on step 2 will I turn on the indirect light so I tried to do the step one without indirect light

 

The problem with the solar power disappear if i use indirect light and i can set the parameters and see the differences. But i don't understand why if I set the indirect light to OFF and i use a Heliodon i can't set the differences between power 10 or 300 on OIP, but is not important at this point.

 

I will go to see into the file the render style settings to better understand

 

Share this post


Link to post

To better explain what i mean:

 

the 2 viewports have the same settings, only a heliodon light (power 100%)  and a HDRI day background (power 100%). The second one had the camera exposures set to ON and 1/100 s + 400 ISO parameters.

 

How could I have a correct light power control without the camera settings (like the viewport 1?) ? I think that the only way is without using Heliodon light.

 

What do you think about it?

 

 

 

Differences.png

Share this post


Link to post
15 hours ago, JoshP said:

I have attached my own approach to lighting along with the renders, explanations, and project file.

 

There are many different ways to get lighting just the way you want.  My example only illustrates my own method.

Archive.zip

 

Can i ask you if is necessary to turn ON the blurriness option? Does it increase drastically the render time?

Share this post


Link to post

No, unless you have a renderworks texture that uses blur.  A texture such as smoked glass.

 

 

Screen_Shot_2017-11-02_at_9_50.40_AM.png

  • Like 1

Share this post


Link to post
5 hours ago, Zeno said:

Does it increase drastically the render time?


And yes, enabling blur and raising blur quality will dramatically increase render time. 

Share this post


Link to post

Ok, at the moment I have these 2 results:

 

(150 DPI 35cm*21cm viewport 16 rebounds)

 

- The first one without ambient light, only indirect light: the scene is more realistic (too dark I think) but the odd splotchiness are there.. 10 minute render time

 

- The second one had the ambient light set to ON, the scene is cleaner but too fake...

 

I prefer to set the ambient light to OFF, but really need I to use another light or could be better if I increase the existing light power? Off course I prefer to have brighter scene, but is more important at the moment to delete the splotchiness (what appened if i will really need a dark scene? ) 

 

I really hate these spots! :-)

 

Thank to all

 

PS: another question

 

during the calculation time, sometimes the WIP render picture, that normally starts in black and going to the final results like in a Matrix view, is totally white up to the final results... someone knows why?

 

 

 

Schermata 2017-11-02 alle 16.39.16.png

Schermata 2017-11-02 alle 16.39.21.png

Share this post


Link to post

My recommendation for avoiding those spots on textures:

 

Even if you have 16 bounces you still need to increase your rendering settings to high.

Share this post


Link to post
5 hours ago, Luis M Ruiz said:

My recommendation for avoiding those spots on textures:

 

Even if you have 16 bounces you still need to increase your rendering settings to high.

 

Yes. 

 

In this case (a file coming from 2017 version) some lights needs to be replaced on the new version. Now I’ve reached a better result (even with a low light in the scene) about thr spot on textures. I hade some problems to have good results only with a daylight from background or/with a heliodon light.  I continue to work with camera exposure set to active but the scene is always dark. I will post the results soon. Thank you for your help. Ps: i don’t like to use a “fake point light” or ambient light, but i’m starting to think that i will need to use them with a camera exposure. 

Share this post


Link to post

Are you using the depth of field in the Renderworks camera?  If so, what F-Stop setting?  If you use something low, like f/4, and set your focus distance to where you want your subject to be, or roughly the center of the room, it will give a nice subtle blur to objects in the foreground and background without hurting the rendering time much.  Make the light coming in from outside abit stronger, add some lit fog to your background, and I think it will add abit more realism.  Lit fog will hurt your rendering time though.  To dial it in more efficiently, duplicate your existing viewport and keep all the settings, then crop the duplicated viewport down to a very small area that just has the area impacted by the lit fog, like where the sunrays will be.

Share this post


Link to post
On 1/11/2017 at 3:22 PM, JoshP said:

Before adding more lights, see what happens if you go into your render style and in the lighting tab change the ambient color to black while using 16 bounces.  This will darken the scene but still give you smooth results.

 

In the mean time I too will be looking into using 8 bounces.

 

Hello everyone...

 

I just restarted to set some renderings on the scene. 

 

Actually, i use a very high background (up to 5000% brightness) and a render style without a camera. I find the internal light good but I need to replace some texture etcetera. No more light on the scene. But some spot are here... and I need to understand how can I remove it to continue my work.

 

Does it depend only on the texture of the window part?

 

Thanks a lot

 

Z

 

 

Schermata 2018-01-24 alle 14.59.02.png

Schermata 2018-01-24 alle 14.58.59.png

Schermata 2018-01-24 alle 14.58.35.png

Schermata_2018-01-24_alle_14_58_22.png

Share this post


Link to post

The first thing I would suggest is that on your glass textures for the exterior windows and doors, make sure you edit the texture, click Indirect Lighting Options and make sure Portals is checked. This helps environment lighting pass through them as desired to light the spaces within. I also often use a solid color of white or very light blue/yellow for the Environment Light background, and then use separate backgrounds for the normal and reflectivity backgrounds, this seems to give me the most light for the lowest brightness values.

However; having any light source, including environment light, set to such a high value like 5000% can cause this spotting effect regardless of quality settings. A better solution that shouldn't cause artifacts would be to lower the Environment brightness, (i generally never increase a light source to anything over 400%) and instead add a Renderworks Camera to the scene, match it to the desired view, and then enable Exposure.

 

This lets you get the light you want by increasing or decreasing ISO and shutter speed, (I mostly just play with them until I get what I want but I am told they match actual camera settings) without having to use values that cause problems like this spotting.

 

Share this post


Link to post
27 minutes ago, JimW said:

The first thing I would suggest is that on your glass textures for the exterior windows and doors, make sure you edit the texture, click Indirect Lighting Options and make sure Portals is checked. This helps environment lighting pass through them as desired to light the spaces within. I also often use a solid color of white or very light blue/yellow for the Environment Light background, and then use separate backgrounds for the normal and reflectivity backgrounds, this seems to give me the most light for the lowest brightness values.

However; having any light source, including environment light, set to such a high value like 5000% can cause this spotting effect regardless of quality settings. A better solution that shouldn't cause artifacts would be to lower the Environment brightness, (i generally never increase a light source to anything over 400%) and instead add a Renderworks Camera to the scene, match it to the desired view, and then enable Exposure.

 

This lets you get the light you want by increasing or decreasing ISO and shutter speed, (I mostly just play with them until I get what I want but I am told they match actual camera settings) without having to use values that cause problems like this spotting.



 

 

Thank you Jim, i will repost it with the updatedet settings

 

How about using non total white color?

Share this post


Link to post
14 minutes ago, Zeno said:

How about using non total white color?


I usually advise not using perfect white or perfect black as they can behave a little strangely, but you only need to tweak this slightly to avoid it. For instance, using the Cool White or Warm White from the standard colors for "white" or using a 99% grey for "black"

Perfect white can sometimes bounce strangely creating flashes or odd washed out colors. Black has the opposite problem, where it does not allow ANY wavelengths in the spectrum to bounce off it properly.

Share this post


Link to post

Some splotchiness are going away buth some are remaining

maybe a 3D geometry problem for the windows?

 

 

Cattura1.JPG

Share this post


Link to post

If you place a point light object in the center of the room (just unrealistically floating in the middle of the room, not like a lamp or fixture) disable cast shadows and set the falloff to None, and then set its brightness to perhaps 30%, it may give another source of light that shouldn't interfere with the environment lighting and existing shadows.

(This is a workaround for us not yet being able to increase indirect lighting bounces higher than 16 which I think would also cure these splotches.)

Share this post


Link to post

I'm just tring some different settings. I had a very big problem. Every metal shaders worked like a light, even at 5 % brightness. 

 

look at picture attached: both have the SAME settings, exept for metal texture settings of sittings (you can see something similar a light on the kitchen: it is a metal part)

 

how is possible to manage it? it works well?

 

 

 

 

Cattura.JPG

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...