Jump to content

Troubleshooting on Project Sharing - The commit operation cannot be performed now because the Project File is in use by another user.


Recommended Posts



I've got a project set up on Vectorworks Project Sharing.  Currently I am the only user on the project.

When I tried to save and commit my individual file to the main file, I get an error that reads, "The commit operation cannot be performed now because the Project File is in use by another user - You need write access to Project File in order to commit your changes.  However, the Project File is temporarily locked by the operation of another user.  Your operation should succeed if retried in a few seconds." 


I have tried to open the main file, then 'close and release' to solve the problem, but the same error message still pops up when I save retry saving and committing my individual file.


Can anyone help me work out why this is the case?


Thanks for your help in advance!


Link to comment

Where are your files located? The recommendation here was that the working file should be stored locally, and the project file on the server.


BTW if you (or anyone else) open the main project file, VW will always create a new working file for you from it. You should only open your working file when you work. Maybe there is some duplication happening that confuses the system?  Accessing the project file under different credentials eg. on an office desktop computer or on a home laptop will create two working files, if the logins are different.



Link to comment

We are also having this problem in our office - Right now I am the only person working on the project sharing file, everyone else is out to lunch (and have closed the file). I'm still getting '...cannot be checked out now because the Project File is in use by another user...' - repeatedly in fact.


Update: I've tried saving the Working File locally as suggested by @JMR- But still having the same problem

Edited by Asemblance
Link to comment

We've had the same problem in our office this morning. It's very frustrating. We tried a few different methods to dry and resolve it, listed below, but the only solution we could find was to to do as @JMRsuggested and "Save A Copy As..." a standard .vwx file and re-build the project sharing files from scratch. Particularly frustrating if not all users have committed all their unsaved changes before this issue arrises.


Options we've tried that don't work:

  • Delete the working file and try re-creating it by opening the project file
  • Deleting the user from the project sharing dialog and get them to start their own files again
  • Opening the working file and clicking revert int he project sharing menu
  • Saving the working file locally
  • Resetting document preferences in the project sharing dialog box

It feels like there should be something like a "reset/release all current activity and check out all objects" option to repair whatever is becoming corrupt in the project file.

Link to comment
  • 11 months later...
  • 1 month later...
  • 2 years later...
  • 1 month later...

I'm using VW 2021 SP3 and still having this issue. I saved, committed to the project file, closed and released my work last night


I was working on this project for the last couple of weeks and everything was going really well. Today morning when I started to modify the object that I've created in the same machine that I've used for the last couple of weeks I'm getting this error. Attached screenshot (FYI I'm the user 'rishie' and I'm using in the same machine and same login)


Please note that last night the working file crashed while I was working so I took the backup working file from my machine and overwritten it to my original working file. Also, I saved and commented on my work to the project file later. Is this activity connect with the above issue somehow?


How can I move forward now?


I've restarted my machine, created a new working file from the project file with no luck yet


Thank you,



1356106694_Screenshot2021-06-25at9_23_44AM.thumb.png.21096b61447b193b008cff9ad0fd1bde.pngI remember checking out 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...