Jump to content
Sign in to follow this  
Bertf

Dashed line on 3D plane shown as full line in section viewport

Recommended Posts

Hi all,

 

When I draw a line on a 3D plane with line type set to dashed:

59f19d6196212_2017-10-2610_29_49-VectorworksArchitect2017-1200_FEDE-001-001_vwx.png.5a1f316c225058761f9237d71c3ec0f5.png

 

And I create a section viewport that shows this line (hidden line render mode), I get the following result:

 

59f19d62037c0_2017-10-2610_30_07-VectorworksArchitect2017-1200_FEDE-001-001_vwx.png.e836c53fd8cf351779e18c5e25ff2fcf.png

 

Anyone has an idea how to display this line as a dashed line in the section viewport?

 

EDIT: Design and Sheet layer have the same scaling set (1:10)

 

 

Thank you,

Bert

Edited by Bertf

Share this post


Link to post

Vectorworks will not automatically interpret a dashed line as a hidden line because it has a dashed linetype.
It will represent a line/object as a hidden line/object if there is some other object covering it (be it on top, in front etc.).

Also you need to set the rendering to dashed hidden line if you want hidden lines to show as dashed.

You may want to create a very thin solid representing the dashed area and then another very thin solid on top of it to make it show as a dashed hidden line.

 

However, if this is just a line in a 3D plane, did you check "Display planar objects" in the object info palette for the viewport properties?

Also check if "Display objects beyond view plane" is still selected (it is the default, so I assume it is).

 

  • Like 1

Share this post


Link to post

It is indeed just a line in a 3D plane. Both the options are checked:

 

59f218426f9ce_2017-10-2619_15_35-VectorworksArchitect2017-1200_FEDE-001-001_vwx.png.69ffe4aed7d9def56efee7428859440e.png

 

 

Edited by Bertf

Share this post


Link to post

I've been having the same problem in Vectorworks 2018. In VW2017, I could make objects in a section/hidden line viewport display dashed by making sure they were set to use class attributes. However, this no longer seems to work in VW2018.

 

See this thread for an example:

 

Share this post


Link to post
21 minutes ago, tsw said:

I've been having the same problem in Vectorworks 2018. In VW2017, I could make objects in a section/hidden line viewport display dashed by making sure they were set to use class attributes. However, this no longer seems to work in VW2018.

 

See this thread for an example:

 

I can get a dashed linetype to appear in a section viewport if both options (show planar objects and show objects beyond viewport) are active and the line is covered by something else. However if the dashed line is not covered by something it will show up as a solid line in the hidden line and dashed hidden line renders but as dashed in e.g. wireframe.

 

See attached example for settings and object positions where the dashed line is not covered by something else. One sheet shows where a dashed planar line is covered and it shows as dashed, the other sheet shows where the dashed line is not covered by something.

Dashed hidden line rendering example.vwx

Share this post


Link to post
1 hour ago, Bertf said:

It is indeed just a line in a 3D plane. Both the options are checked:

 

59f218426f9ce_2017-10-2619_15_35-VectorworksArchitect2017-1200_FEDE-001-001_vwx.png.69ffe4aed7d9def56efee7428859440e.png

 

 

Yes, that is ok. However, your dashed line is not covered by something so it will render as a solid line in (dashed) hidden line view in 2018 (will have to check for 2017 later as I don't remember for sure about 2017 in this particular case), see the example in the reply to TSW's post above.

Share this post


Link to post

Here's another quick test file. I can get the look Bertf is going for in VW2017, but when I open the same file in 2018, the previously dashed line renders solid. Is this happening for you too?

 

Screenshot of how the Hidden Line viewport looks in 2017 (vwx file also included):

 

dashed line.jpg

dashed line test v2017.vwx

  • Like 1

Share this post


Link to post
33 minutes ago, tsw said:

Here's another quick test file. I can get the look Bertf is going for in VW2017, but when I open the same file in 2018, the previously dashed line renders solid. Is this happening for you too?

 

Yes, I do get the same solid line issue in VW2018 and in VW2017 it shows as per your screen shot.

 

I used a colour override for the dashed class and in some render option it shows the colour and in some it doesn't. I'd file this as a bug report as there is something odd with the rendering compared to VW2017.
The help documentation shows no differences that could explain this as far as I can tell.

  • Like 1

Share this post


Link to post

Thanks for taking a look at the file and confirming it happens on your machine too. Good to know it's not something specific to my set up! I submitted the bug report with a link to this thread.

Share this post


Link to post
10 hours ago, tsw said:

Here's another quick test file. I can get the look Bertf is going for in VW2017, but when I open the same file in 2018, the previously dashed line renders solid. Is this happening for you too?

 

Screenshot of how the Hidden Line viewport looks in 2017 (vwx file also included):

 

dashed line.jpg

dashed line test v2017.vwx

 

 

Thanks TSW!

Indeed it works by changing the pen style of the line to class style and changing the pen style of the class to a dashed line. I see the dashed class dashed in the hidden line section viewport (in VW2017).

Although it's strange that it doesn't work when just changing the pen style of a specific line...

 

Share this post


Link to post

I've tested your file and have the same result as you: dashed in VW2017. Full line in VW2018. 

 

I've also noticed the following strange behaviour in another file I've added:

Design layer scale is set to 1:20. And when looking at the design layer in top plan I see the following:

59f2ccc0d3748_2017-10-2708_04_51-VectorworksArchitect2018-test_dashed_vwx.png.0ea36ef6aae001a993e8a581236d27ba.png

in ISO:

59f2ccc161bb2_2017-10-2708_05_13-VectorworksArchitect2018-test_dashed_vwx.png.2e291346098ef57d15d3b9d57d480208.png

TOP:

59f2ccc1d04b9_2017-10-2708_05_31-VectorworksArchitect2018-test_dashed_vwx.png.29b91b47ad582f615d8d1b993410c1bd.png

 

In the top and iso view, the dashed line is not shown as properly as in the top/plan view. 

I don't have this issue in VW2017:

59f2cd7a3e3c6_2017-10-2708_08_37-VectorworksArchitect2017-test_dashed_v2017_vwx.png.bc1ec4d00f41cbcb1021ef70d1323970.png

 

 

test_dashed.vwx

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...