Jump to content
  • 0
mike-h

Import PDF issue VW2018

Question

Anyone else having trouble importing pdf files into 2018? Even pdfs exported/ published from the same file throw up the 'unable to import' window shown. This is quite irritating, can't really see what I can have done wrong as its only a 2 step process - drag & drop or Import have the same result. I have restarted VW and my machine. Running SP1.

Screen Shot 2017-10-24 at 12.03.52.png

Share this post


Link to post

Recommended Posts

  • 0

I have not, could you please attach any one of the PDFs that gave you this error? If it works here, we can reset your preferences.

Share this post


Link to post
  • 0
4 minutes ago, mike-h said:

Example attached here...

17-126-Model-3D yard.pdf

The file imports without issues in my windows version of VW 2018 SP1. The PDF itself seems to be ok as there are not particular settings such as PDF/A, password protection etc. that might interfere with import.

Share this post


Link to post
  • 0

Thats odd, I haven't been able to import any PDFs, from VW or not, certainly since update to SP1 (I can't remember if I did any before that). I've had to save images as jpeg just to get them into the file to get the work done. Never had any problems with 2017.

Share this post


Link to post
  • 0

Looking at it now I have a file where I have imported pdfs (I guess before SP1), which are still showing fine on the sheet layers, but if I try to reimport the same pdf it kicks up the same error message.

Share this post


Link to post
  • 0

Backup/reset your preferences as described here with Vectorworks closed:
 


Then, reboot the machine and retry the import. If it still fails, get in touch directly with tech@vectorworks.net.

Share this post


Link to post
  • 0

Thanks Jim, that worked - great.

Its a bit worrying that the article doesn't suggest backing up your preferences first (theres a reference to a link in a comment at the end, but I couldn't see it). Elsewhere we're told to use our User folder to keep title blocks, templates etc. safe from updates, but the instruction "4) Throw away the "20XX" folder found in 'HD > Users > (User's Home Folder) > Library > Application Support > Vectorworks' " could wipe all that out if you didn't know. Fortunately I keep a copy of all (hopefully) that sort of thing elsewhere, 'just in case'. Worth a caps lock warning at the top of the article, I'd have thought?

 

Cheers

Share this post


Link to post
  • 0

It said that and linked to it in italics near the top of the article as well, but I have now made that text bright red to increase visibility.

Share this post


Link to post
  • 0

Thats better :) I think in all these things the danger points need robust highlighting as its so easy to miss something even when you think you're reading carefully (especially when your used to skimming over irrelevant paragraphs ie. different OS etc.)

Share this post


Link to post
  • 0

This has immediately reoccurred as an issue on the first job this morning. Ho hum, off to Tech support we go.

Share this post


Link to post
  • 0

Hi mike-h, 

 

Id be very interested to know if you found a solution to this issue with the PDF import-   Finding a similar situation here on VW 2018 SP2 -  All fine on my 2017 version but with 2018 application I receive exactly the same window response to 90 % of PDF files on my system . Seems strangely indiscriminate - some small number will import , most will not . 

 

The reset of Preferences was finally a solution ? 

 

D

Share this post


Link to post
  • 0

Did anyone solve this problem? I am having the same problem. And it's got my work stopped dead in the water for using 2018. At first I opened at 2017 file with a linked PDF. It was missing on my design layer. So I deleted the file using the Organization tool and tried to re-place the file. No luck. This is a very big problem for me. I also tried different version of PDF 1.4 v 1.7 for the original file generated from Adobe InDesign.

Share this post


Link to post
  • 0

Hi Scott, 

 

Have been unable to resolve this issue - 

I have discovered - at least in my case - this issue occurs only with PDF files held remotely on 1) an external  server / 2) external disc .

As soon as I copy PDF to my local computer hard drive import process is as normal - Unfortunately ,  this is not always possible or the simplest thing to do .... 2017 VW Version has no issues similar to this with identical files and resources running on same hardware set up . 

 

I have been through various trial resolutions with UK Nemetschek tech support to no resolution - they have also forwarded details to Nemetschek techh support in US to no resolution -

 

Have also been advised and removed reset all VW Preferences to default - no resolution , 

 

It was suggested this had perhaps only to do with my particular computer / software set up - however,  the issue occurs with different computer set up to use identical external resources .

 

My final / last email from VW tech support was along the lines of 

"

At this point, I would go ahead and try an uninstall and reinstall of Vectorworks to see if it was anything related to the install itself. Hopefully that fixes it; however, I am doubtful it will impact this issue.

If the issue does persist after the uninstall/reinstall, can we possibly get system diagnostics from both the working and not working machines he tested with? My next guess would be a software such as a security based software or an automatic backup software that may be reading/writing the files and causing it to fail. With both system diagnostics, we can confirm what software is different between them and see if we can narrow it down from that."

 

As Im not aware of any such security / back up running on our systems which could effect this - I gave up at this point and decided to make do by other means . i.e. - copy the files to local disc before using . or use 2017 version . 

Share this post


Link to post
  • 0

Also - just to add  - 

 

as advised by Tech support in US (which I can easily believe ) - its very hard to define the problem - as little - nothing - has changed in PDF Import method / process between 2017 and 2018 VW Versions ..

 

Therefore , the issue lies not with the import process , rather with how application versions are reacting to reading various file locations on this particular system . 

 

 

Share this post


Link to post
  • 0
9 minutes ago, davidwd said:

as advised by Tech support in US (which I can easily believe ) - its very hard to define the problem - as little - nothing - has changed in PDF Import method / process between 2017 and 2018 VW Versions ..

 


Were they able to get your server file name/path and file a report?

Share this post


Link to post
  • 0

Thanks for the responses. I will do my best to help track down the problem but this one is a serious problem for my workflow. As an environmental graphic designer I work with a lot of imported files.

Share this post


Link to post
  • 0
2 hours ago, davidwd said:

As Im not aware of any such security / back up running on our systems which could effect this

 

time machine (?)

Share this post


Link to post
  • 0

We have the same problem when importing a pdf from the server.  When a PDF is on the desktop it comes in with no problem.

Share this post


Link to post
  • 0

Ok, here's what I've learned. Thank you, John, for the test idea. I have confirmed that this works with a PDF file on the desktop, or anywhere on the internal hard drive. Where it fails is when I am referencing a PDF file on my external drive, the main drive where all of my project files are located. So VW tech support…what say you? Feel free to contact me and we can work through this issue. For the record, I also updated to MacOS 10.13.2 (which I hope I don't regret, for other reasons). 

Share this post


Link to post
  • 0
On 04/01/2018 at 10:34 PM, zoomer said:

 

time machine (?)

 

Hi - 

 

No time machine running on the external drives I am using ( although all of these are encrypted - but as they are recognised and have permissions throughout system this should mean nothing )  .

 

and certainly not external servers - which for my working , are generally based in third party or contracted,  production / company office set ups  . 

 

At some point I will run through issues and/or results again , both on my Macpro and Laptop and with external drives / servers / and or flash drives used here. 

Share this post


Link to post
  • 0

Before JimW mentioned I had never thought about time machine could

interfere with files used by an App. But it sounds somehow logical that

only one task can read a file at the same time.

But I also never had problems with file acces. And I include my external

data SSD in time machine. So maybe things like time machine need to

do some extra voodoo to not interfere with work.

 

But that all problems disappear as soon as the file is on desktop looks

very much like any acces right problem.

Either really an access problem or more that something thinks it has

a problem while other tasks can access the file. Like in the past where

some tasks did not like special charecters in paths or misunderstandings

with differentiation uppercase vs lower case letters, ...

Edited by zoomer

Share this post


Link to post
  • 0

Further to the above item - 

 

Following recent work on a file held at remote disc - i.e. external drive - I note also that this file , although saving and backing up correctly , is never noted in recent items list under open menu . .. 

 

I will attempt a record of system profile again over the coming days and attempt to reach tech support again . 

 

David 

Share this post


Link to post
  • 0

Wow! I just looked back to this thread & now I wish I had 'auto notify of new replies' on - I was just abut to try (again, and no doubt unsuccessfully!) to reset my preferences as this is still a problem for me. Its irritating, but having looked at the thread the copy to desktop workaround works for me also. Strange though, as we have our files on a cloud storage, but there is a local copy of all files on my computer that I work from, and that is checked and backed up to the server - and I also have the desktop set to backup. Its technologically a bit beyond me I'm afraid, but happy(ish) with the workaround - at least compared to not being able to import! Just got to remember to delete those files off the desktop straightaway afterwards!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×