• 0
Wesley Burrows

VW 2017/2018 Cinema 4D Export Bug?

Question

I'm using VW Spotlight 2018 and now Cinema 4D R19 (this also happened in 2017 and R18)   I find that after 1 or 2 Exports to Cinema 4D or send to Cinema 4D commands,  the file exported is only 127KB vs 16+MB it normally is and of course won't import all the geometry properly.    The problem is briefly fixed after restarting VW,  it'll allow another 1 or 2 exports before doing the same thing.   This happens no matter which options are selected in the export dialog.   (And as far as I can tell these options don't really do anything,  VW's always seems to export as if all options are checked) 

 

Anyone else?

Share this post


Link to post
Share on other sites

22 answers to this question

  • 0

So far I did not notice something like this.

(beside if I forgot to set proper Layer/Class visibilities or to activate my saved view before export,

which btw I find quite tedious and error prone to need to do that way)

 

But my next Exchange is only hours away.

I will check that then.

Share this post


Link to post
Share on other sites
  • 0

Confirmed !!!

 

I am missing parts of my geometry after Exchange .....

Ouch,

that is a severe problem for me .... 27 hours in front of the deadline ....

Edited by zoomer

Share this post


Link to post
Share on other sites
  • 0

Looks like these where all Extrudes, often more than one 2D Element in them.

And they had an overall and a separate Material for their Top Face,

which I switched back to Overall recently.

Also I edited some of these and replaced some 2D nGons (24 sides Polygons) by Circles.

And created some Chamfers from a few (multiple-) Cylinders in Extrudes.

 

These were all gone.

Edited by zoomer

Share this post


Link to post
Share on other sites
  • 0

Never had, or had noticed that in VW 2017.

Tried a few times with additional Exchanges and double checked my settings,

but had to redo it from scratch at the end.

Share this post


Link to post
Share on other sites
  • 0

I'm glad you were able to confirm it.   When a render deadline is approaching and some last minute geometry changes are required,  having to restart VW nearly each time I want to re-export to C4D is irritating,  and it takes unnecessary time.

 

I am unsure of the proper bug submission channels.    Or if this is, indeed, the proper channel.

 

-W

Edited by Wesley Burrows

Share this post


Link to post
Share on other sites
  • 0
23 minutes ago, Wesley Burrows said:

I'm glad you were able to confirm it

 

Hah, I am not :)

 

 

24 minutes ago, Wesley Burrows said:

I am unsure of the proper bug submission channels.

 

If you have a file (not under NDA) which they can use to reproduce this,

an official Bug Report is much better of course.

http://www.vectorworks.net/support/bugsubmit.php

 

But I am sure @Selinlooks for such posts now and then ....

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, zoomer said:

 

Hah, I am not :)

 

 

 

If you have a file (not under NDA) which they can use to reproduce this,

an official Bug Report is much better of course.

http://www.vectorworks.net/support/bugsubmit.php

 

But I am sure @Selinlooks for such posts now and then ....

 

Whelp,  I tried to submit a bug through the bug submission form.  And funny enough.  I got an internal server error 500 on submission.   I'm not sure where you submit a bug about the bug submission form.    :-) 

 

 

Share this post


Link to post
Share on other sites
  • 0

That was mentioned in another thread and was said to work now (or soon) again.

Share this post


Link to post
Share on other sites
  • 0

Hey everyone! CineRender merging recently changed (it's annoying for me too :sigh: ) So I might have missed to check some cases. If you could send me your files and export dialog settings through DM,  or attach them here, I can take a look at them. Sort by class is usually the problematic one but the includes should work regardless of scene organization.

Share this post


Link to post
Share on other sites
  • 0

Unfortunately all NDA here.

Will see if I test with a private file again in a reasonable timeframe

(as I currently have to fight with Site Modeling)

 

1.

That larger geometry editing may be a problem, like converting 2 former Extrudes into a Add Solid and such,

as stated by Dave, is not nice but I can workaround by creating a copy and deleting the original geometry.

Didn't experienced that it previous Versions luckily, but good to know.

 

2.

I often voted to exclude object type exported parts naming and just use the Class Name, to better find things again.

That these names will not update ever after changes is not nice but also good to know.

(If I do a search for objects by name in C4D I will either miss some or change the wrong objects)

 

3.

Updating Objects Class assignment and so Materials worked reliable until VW 2018,

or at least I did not notice if not.

I think this is quite severe. As long as it does not work, Exchange is pretty useless.

I have no chance to re-check all objects that I might have changed Materials by Class and reassign them.

 

For me it is not clear 100% under which circumstances this fails.

Maybe activating Material import, for C4D input, may work nevertheless.

I did activate that for Exchange for the first time as I have 100% C4D imported Materials in VW.

I did not use Material active for Exchange Input, other than the first import, in previous projects at all

as I had all Material overwritten in C4D and got new Materials from VW or Materials Duplicates for new

objects into C4D anyway.

I switched that setting off at one point, to keep my my Materials sorting by Layers order in C4D

 

 

 

Share this post


Link to post
Share on other sites
  • 0

To further clarify.   In my case it still fails after one or two exports BEFORE merging in C4D.  There isn't a VW crash or any notification that VW is aware of the failure.    So say I have a VWX that is Project Master.vwx,    I export it to File A.c4d that ends up being 20MB and works great in C4D no problem,   Then I make some geometry updates/changes to Project Master.vwx and re-export a File B.c4d,   It's still around the same file size and also works.    Finally I go back and make a few more changes to  Project Master.vwx and export to File C.c4d and now the size is 16kb's and of course won't open correctly in C4D or merge correctly.   Any subsequent exports from VW to C4D produce a resultant .c4d in the KB range and will not work correctly until I restart VW again.   Then the process repeats.   

 

This would be using Export to Cinema 4D (3D Only) menu item most of the time,  but Send to Cinema 4D has resulted in the same behavior for me.

Edited by Wesley Burrows

Share this post


Link to post
Share on other sites
  • 0

OK, so this seems to be something completely different.

I have not noticed that so far but did not Export C4D many times after making some changes.

 

I just had FBX export attempts in the past with saving out 0 KB files without any warning,

just because I had Furniture Symbols included.

(VW or C4D FBX Exports do not support Symbols/Instances, other than C4D Export)

So VW may have decided to skip every geometry in the end.

 

 

Share this post


Link to post
Share on other sites
  • 0

These are the export settings I've been using.   When I've messed with Include in the past it hasn't seemed to make any difference.  If I uncheck camera's or backgrounds or something,  they still show up in C4D like they were included anyway.  (When the export works correctly)

 

59e4de16794fa_ScreenShot2017-10-16at11_27_10AM.png.20c1ba7bc6f354ba0e6b16742c3f118a.png

Share this post


Link to post
Share on other sites
  • 0

Same here, except :

Cameras, Lights; Backgrounds; Planar Objects => OFF

(As they do not have much value in C4D)

and

I use Custom made Render Style

Edited by zoomer

Share this post


Link to post
Share on other sites
  • 0
On 29.10.2017 at 2:34 PM, zoomer said:

Strange,

I miss half of my Texture Images in FBX Exports.

 

Confirmed.

 

New FBX export will include only 60% of image textures opposed to an C4D Export.
I see no difference between VW using true VW Materials vs using "C4D imported Materials".

Some Materials have textures while others won't.

Especially all Textures in the Reflection Slot (from Arroway Materials here) are missing in general.

Share this post


Link to post
Share on other sites
  • 0

Tech support has confirmed my export issues too,  but so far, only in the example files I've sent.   Working with engineering to figure out what's going on.    I'll report back when I hear more.

Share this post


Link to post
Share on other sites
  • 0
On 10/30/2017 at 2:24 PM, Wesley Burrows said:

Tech support has confirmed my export issues too,  but so far, only in the example files I've sent.   Working with engineering to figure out what's going on.    I'll report back when I hear more.

Well, the engineering would be me :) I haven't seen any bug reports about this or anything else from tech support. I can't reproduce this myself either, so my hands are tied.

 

I can only guess why merge might not be working with geometry changes. When you add solids, convert something to a symbol etc. you are essentially creating a brand new object and merging won't work. But, you're saying you are doing a fresh export every time so this exception would be irrelevant anyways.

@zoomer after you export a vwx file to cinema, can you please try to export that file from Cinema to FBX? Are the materials still missing?

Edited by Selin

Share this post


Link to post
Share on other sites
  • 0
Just now, Selin said:

Well, the engineering would be me :) I haven't seen any bug reports about this or anything else from tech support. I can't reproduce this myself either, so my hands are tied.

 

I can only guess why merge might not be working with geometry changes. When you add solids, convert something to a symbol etc. you are essentially creating a brand new object and merging won't work. But, you're saying you are doing a fresh export every time so this exception would be irrelevant anyways.

@zoomer after you export a vwx file to cinema, can you please try to export that file from Cinema to FBX? Are the materials still missing?

 

Hi @Selin.   I've been talking to Joseph Block,  he said he was able to reproduce the error with my file and forwarded it to engineering.   JIRA VSS-60589 

 

Share this post


Link to post
Share on other sites
  • 0
51 minutes ago, Selin said:

@zoomer after you export a vwx file to cinema, can you please try to export that file from Cinema to FBX? Are the materials still missing?

 

Sorry, meanwhile forgot what we were talking about.

Missing Materials or just missing Image Textures ...

 

 

52 minutes ago, Selin said:

When you add solids, convert something to a symbol etc. you are essentially creating a brand new object and merging won't work.

 

The only meaningful Exchange behavior I can imagine :

 

VW :

EXTRUDE_A, EXTRUDE_B

> Add Solids form both or create a Symbol or anything similar 

 

C4D :

EXTRUDE_A and EXTRUDE_B will be both deleted

ADDSOLID_NEW will be added

 

 

Everything else creates chaos.

 

Even if you had already done C4D Edits like replaced the Materials of EXTRUDE_A and EXTRUDE_B before,

bad luck, you will get ADDSOLID_NEW in and have to do it again.

But it does not make sense to neither keep EXTRUDE_A and EXTRUDE_B because of their edits in C4D

nor to not import ADDSOLID_NEW (with its VW Material)

 

 

But if you have :

 

VW :

EXTRUDE_A

> change geometry like adding or deleting a few rectangles inside in edit mode or edit extrusion height

EXTRUDE_B

> delete

 

C4D :

EXTRUDE_A is kept but get its geometry updated

(And so keep Material changes done in C4D)

EXTRUDE_B gets deleted.

 

 

 

There are a few more complicated situations to to argue (like changing Classes and Material Assignments)

but I think the easiest and most predictable way for an Exchange is a VW Priority.

(Inside the VW Exchange Folder in C4D)

If you change an Object's Class in VW it should also change its Layers in C4D.

If the Objects get their C4D Names from VW Classes and such, and Assignments change in VW, so also

their names in C4D have to be changed.

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0

My VW workflow is :

 

- All attributes by Class

- All PIO's or Symbols reside in their "Main"Class

- All attributes set by Components

- All Components get their attributes from their Class

 

 

So my Dream Exchange to C4D option would be :

 

- Each Layer creates a Group in VW Exchange Folder with its Layer Name

- Each Class creates a Subfolder in its Layers

- Each Class's SubFolder is named "LayerName_ClassName"

- Each Object sits in its Class Folder (which sits in its Layer Folder)

- Each object is named (only!) by "ClassName"

(If really necessary, then please "ClassName_ObjectName" for sorting by name)

- Each Class Folder has assigned the Class's Material (so applies to its parent objects)

- Each Object has assigned a C4D Layer by its Class

- All PIOs (like Wall with Windows in Walls) is not a own folder but components also spread

over the Class Folders like standard objects

- All Symbols are stored in the hidden Symbol Folder as it is now

- Each Symbol gets its own Group

- Each Symbol Group gets its "SymbolName"

- Each Symbol Group gets its C4D Layer from its Class assigned

- Each Symbol's content Objects get their "ClassName"

- All Symbol's content objects have their Material assigned by Object

- Each Symbol Instance gets its "SymbolName"

- Each Symbol Instance gets its Symbol's C4D Layer assigned

- VW does not change Image Texture's Names from original Image Name

- VW will not re-import Materials into C4D when there is already a C4D Material with same name,

but use the current C4D Material instead.

 

Same for FBX,

same Geometry and Structure Order (*)

except that the Materials need to be assigned by Object (like they currently do)

 

(*) FBX is able to keep Symbols and instances (see Modo and Maya)

Convert Instances to Geometry as an option only.

 

 

Beside those little general details, this is a bit similar to standard "by Class" Export,

but has the advantage that it does not lose the whole Layer Sorting.

And it makes it much easier to select, navigate and manipulate Elements in the 3D App in general.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now