• 1
markdd

Straight and Curved truss

Question

Any Spotlight users having problems making the straight and curved truss tools work in 2018 sp1?

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Yes.  After installing SP1 the straight/curved truss tools do not function.  This seems to only occur in a drawing started in VW 2017 and imported to VW 2018 first release.  Does not occur in a new drawing started in 2018 SP1.  Workaround for me was to simply copy and paste objects from a blank drawing or the existing drawing.

Edited by Industrial Event Services

Share this post


Link to post
Share on other sites
  • 0

Tech support in the UK suggested a reset of my user folder which fixed the problem. 

Share this post


Link to post
Share on other sites
  • 0

I'm having this issue. Existing trusses disappear if you edit them and I am unable to even select the Curved Truss tool. Each time I do VW reverts back to the selection tool. Nothing like unreliable software when you have revisions with a short turnaround window. I ended up ungrouping the correct size truss in VW2017 and importing the geometry into VW2018 to make things work. Sigh. SP1 is turning out to be less reliable than SP0. Doesn't anyone beta test before releasing anymore....

 

Kevin

 

Share this post


Link to post
Share on other sites
  • 0

I have had it sorted by tech support in London. Here is the routine. It’s a reset of the User folder:

 

Go to your VW preferences. In the user tab click the button that says “reveal in finder”. This will get you to the location of your user folder. 

 

Close Vectorworks

 

By default the user folder is called 2018. Drag it to your desktop leaving nothing behind. Vectorworks will rebuild the folder when restarting.

 

Restart VW. You will need to allow it to re register you so you will needs to be online.

 

A “fresh” version of VW will restart and the Truss tool should work now. 

 

After that I slowly rebuilt the user folder one folder at a time from the copy on the desktop, starting with the plugins and workspace folders. That pretty much got me back to where I was before. Restart the programme after every file restore. You will need to redo your user preferences again though which is a bit of a bore although there is an XML file for that somewhere which I guess you could also restore. Keep checking that the Truss tool still works though. I don’t know where the “corrupted” file is that caused the problem in the first place.

 

Edited by markdd

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, markdd said:

I have had it sorted by tech support in London. Here is the routine. It’s a reset of the User folder:

 

Go to your VW preferences. In the user tab click the button that says “reveal in finder”. This will get you to the location of your user folder. 

 

Close Vectorworks

 

By default the user folder is called 2018. Drag it to your desktop leaving nothing behind. Vectorworks will rebuild the folder when restarting.

 

Restart VW. You will need to allow it to re register you so you will needs to be online.

 

A “fresh” version of VW will restart and the Truss tool should work now. 

 

After that I slowly rebuilt the user folder one folder at a time from the copy on the desktop, starting with the plugins and workspace folders. That pretty much got me back to where I was before. Restart the programme after every file restore. You will need to redo your user preferences again though which is a bit of a bore although there is an XML file for that somewhere which I guess you could also restore. Keep checking that the Truss tool still works though. I don’t know where the “corrupted” file is that caused the problem in the first place.

 

 

 

I did what Mark is suggesting and it fixed it for me.

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, markdd said:

I have had it sorted by tech support in London. Here is the routine. It’s a reset of the User folder:

 

Go to your VW preferences. In the user tab click the button that says “reveal in finder”. This will get you to the location of your user folder. 

 

Close Vectorworks

 

By default the user folder is called 2018. Drag it to your desktop leaving nothing behind. Vectorworks will rebuild the folder when restarting.

 

Restart VW. You will need to allow it to re register you so you will needs to be online.

 

A “fresh” version of VW will restart and the Truss tool should work now. 

 

After that I slowly rebuilt the user folder one folder at a time from the copy on the desktop, starting with the plugins and workspace folders. That pretty much got me back to where I was before. Restart the programme after every file restore. You will need to redo your user preferences again though which is a bit of a bore although there is an XML file for that somewhere which I guess you could also restore. Keep checking that the Truss tool still works though. I don’t know where the “corrupted” file is that caused the problem in the first place.

 

Thanks Mark. I often follow those steps when VW acts up. I've already done it once for VW2018. This will be the second time hence my frustration. This year was the first time I used the Migration Manager. I only used it to move my 2017 workspace, nothing else, but I suspect this it the root of my problems.

 

Kevin

 

Share this post


Link to post
Share on other sites
  • 0

The steps outlined above did not resolve my truss tool problem, so I went the extreme route. 

 

- I have uninstalled VW 2018 completely.  

- Reinstalled 2018.  Changed no settings, nor loaded any Preferences. Kept everything default. 

- Tried Truss tool and it worked.

- Installed SP1. Once again, changed no settings, nor loaded any Preferences.

- Tried Truss Tool and it FAILED. 

 

Will have to uninstall and this time around will not update to SP1.

 

Any other suggestions? 

Share this post


Link to post
Share on other sites
  • 0

Thanks Markdd,

Resetting the user folder did allow the truss tool to work, as well as make older symbols visible that I created with the truss tool pf previous VWX versions.

I agree with Kevin though, this SP should have been reviewed and thoroughly tested to ensure everything is working properly.....

db

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now