Jump to content
Sinead V

Can a roof opening be edited or deleted??

Recommended Posts

Hi everyone,

 

I have a roof which was created by create roof and wanted to add a small gable roof to it. The problem now is once i create an opening in the main roof, how can i edit it or delete it things change? I find it strange I can't edit this void as we all know how elements in the design process change all the time! and can I extend the roof to meet the main roof? 

 

Thanks 

Share this post


Link to post

Without seeing your file (or a screenshot of the roof plan) it's hard to be sure. But I usually use more than one Roof, or Roof Faces for this type of thing. Another trick is to Ungroup the Roof, which will yield a number of Roof Faces. I find it much easier to edit and play with Roof Faces; you can Add/Clip Surface, etc. and you can duplicate one roof face and then rotate, edit, etc.

Share this post


Link to post

Sinead, it is possible to remove, edit and replace openings in a roof.  For anyone to give you useful advice, however, it is essential that you identify which version of VW you are using.

Share this post


Link to post
4 hours ago, CipesDesign said:

Without seeing your file (or a screenshot of the roof plan) it's hard to be sure. But I usually use more than one Roof, or Roof Faces for this type of thing. Another trick is to Ungroup the Roof, which will yield a number of Roof Faces. I find it much easier to edit and play with Roof Faces; you can Add/Clip Surface, etc. and you can duplicate one roof face and then rotate, edit, etc.

 

Thanks for your reply. I have attached a roof plan of what i'm trying to cut. I moved my gable roof so need to update the cut. I ungrouped the main roof but I still cant locate the opening to edit it. Is there a way to tab through the area to find the opening?

Vectorworks roof.png

Share this post


Link to post
1 hour ago, P Retondo said:

Sinead, it is possible to remove, edit and replace openings in a roof.  For anyone to give you useful advice, however, it is essential that you identify which version of VW you are using.

Hi Retondo, thanks for your reply. I'm using VW 2016. Still struggling to edit the roof opening!

Share this post


Link to post

Are you talking about a hole created in the Roof object by clipping a polygon from the roof? If so, you can select the roof and use the Edit Group command. When you're in Edit Group mode, you should be able to select the clipping polygon (you may need to marquee around it) and move or delete it. Once you exit the "group", the roof will update with the changes.

Share this post


Link to post
On 10/12/2017 at 2:03 AM, Matt Panzer said:

Are you talking about a hole created in the Roof object by clipping a polygon from the roof? If so, you can select the roof and use the Edit Group command. When you're in Edit Group mode, you should be able to select the clipping polygon (you may need to marquee around it) and move or delete it. Once you exit the "group", the roof will update with the changes.

Thanks for your reply Matt. I changed the roof to roof faces and used a polygon with the clipping tool to create an opening. To delete it, the only way i could was to use a rectangle and add surface which effectively filled it in. It was a bit more difficult to select it to modify it. 

While i was creating openings in my roof for 4 gable roofs it somehow deleted part of the main roof. Not sure why it would do this! Since then, I've had graphic trouble in OpenGL mode while in 3D orbit. Very pixelated and walls and roofs can sometimes disappear or go transparent but not deleted from the file etc. Worried it's now corrupt!

Share this post


Link to post
11 hours ago, Sinead V said:

Thanks for your reply Matt. I changed the roof to roof faces and used a polygon with the clipping tool to create an opening. To delete it, the only way i could was to use a rectangle and add surface which effectively filled it in. It was a bit more difficult to select it to modify it. 

While i was creating openings in my roof for 4 gable roofs it somehow deleted part of the main roof. Not sure why it would do this! Since then, I've had graphic trouble in OpenGL mode while in 3D orbit. Very pixelated and walls and roofs can sometimes disappear or go transparent but not deleted from the file etc. Worried it's now corrupt!

 

The "Edit Group" command should work with both Roof and Roof Face objects. If you have trouble clicking on the hole object in Edit Group mode, click-drag a marquee around the hole object to select it. If you plan to edit it, you might want to use the "Send to Front" command to make it easier to get at.

 

Can you send me the file privately so I can take a look at it?

Share this post


Link to post
On 10/14/2017 at 2:03 AM, Matt Panzer said:

@Sinead V,

Are you on VW 2018 SP1?

On VW 2016 SP6.

I'll send on the file and hopefully the graphics problem can be sorted. Thanks

Share this post


Link to post

Hi Sinead,

 

I got your file and see the problem (and have the fix):

The distortion you're seeing is due to the file have some objects very far from the document origin. If you ever see this problem, usually that is the reason.  Here's the fix:

  1. With the "Ground Level" layer active, use the "Select All" command to select everything.
  2. Use the Zoom "Fit to Objects" command.
    You will notice that you see what looks to be a locus point at the top center of the document and nothing else. That "locus" is actually all the objects from your model contained on the layer.
  3. While the objects are selected, notice the number of objects selected in the Object Info (172).
  4. Using the selection tool, deselect those objects at the top of the document by holding the shift key and click-dragging a marquee around them.
    In the Object Info palette, you should now see 2 lines selected. These lines are near the bottom center of the screen (2,480,043,659mm from the document origin).
  5. Delete the lines and the file should render normally again.

Best,

Matt

Share this post


Link to post

That's awesome Matt, thanks so much. Everything is working like normal again! Not sure how i managed to put lines that far away. Still getting used to VW! :-)

Share this post


Link to post

Your'e welcome, Sinead!

Having objects windup on another planet happens to the best of us. ;-)

If things seem to be acting up with display accuracy, checking for this issue is a great place to start.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...