Jump to content
  • 13

VW 2018 (and VW2021 and VW2022): Push-pull tool problems continue


line-weight

Question

This is a continuation of an issue that I was already having in 2017. Mentioned in a couple of threads by me and others previously without much response.

 

Essentially: the push pull tool (a) struggles to select faces, (b) fails completely to select faces, or (c) causes a freeze with spinning beachball when there are moderately complex objects in the drawing.

 

As far as I can work out, it happens as soon as one of those objects is behind whatever face you are trying to select.

 

This has been a big problem in a drawing where I had a few imported symbols (from BIMobject and elsewhere). It became impossible to use the push-pull tool to edit simple objects in the drawings, unless I hid all of those complex objects. To make sure this isn't a problem specific to that drawing file, I've created a new and fairly simple one in VW2018. If anyone would like to see if they can replicate this, here is what I did:

- new blank file.

- go to BIMobject download. I downloaded fairly much at random a server unit casing, in SKP format. If you type "sr25ub" into the BIMobject search bar you should find it.

- I placed two of these units next to each other

- then I drew a simple extruded rectangle, sitting next to them. See screenshots below.

- one of the screenshots has a viewpoint with the extruded block to the left. using this viewpoint, the push-pull tool will select any face on the white block easily and correctly, and function as expected.

- however - the other screenshot has a viewpoint with the server units hiding behind the white block. using this viewpoint, the push pull tool struggles to select the face of the white block at all, and I get freezes and spinning beachballs.

 

This doesn't seem like an overly complex drawing. My machine specs are posted down below. It's a refurbed/upgraded mac pro.

 

I've attached the drawing file too.

 

59bd3d78d32a4_ScreenShot2017-09-16at16_02_53.jpg.e9043ca56dc3ed4919e344efdbcd1f02.jpg59bd3d798fe99_ScreenShot2017-09-16at16_03_19.jpg.437b1738a6ed59d21ddb58013a3dfaa1.jpg

 

59bd3edcc19d4_ScreenShot2017-09-16at16_08_49.jpg.e5d138baa2d8aeba883def3c0d5275d5.jpg

pptest.vwx

Edited by line-weight
Link to comment

Recommended Posts

  • 0

Thanks for the clarification Mike!  Very helpful.  I just followed your method and it worked.  I agree that with many of the functions of this program subtlety is a constant and likely needs to be for the endless customization options available.  From the standpoint of a lesser experienced user who relies on the educational content provided and these threads-those subtleties need to be pointed out consistently.  I have to say that many of the educational videos give it to us as "its as simple as that".  This is not necessary criticism but feedback.  The learning curve with this is high so at every opportunity the little things that show up as glitches should be highly emphasized in all training resources.

Link to comment
  • 0
5 hours ago, Landartma said:

Thanks for the clarification Mike!  Very helpful.  I just followed your method and it worked.  I agree that with many of the functions of this program subtlety is a constant and likely needs to be for the endless customization options available.  From the standpoint of a lesser experienced user who relies on the educational content provided and these threads-those subtleties need to be pointed out consistently.  I have to say that many of the educational videos give it to us as "its as simple as that".  This is not necessary criticism but feedback.  The learning curve with this is high so at every opportunity the little things that show up as glitches should be highly emphasized in all training resources.

 

Just to clarify for other readers of the thread... the problem @Landartma describes, is not the same as the main subject matter of this thread, which is a fundamental dysfunction of the push-pull tool, not something that can be resolved by the user following the correct method.

 

And VW have failed to fix it for 5 years and counting now.

 

 

  • Like 1
Link to comment
  • 0
2 hours ago, mike m oz said:

Line-weight, I'm running Vw2022 on an M1 Mac Mini and I don't have any problem selecting any of the faces of the white object in your view.

 

Are you navigating in perspective (rather than orthogonal) view?

 

If so and you can't replicate problems in the file posted at the start of the thread, can you replicate the one in this post:

 

 

Link to comment
  • 0

I get a different problem in the March 13, 2021 file.  
 

With the Push Pull tool active I can hilight all of both wall faces that can be seen.  

 

If I pull on the left visible wall face it moves.  Afterwards though I can't hilight the right visible wall face and the left wall remains active even though I have deselected it.  I can't prevent the Push Pull tool from hi lighting its various faces and moving them.  Very weird.

 

Edit:  I'm intrigued as to why you need to Push Pull a whole wall face.

  • Like 1
Link to comment
  • 0
1 hour ago, mike m oz said:

Edit:  I'm intrigued as to why you need to Push Pull a whole wall face.

 

I don't! Those just happened to be the elements I could isolate from a larger file and use to produce some replicable weird behaviour.

 

It sounds like you are experiencing some weird behaviour even if it doesn't match mine. That confirms to me that something wrong is happening, as far as face selection is concerned.

 

I don't think I've tried either of these test files since I've had VW2022 installed. I'm on an M1 mac mini too so I will try doing that, and see if my experience matches.

Link to comment
  • 0
1 hour ago, Andy Broomell said:

Lately I've realized that using any tool that relies on face-detection (such as Push/Pull or Extract) is near impossible in Perspective once there are a few dozen objects in the model. Very disappointing...

 

It's almost like the invisible 'bounding boxes' of other objects get in the way of the object you're trying to highlight.

 

Yes! this is exactly what I've been complaining about since the first post of this thread ... in 2017.

  • Like 4
Link to comment
  • 0

I might be trying to solve the wrong problem but it looks like @line-weight your having an issue with push pull in an environment other than cube on the screen with basic push pull functions.  Is that correct?  I looked at your building peak.  Your simply not able to detect a face correct?  I just looked at the pptest.wvx file and was able to get a subtraction in the rectangular extrusion fairly easily.  I just used the flyover tool to get a variety of narrow perspective views.  I was able to put a shape on the plane of the object and select the push pull tool which highlighted the shape.  I started my pull operation and then pressed ALT.  Its hit or miss though.  My guess is that its a specific clicking method between ALT and left click which I have yet to master reliably.   I was able to get subtractions and face pulling action.  The face selection needed to be precise though.   I messed with the BIM object...way above my skill level for now at least...thats some wonky stuff to mess with.  I do have to say that with all the issues I have encountered in my brief VW experience the push pull function has been challenging.  My guess is it will be a matter of a work around.  

Link to comment
  • 0

@Landartma

 

The issue is VW not finding the face correctly (ie. the face I hover the cursor over, does not highlight in re as it should). It has nothing to do with what mode I am using the tool in.

 

As you say, usually you can eventually manage to select the face by moving around with the flyover tool, and looking at it from various directions. That is not how it should be though, and that is not an efficient way to work. The P-P tool seems to operate correctly in orthogonal mode, but not in perspective mode. This is a big problem for me because that's how I work in 3d - viewing in perspective. The only "workaround" for me would be to start operating in orthogonal mode but this would be very disruptive to my workflow, and I have good reasons to want to view models in perspective.

 

VW is supposed to let me push-pull object faces while in perspective mode. It doesn't work properly, the problem has been known about for at least 5 years, it's not been fixed, and we are given no information about when it might be. Welcome to Vectorworks! It might not be too late for you to check out other software packages before you get too invested in it!

Edited by line-weight
Link to comment
  • 0
17 hours ago, Senthil Prabu said:

Hi @line-weight,

 

Face picking issue in Perspective projection is fixed in VW 2022 SP3.  And the dependent bugs VB-128360, VB-177561 and VB-184124 (contains the VW file you shared with me through DM) are resolved.

 

Thanks for pointing out the issue.

 

Thanks,

Senthil Prabu

 

Thank you very much for the update. I will look forward to testing it, when SP3 is released. If it's really fixed, then this will make a big difference to my daily VW experience.

  • Like 1
Link to comment
  • 0

Ok, I've just done a bit of a test of this in SP3 and I'm pleased to say, it looks like face picking with the push-pull tool is greatly improved.

 

Thank you very much to whoever put the work in to get this sorted (at last). It will make a big difference.

 

Unfortunately I can now move onto complaining about something similar - picking edges with the "extract" tool in "extract curve" mode. I don't use this nearly as much as the push-pull tool but it has long been quite erratic. This remains the case in SP3. You can see in this video, there are some edges it seems near enough possible to pick.

 

 

 

  • Like 1
Link to comment
  • 0
  • Vectorworks, Inc Employee
3 hours ago, line-weight said:

Ok, I've just done a bit of a test of this in SP3 and I'm pleased to say, it looks like face picking with the push-pull tool is greatly improved.

 

Thank you very much to whoever put the work in to get this sorted (at last). It will make a big difference.

 

Unfortunately I can now move onto complaining about something similar - picking edges with the "extract" tool in "extract curve" mode. I don't use this nearly as much as the push-pull tool but it has long been quite erratic. This remains the case in SP3. You can see in this video, there are some edges it seems near enough possible to pick.

 

 

Screen Recording 2022-03-16 at 09.19.33.mov 62.17 MB · 2 downloads  

 

 

 

Thanks for testing the face picking fix.

 

Regarding edge picking: looks like this issue is relates to perspective view picking.  Could you please send me the file directly to me?  I will look into that.

 

Thanks,

Senthil Prabu

  • Like 3
Link to comment
  • 0
14 minutes ago, Senthil Prabu said:

 

 

Thanks for testing the face picking fix.

 

Regarding edge picking: looks like this issue is relates to perspective view picking.  Could you please send me the file directly to me?  I will look into that.

 

Thanks,

Senthil Prabu

Please see the private message I've just sent you.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...