Jump to content
Juay

Custom Lighting Instruments

Recommended Posts

Hi all,

 

Still picking up vectorworks spotlight and is trying to customise lighting fixture.

My practise here is to import the Clay Paky DWG and make it into a symbol.

When use Spotlight>Object Conversion>Covert to instrument, the 3D model main body of the moving light goes out of position.

Does anyone know where I am doing this wrongly?

ClayPakyMythos.vwx

  • Like 1

Share this post


Link to post

You  need to attach a parts record to the 3d components and position them in the correct way the fixture in edit 3d component make sure you place a 3d locus in the middle of the head and include it in the body part of the record.

 

 

  

Watch from about 5.15 same process applies with a moving light 

 

Share this post


Link to post

Hi Will,

 

Thanks for the link,

That is the same video that I saw and try to practise on.

I tried to do the same thing except for the modelling part.

Some how when i change it to a instrument the attached photo happens.

 

My loci is shown as the center of the yoke arms. Somehow the head is still at the wrong position.

Screen Shot 2017-08-30 at 11.32.00 AM.png

Share this post


Link to post

There is a locus point in the body symbol. You should get rid of it. The 3D portion of the symbol should consist of 4 individual objects only. That will solve your problem. Also, the body symbol is a Page Based symbol which means it won't scale. Edit the symbol options and check the World Based field. All page based symbols show up as green in the Resource browser.

  1. Base (Parts record attached)
  2. Body (Parts record attached)
  3. Yoke (Parts record attached)
  4. Locus Point (No parts record attached)

As a side note, the geometry in this CAD file is very vector heavy and you should think about  simplifying it by deleting what you don't need. If you are going to be using a lot of these fixtures then you will find that the over complex symbol you are creating will markedly increase your file size and as a result slow down rendering times etc.

Share this post


Link to post

the CP Mythos is available in our libraries.  Also, once it has all the records attached properly, the symbol should directly come in as a lighting object once you make it the active symbol.  We stopped using nested symbols internally because they were doing some wonky things sometimes.  I see that both your base and your Body are nested symbols. The Loci should be in the main symbol, not the nested part, with it in there it is not "Seeing" it and so rotating around the insertion point.   Another thing I notice is that you put the Kg weight in the Light info record, that record expects Imperial units.  for Metric you need to put the weight in the Light info Record M.  You also have the device type as Light, it should be Moving light.  Noticed you accidentally attached the Light Info Record to the yoke.  it won't really affect anything, but might want to remove it.  and as Mark said, that geometry is heavy, might want to clean it up a bit.  And finally, you want to give everything the default instrument texture or you won't have light coming out of the fixture.  

Share this post


Link to post
4 hours ago, markdd said:

There is a locus point in the body symbol. You should get rid of it. The 3D portion of the symbol should consist of 4 individual objects only. That will solve your problem. Also, the body symbol is a Page Based symbol which means it won't scale. Edit the symbol options and check the World Based field. All page based symbols show up as green in the Resource browser.

  1. Base (Parts record attached)
  2. Body (Parts record attached)
  3. Yoke (Parts record attached)
  4. Locus Point (No parts record attached)

As a side note, the geometry in this CAD file is very vector heavy and you should think about  simplifying it by deleting what you don't need. If you are going to be using a lot of these fixtures then you will find that the over complex symbol you are creating will markedly increase your file size and as a result slow down rendering times etc.

Hi Mark,

 

Thanks for the taking the time to look through my file and explaining the details!

I will give it a go tomorrow first thing in the morning.

Share this post


Link to post
3 hours ago, Rob Books said:

the CP Mythos is available in our libraries.  Also, once it has all the records attached properly, the symbol should directly come in as a lighting object once you make it the active symbol.  We stopped using nested symbols internally because they were doing some wonky things sometimes.  I see that both your base and your Body are nested symbols. The Loci should be in the main symbol, not the nested part, with it in there it is not "Seeing" it and so rotating around the insertion point.   Another thing I notice is that you put the Kg weight in the Light info record, that record expects Imperial units.  for Metric you need to put the weight in the Light info Record M.  You also have the device type as Light, it should be Moving light.  Noticed you accidentally attached the Light Info Record to the yoke.  it won't really affect anything, but might want to remove it.  and as Mark said, that geometry is heavy, might want to clean it up a bit.  And finally, you want to give everything the default instrument texture or you won't have light coming out of the fixture.  

Hi Rob,

 

I don't seem to see the file. I could have missed it. 

On the other hand, could it be due to the fact that I am running VW2015 and it is not included in my version?

 

Appreciate the advice and knowledge you and Mark are providing. it really speeds up my learning.

Share this post


Link to post

Ah, Don't recall when we made that fixture.  it was probably after the release of VW2015.

As I tell folks making symbols with me, the one thing that is important with them is that the size be correct, but you don't need every fin, nut, bolt, screw, etc.  that stuff only slows everything down when you go to render.  for the most part, when we create a symbol, they are either sweeps, or extrudes with additions or subtractions to make it more closely resemble the fixture.  we do not put in lots of fillets or chamfers, that stuff while making it look nicer close up, is not really needed from 20' away, or even at 10', and it adds to the render time.  simpler is better, and still gets the idea across.  

if you need any more help, feel free to reach out to me.

 

Rob.

Share this post


Link to post
9 hours ago, Rob Books said:

Ah, Don't recall when we made that fixture.  it was probably after the release of VW2015.

As I tell folks making symbols with me, the one thing that is important with them is that the size be correct, but you don't need every fin, nut, bolt, screw, etc.  that stuff only slows everything down when you go to render.  for the most part, when we create a symbol, they are either sweeps, or extrudes with additions or subtractions to make it more closely resemble the fixture.  we do not put in lots of fillets or chamfers, that stuff while making it look nicer close up, is not really needed from 20' away, or even at 10', and it adds to the render time.  simpler is better, and still gets the idea across.  

if you need any more help, feel free to reach out to me.

 

Rob.

Hi Rob,

 

So I presume that under the licensing, the 2017 library will not be made available to 2015 users even if we do a library update?

 

I see where you are coming from in terms of being pragmatic in the model design. Aesthetic vs efficiency.

Will keep this in mind as i continue in my practises.

 

Thank you so much!

Share this post


Link to post

Service Select customers have access to some libraries in older format, but we only keep libraries there in the current format and the just previous format.  so right now, there are 2017 and 2016 formatted files on the Service Select portal.  otherwise, we don't distribute new content to older versions.

Share this post


Link to post

Service Select customers have access to some libraries in older format, but we only keep libraries there in the current format and the just previous format.  so right now, there are 2017 and 2016 formatted files on the Service Select portal.  otherwise, we don't distribute new content to older versions.

Share this post


Link to post
On 31/08/2017 at 9:11 PM, Rob Books said:

Service Select customers have access to some libraries in older format, but we only keep libraries there in the current format and the just previous format.  so right now, there are 2017 and 2016 formatted files on the Service Select portal.  otherwise, we don't distribute new content to older versions.

 

Hi Rob,

 

Speaking of Service Select, would that by any chance come to Singapore? Or if the market is too small to be considered a viable option, will it be possible to tag onto other servers? I'm especially interested in leveraging on cloud based rendering to free up hardware, but that's sadly not an option right now.

 

Gabriel

Share this post


Link to post
On 9/4/2017 at 5:57 AM, Gabriel Chan said:

 

Hi Rob,

 

Speaking of Service Select, would that by any chance come to Singapore? Or if the market is too small to be considered a viable option, will it be possible to tag onto other servers? I'm especially interested in leveraging on cloud based rendering to free up hardware, but that's sadly not an option right now.

 

Gabriel

I would talk to your distributor about Service Select.  They should be able to let you know if they have a plan in the works to expand it to your market.  I only directly work on the US/English Service Select system.

 

Rob.

Share this post


Link to post
On 05/09/2017 at 9:12 PM, Rob Books said:

I would talk to your distributor about Service Select.  They should be able to let you know if they have a plan in the works to expand it to your market.  I only directly work on the US/English Service Select system.

 

Rob.

Thanks Rob!

 

I'll here from you again here if there are any updates then. My distributor is not the most responsive unfortunately.

 

Cheers,

 

Gabriel

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×