Jump to content
  • 0
Sign in to follow this  
HCB

Site Model Spiderweb

Question

When creating a bespoke site model crop I am finding that anything more than a simple 5 - 8 sided polyline will result in a "spiderweb"  effect that crosses between the extremities of the crop when viewed as a 3D Mesh Solid.  Are we aware of a simple fix for this (I have tried changing my OpenGL settings with no success) or is it a known bug?  Many Thanks.

Site Model Spiderweb.png

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

Not sure, but it appears all your webbing is outside the squiggly site model border.  Did you try a simpler polygon around the main four corners?

Share this post


Link to post
  • 0
On 27/07/2017 at 2:05 PM, Rossford said:

Not sure, but it appears all your webbing is outside the squiggly site model border.  Did you try a simpler polygon around the main four corners?

Thank you for your reply, I simplified it as much as I could but it still suffered from the spider webbing.  I will submit it as a bug and hopefully it will get sorted.

Share this post


Link to post
  • 0

I took a stab.....here's another one on the simple scale, but what about deepening the hull of the site model?

Share this post


Link to post
  • 0

Some thoughts and workarounds. Sorry this is so long after the OP.

A. This stuff shouldn't happen, so, yes, bug or problem that needs attention.

B. This is similar to the problem of bridging/clipping between contours. With the crop, this seems to happen because too many points in the contours.

C. My stupid workarounds:

1. If those extra surfaces are at ground plane rather than up at Site Model surface (probably not the case), then Site Model Settings>Minimum Elevation> adjust upward to hide the lower elements.

2. More likely, the unwanted extra or missing surface is at site model surface. For safety, Copy/Paste in Place the Site Model into a new file. Also Copy/Paste in Place the source data to a separate new layer in the new file.

a. Right click the SM>Edit Site Model Source Data.

b. Wherever the crop crosses a source contour

•Place some 3d loci on the contour, inside the crop boundary. Verify that they are all at correct Z.

•Split the contour at point past the line of loci.

•Delete the part(s) of the contour "under" the loci.

•Exit the edit window.

• If not successful, increase spacing of the loci, or use fewer.  May need to clip more of the contour.

 

Or,

c. Replace some or all contours with 3d Loci:

•Right click the site model>Edit Site Model Source Data 

•Place a 3d locus in empty space

•Select the contour and the 3d locus

•Duplicate Along Path. Group the new loci

•Delete the 3d poly contour leaving only the 3d loci. test a few intervals.

•Repeat  at other contours as needed.

 

-B

SiteModelCrop_A.png

SiteModelCrop_B.png

SiteModelCrop_C.png

Edited by Benson Shaw
'splainin'
  • Like 1

Share this post


Link to post
  • 0
On 7/27/2017 at 2:50 AM, HCB said:

Are we aware of a simple fix for this (I have tried changing my OpenGL settings with no success) or is it a known bug?

 

This happens on our end all of the time. Most of the time we just deal with it, but in other instances we have had to resort to a workflow similar to the one offered by @Benson Shawabove.

 

This is something that should be addressed, along with many other outstanding site model issues that have been raised on this forum. It definitely needs some streamlining and functionality improvements.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×