Jump to content
Sign in to follow this  
shasta

more 3d poly's

Recommended Posts

I've got a common situation: a(n AutoCad file) survey of a house and property that I wish to convert to a 3D model. 'Importing' it gets me an 'Error on line 2' message. Trying '2d polys to 3D contours' seems logical: when I start with the 'lowest contour' and 'contour interval' inputing, it pans back so far I can't see the lines it's refering to. Thinking it's a scale issue, I imported the file at 1:1 on a 1:1 setup layer and found the survey to be either way to small or way to big (couldn't pan or zoom enough to find it). What do I do?????

Share this post


Link to post
Guest

The drawing is probably waaaaaay away from the (0,0) origin.

You can click on the fit to objects button in the horizontal scroll bar at the bottom of the screen.

That will zoom out and put the objects in the drawing within your viewing window.

You can then reset the origin or leave it and just use the Move Page tool to move the print border to your drawing.

This usually happens becuase the AC person moves the page before they start drawing, or they imput the data for the polys as coordinates. The later places the objects out in nowhereville.

Share this post


Link to post
Guest

BTW

if you import a dxf and the objects are 3d polys in AC, you can select the "3d Only" option in the import dialog box and it will import the polys as 3d objects. All you have to do is convert them to 3d polygons under the Model menu and ungroup it. You should be good to go then.

Share this post


Link to post

Thank you Katie. We seem to be making some progress: I imported 3D only and got something that looked useful. I first turned-off all classes other than 'contours' to simplify the drawing. I started the 'Site Model' command and it began calculating. After a bit, it stopped and gave the following error: 'Creation of the DTM failed. Examine your data, eliminate duplicate or vertically stacked datapoints or crossed contours and try again' The only visible potential problem was that the major contours have a gap where the elevation is numbered. To test this theory I deleted all but a few contours at the bottom of the survey that were complete and tryed again. Same result! Ideas?

Share this post


Link to post
Guest

You can use the check 3d polys command to have it search for overlapping or invalid 3d polys.

The result will tell you how many are overlapping and where the first one it found is relative to it's coordinate.

To find the next one, you'll need to run it again and find the second one.

Repeat for the others.

After a while, you should start to see what causes an invalid object.

Basically, survey's are essentially done by humans. There is always room for human error when doing survey data. There is probably a line that crosses another line at one vertex or there is a duplicate poly at the same place.

You can either delete the offending polygon, or just use the reshape tool to reshape it into something that doesn't cross another object.

Share this post


Link to post

Will the gaps where the elevation numbers intersect the lines matter? If so, what is the best method for mending them?

Share this post


Link to post

I did what you suggested and got a coordinate that appeared to be well away from the polygons in 'blank' space. Thinking that there may be something out there I 'cut' the visible polygons, selected 'all' and deleted, then re-pasted the polygons and performed the test again. Same result. By the way, how do you move to a specific coordinate once it's been found?

Share this post


Link to post
Guest

Shasta, email the file to me and I'll take a look at it. If i get it before the end of today, I'll look at it today (friday). Otherwise, I can't get to it until monday.

Put your phone number in the email also and I can call you and walk you thru what you need to get up and running with this file.

Email -

Tech@nemetschek.net

attn: katie in the subject

Share this post


Link to post

Thanks, just sent it....

I'll write some highlights of our discussion for those of you following along at home.

Share this post


Link to post

Shasta,

THANK YOU! I look forward to reading the highlights!

How refreshing! I can't tell you how many times I have been following along in a post only to get to the point when Katie or Robert or someone says "email me and I'll call you".....then nothing more on the post. Kinda like we got left out in the cold.

Doesn't it kinda make sense that the ones that end in a "email/send it to me" should be (above all) the main support/forum topics the next day?

Thanks again,

Matt

Share this post


Link to post
Guest

Imported the file as 3d only.

Moved the polygons to thier own layer.

Had to adjust some overlapping polys.

Then we had to Filter 3d polygons to get the DTM to generate. Sometimes if there are points that are too close together with different z heights, the DTM will fail - as in this case.

The problem with finging out how to get the DTm to look like a "cake" was done using the View Options under DTM Processor. Adjusting to the desired 3d model view setting resolved that issue.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...