Jump to content

Recommended Posts

Strange issue.

I installed Vectorworks like always. I left the Vectorworks 2017 folder (fresh install, new computer) sitting in my 'user~Applications' folder. Thats the main, regular old applications folder. 

I went to download some online content via the resource browser.

It failed. Gave me an error saying I don't have the permissions to change my Vectorworks 2017 folder.

Selected the folder, hit CMD+i to get info. Sure enough, I have administrator rights to that folder. Read and Write.

Called Apple support. Asked why I wouldn't be able to write to that folder.

Stumped, the support guy got two senior engineers on chat.

According to Apple, apparently, you can no longer set permissions on the Applications folder itself. I attempted to add myself with administrator rights to the Applications folder. It fails.

Since the Vectorworks folder is INSIDE the Applications folder, I can no longer download things using the Resource Browser in this configuration.

This seems insane to me. Anybody else seen this?

My workaround is to just move my Vectorworks 2017 folder to someplace else. Any suggestions? They suggested the desktop, but that is such a mess I hate to leave full application folders sitting on there. Apparently the 'Can't set permissions on the Applications Folder' is a new development or 'un-documented feature' on Apples part. This worked fine back in January when I built this machine. I'm guessing one of the OS updates introduced this.

 

 

Share this post


Link to post


This should be configurable manually still, if not automatically by the installer. If setting it manually does not work for both the Application Data folder as well as the Application folder, Tech@vectorworks.net should be able to get you sorted.

Share this post


Link to post

Thanks all. Got this solved.

Yes. According to Apple you can't set permissions on the Applications folder to "me~Read/Write and 'apply to enclosed items'". You don't get to do that any more.

If you select the Vectorworks2017 folder, and CMD+i, you can add yourself as Read/Write access. You can also select "Apply to Enclosed Items". Although, this clearly does not fully apply to the enclosed items.

I had to manually drive to the 'Libraries' folder within the Vectorworks2017 folder, Add myself as Read/Write, and also "Apply to Enclosed Items" (again).

When you choose "Apply to Enclosed Items" on the Vectorworks2017 folder, for whatever reason, things within the 'Libraries' folder don't get updated permissions. I don't know why. Even though the 'Libraries' folder is very clearly enclosed in the Vectorworks2017 folder.

Appreciate the help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×