Jump to content

3D Deform Tool Fail

Recommended Posts

I've been working on a 3D project which requires a few curved walls that are cut out shapes not just solid objects. I used the 3D deform tool for one and it worked great, but now I'm trying to use it again on another wall and it has been failing. This wall is a more complicated shape, but I made it the same way I made the others, so I see no reason why the deform tool shouldn't work with it. Does anyone know why the tool might not work now, and how I can fix my object to be more compatible with the deform tool?

Link to comment

In my experience the Deform tool isn't that predictable. I've used it for bending complex railings successfully but then it will fail with very simple geometry. If you are able, post an example of what you're trying to do and someone may have a solution. Is it failing completely or is the deformed geometry not as you expected? You may find that your example should be submitted to tech support for further investigation.




(Another recent example of issues with the Deform tool - 



Link to comment

Nice scrollwork!


Here's what I would try:

- using the surface mode of the Extract tool, extract a polyline from your existing extrude.

- extrude the new polyline into a fresh extrude.

- try deforming that.


The extract tool often fixes hidden geometry problems. I suspect there's some coincident points in your initial polyline. Another method that might fix it is using the Simplify Polys command (Model>Drafting Aids>Simplify Polys) with the deviation set to 0. Watch the point could of the polyline in the OIP before and after. If it goes down by one or two points then there were coincident points.


Which view are you in while performing the deform? I've recently had some trouble deforming a sort of U shape like yours. The problem seemed to be related to not selecting the same snap point when I was working in Top/Plan View. It was trying to snap to a top point on one side of my object and a bottom point on the other.




Link to comment

I gave it a shot but unfortunately, that didn't work either. I also tried decomposing the shape and recomposing it again, which has helped when I've had other 3D modification tools fail in the past. I've mostly been using it in Top/Plan View,  but I also tried bottom and front view in case I was grabbing the wrong points. This is what my object looks like in top view though. So something must be wrong with the object itself. I haven't been able to fix it either. This image is of a more complicated version of the object. 

Castle 3D.jpg

Edited by lhaldeman2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...