Jump to content
Sign in to follow this  

Can someone make a short test for me?

Recommended Posts



Someone feel like test, if this script run on your machine? :-) Please save (close) all open Files first.

I saved a file with a marionette PIO on my Sierra Mac Book in the office and it worked perfectly. Now on my iMac at home, this script do not want to run anymore (also sierra).


I started standard-practice for searching the issue:


1. Rename User PlugIn Folder (where the Marionette settings are) --> still crash

2. Copy/Paste Script out of the symbol and run --> worked

3. Rename Symbol --> worked

4. Close all files and revert to the the original file which did not worked before --> worked?!

Maybe a problem with my user cache or user settings. 

5. After restoring my user settings to the old version it is still working .... ok, back to work this will stay a secret




Edited by DomC

Share this post

Link to post

Dear Dom,


I `ve been downloading your file. On my Windows 10 system it works. Ich doubleclicked on the plugin object, seeing the network.

When leaving the script,reactivating the plugin, it takes a long time (longer than  with most ather networks) until seeing the plugin object, but oke.


I wish you a qonderful weekend!- and good luck for disovering the secret of your issue.

frinedly regards


Share this post

Link to post



I opened your file on a MacBook Pro (15" Mid 2010)/Sierra 10.12.5, I could alter the length and width of the PIOs in the Info Pallet and it worked.

Double clicked the PIO to view the marionette script and closed again, took about 20 seconds to close, but everything worked.


Regards Colin

Share this post

Link to post

Thanks guys


Seems to was an issue on my system. The delay by exit the symbol is normal, because it caches the script and updates all pios which contains the symbol instance.



(longer than  with most ather networks)


This is related to the dimension nodes inside the script. Unfortunately I have no comparison about the speed, because I see no other scripts with dimensions here in the community board.



Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...