Jump to content
  • 4
markdd

Spotlight Instruments and OpenGL shadows

Question

I often want to see shadows from Spotlight Instruments in OpenGL. This is currently not possible as Open GL sees the texture applied to the object as solid and does not allow light to pass through. It would be terrific if VW engineers could find a way of enabling the "does not cast shadow" functionality for a named texture in OpenGL so that we can use instruments to check shadows and shutters etc.

 

Thanks

 

Mark

  • Like 1

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

The problem is that the texture we apply that allows the light to come out of the geometry would not let the light pass out of the fixture then.  worst of both worlds.

Share this post


Link to post
  • 0

Hence the Wishlist item. 

32 minutes ago, markdd said:

It would be terrific if VW engineers could find a way of enabling the "does not cast shadow" functionality for a named texture in OpenGL so that we can use instruments to check shadows and shutters etc.

 

As you can see my post asked if this could be made possible. It would be so helpful to see shadows. Its not always about the beams!

Share this post


Link to post
  • 0

I agree, and did give it a vote.  the problem currently is that you need the texture to have the lights that are on work, but you can't change the texture because then you don't have lights to test if they are hitting something or not.  bad catch 22.

Share this post


Link to post
  • 0

I've discovered a workaround this morning. I class my instruments so that the 3d portion is in a separate class. What I have discovered is that if you change the class properties of that class to "no fill", then even though the texture is there it doesn't block the emitter locus and voila you have a beam to use that emits shadows. So the workflow is simple. Just toggle the 3d geometry class to no solid, refresh the instruments and then you can see the beams in OpenGL with shadows!

 

 

Open_GL_Shadows.vwx

Edited by markdd
  • Like 1

Share this post


Link to post
  • 0

Mark,

 

How did you set up the Light-3d class to allow for the shadows.  I tried to set up a class for an instrument, as you appeared to have done, yet no luck with shadows.

 

Tim

Share this post


Link to post
  • 0

Go to your instrument symbol and go to the edit 3D portion

 

Put all the 3D geometry into separate class; say, “Lights-3D”

 

Make sure that the geometry is all set to inherit Class Attributes.

 

Then go to the edit class dialogue and set the fill for that class to None.

 

After you refresh the instrument/s you should be left with an open wireframe instrument in OpenGL with shadows enabled. This means that the instrument will now allow light to pass out from the locus point to the focus point and you will see the beam on any 3D surface. Enabling shadows in OpenGL means that you will also see the effect of shutters and gobos as well.

 

The reason this is necessary  is because OpenGL does not “understand” the “cast no shadows” nature of the default Lighting Instrument texture which is read by Renderworks. 

 

Hope that hat makes things clearer.

Share this post


Link to post
  • 0
On 6/6/2017 at 6:44 AM, markdd said:

I've discovered a workaround this morning. I class my instruments so that the 3d portion is in a separate class. What I have discovered is that if you change the class properties of that class to "no fill", then even though the texture is there it doesn't block the emitter locus and voila you have a beam to use that emits shadows. So the workflow is simple. Just toggle the 3d geometry class to no solid, refresh the instruments and then you can see the beams in OpenGL with shadows!

 

 

Open_GL_Shadows.vwx

So Mark: This notion has captured my interest. So how do you class the 3D portion of the fixtures? D'you create a separate library, with all your re-classed fixtures or other technique?

-Thanks-

Share this post


Link to post
  • 0

@mjm Yes. I have for years kept my own library instrument symbols. Some have been made by me from scratch and some are adapted from stock vwx symbols. All are classed as follows:

 

  • Lights-2D (for the 2D TopPlan shape)
  • Lights-Info (for information such as beam angle or other text)
  • Lights-Movement Radius (For the movement radius of moving lights)
  • Lights-Col (For a circular disk that I set to show Gel colour in 2D as well as represent the lens geometry in 3D. This uses the "modify lighting instrument colour" portion of the Spotlight Preferences dialogue)
  • Lights-3D (For all the 3D geometry (apart from the lens))

 

It is the Lights-3D portion that I set to No Fill when I want to see beams in OpenGL with shadows enabled. However,  as the stock vwx symbols are classed Lighting-Incandescent; Lighting-LED; etc These could just as easily be set to "no fill" and the same principle will apply. It's just that the 2D Top/Plan representation will have no fill as well while you work on your beams/shutters/gobos etc in OpenGL.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×