• 3
line-weight

Structural member / column: resets to zero height when 3d attributes changed

Question

Posted (edited)

Try this in blank document:

 

Create a column with the structural member tool.

 

It'll have a Z height, looks like default is layer wall height.

 

Go to its settings dialogue, "3D attributes" tab.

 

Change "set attributes:" from "object" to "class".

 

The column immediately flips to zero height (even if you don't change the "class" from the default) and the "start bound" and "end bound" dropdowns in the OIP are blanked out.

 

Is this a known bug?

 

 

***edited to add:

(1) with column same seems to happen if I change "set attributes" to "class" in the 2D attributes tab,

(2) the beam version of the structural member tool survives these processes.

(3) setting "2D attributes" by class seems to have no effect on rendering of beam in top/plan view. Only setting the class of the object itself achieves this.

(4) with beam, having changed 3d attributes to "class" I can't seem to then change them back to by "object"

Edited by line-weight
0

Share this post


Link to post
Share on other sites

58 answers to this question

  • 0
12 hours ago, line-weight said:

I tried temporarily moving my user folder.

 

The problem I describe in my initial post, relating to the column flipping to zero height, seemed no longer to exist. When I put my user folder back, and tried again, the problem reappeared.

 

Happy to send you the contents of my user folder if it would help decipher what is happening.

 

6 hours ago, Kevin McAllister said:

I tried removing my User Folder and the tool seems to work fine. Switching back to my old user folder makes the problem reappear.

 

Good, a lead! Please zip your user folders and attach them to a reply. Thanks!

0

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, JackG said:

 

 

Good, a lead! Please zip your user folders and attach them to a reply. Thanks!

Have sent you private message with attachment.

0

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, JackG said:

 

 

Good, a lead! Please zip your user folders and attach them to a reply. Thanks!

Jack,

 

I've sent you a link to download mine via private message.

 

Kevin

 

0

Share this post


Link to post
Share on other sites
  • 0

Is there any updates on this issue?

 

I have just had the exact same problem or the column error when trying to use the structural member tool. 

 

The other issue I was having is that I created a set of purlins for a roof that changes angle halfway up I then tried to add rafters connecting them. When it snaps to the purlins they always default back to being horizontal rather than on the slope?

 

Thanks!

0

Share this post


Link to post
Share on other sites
  • 0

Yes, come on VW - any update?

 

I just updated to SP4 to see if anything had changed, but no.

 

This tool is completely dysfunctional and it was one of the things that 2017 was advertised as having when we paid for it a year ago.

 

This thread was started over two months ago, and it seems others have been reporting issues from much longer ago than that.

0

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Are there any news or feedback ?

It looks like I am unable to create ANY SM in column mode in SP4

(Can't create zero height warning)

and vertical positions settings disappear constantly.

 

 

Aren't top/bottom or start/end fields mixed up anyway though ?

I tried it both ways.

Edited by zoomer
0

Share this post


Link to post
Share on other sites
  • 0

Having just been fiddling around with VW2018, it *appears* that this problem *might* be fixed.

 

Haven't tested thoroughly enough to find out whether the Structural Member tool is now usable, but let's see.

0

Share this post


Link to post
Share on other sites
  • 0

Yes same here.

Do not know if everything works now, but that was one of my first VW 2018 tests.

 

And, that was again the first time I was able to create any SM in Column Mode since

the roll out of SP3 !

Edited by zoomer
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now