Jump to content

Black line appearing in final render in viewport

Recommended Posts

I have created a site model with 3d modelling for a landscape.  It works well, but when I render in viewport I am getting a black line appearing along the line of one element of the drawing.  This is always the last part of the drawing to render and the line appears on top of everything else. Anyone any ideas what this can be?  I've deleted all layers that I was not using. Screenshot attached. 







Screen Shot 2017-03-26 at 18.58.37.png

  • Like 1
Link to comment

If rDesign's idea of switching off the Display Planar Objects does not solve or is not satisfactory, try to find and select the 2d poly. Then delete it or move it to another layer or make it invisible. 2d objects always render on top of 3d objects, even if they are moved to back or are on layers lower in the layer order. (assumes Unified View is enabled)


I'm guessing that the offending black line(s) is a 2d poly coincident with the 3d extrude of the concrete walkway, and it's layer/class assignments are visible in the VP layer and class settings - probably same Layer/Class as the 3d walkway object.  To find the 2d poly, sequentially switch off layers in the VP until the poly disappears - that's the layer.  Activate that layer and view it in Top/Plan with Active Only visibility.  Hold the J key and select an edge where the 2d poly is likely to reside. A dialog appears listing all the objects in the stack and their types (Extrude, Polyline, etc). Click the likely item/row in the list to highlight the corresponding object the drawing. Dismiss the dialog to reveal the object selected in the drawing. In OIP, move this object to a layer or class which is invisible in the VP, or if you don't need it, delete it.


It is possible that the top edge and the bottom edge of the walkway were originally represented as separate, coincident (stacked) 2d objects. I find this often in dwg imports.  If one poly was used in vwx as source for the 3d walkway extrusion, the other 2d poly would remain on the design layer and would display in the VP.


OK, post back if no joy.





Link to comment
  • Vectorworks, Inc Employee

If it is not what has been suggested above, I've seen a few instances recently of these types of lines appearing on viewports if Indirect Lighting is enabled in the viewport's lighting options. This is uninstentional but worth checking by doing a test render with Indirect Lighting set to None.

Also, which version of Vectorworks, what service pack, and what operating system are you using?

Link to comment

Thanks for all the suggestions.  I've turned off display planar objects and that makes no difference.


I've deleted anything which might have been a 2d shape of any kind. The boardwalk is a hardscape object with 150mm thickness and a pad modifier, bottom edge.  The dark line appears to be showing the site modifier along the bottom edge of the hardscape. It's also appearing under a road polyline which is also set to modify the site model below.  


If I turn off indirect lighting I still get the same effect.  


I don't get the effect in open GL render, just in the final render works style. 


I'm running Landmark with renderworks 2017 SP2 and SP3 (2 machines) MacBook Pro and iMac.  Same effect on both.



Any more advice?




Link to comment

Nice, H Palmer!  Thanks for the show.


Late entry here. PaulGs class solution is great. There is also a layer option. Site modifiers can be effective when placed on layers other than the site model layer. Those other design layers can be can be made invisible in View Port Layer options and still affect the Site Model. Layer effective options are found in flyout menu of Site Model OIP> Site Model Settings>Use Site Modifiers on (several layer options). For instance, a drawing could have a Pads & GradeLimits layer, a Texture Beds Layer,  a Site Model Layer, a Buildings layer, etc.Then use the Use Site Modifiers on All Layers option, but make the modifier layers invisible in the VP.




Edited by Benson Shaw
Link to comment

I totally agree with other comments of the stunning result you have achieved. Is this all done in Landmark? It would be interesting to discover some of the techniques you used as I am looking at purchasing an upgrade to landmark.

thanks again for sharing.

Edited by Alan Woodwell
Link to comment
  • 4 months later...
Guest egidoro


in this rendering appear (on the floor)  all the lines corresponding to the sections of  3d model (viewport).
The result is really disappointing ..
How can I fix it?



Link to comment
  • 3 months later...
  • 1 year later...
  • 2 years later...

I was able to solve this issue by applying a texture to the component which was rendering with black lines, in this instance the glazing in the windows. Window type [1.] does not have a texture assigned to the "glass" component, whereas window type [2.] already does. I hope this helps someone.





Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...