• 0
Dubman

Snapping Pallet tools working intermittent & other

Question

On occasion the vertical/horizontal constraint stops working. As I click to start drawing a line for instance, and press the shift key to constrain the line horizontally to the right, its starts out correctly & then starts going every direction with no control in any direction. I have also noticed that this coincides with the smart cursor cues stop working. When opening the smart cursor settings I see the show cues is de-selected, in which I always have selected. I even deleted in the Workspace Editor Keys-Other Keys to toggle smart cursor cues so I would not accidentally turn it off.

Also, on occasion, I can not enter the (") inch tick mark when typing text. If I press twice then I see two of them & have to Backspace one. I'm able to do it in other software with no problems. It works better after a computer reboot.

 

The lost of constraint control happens also when moving any object or objects. I can not tell if these are a setting I do not have correct, my computer problem or software problem.

 

Thanks for any advice !

0

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

For me it sounds like a keyboard problem.

 

I had such behavior after cleaning my Mac USB keyboard too humid ;) (irreversible).

Or there could be problems with bluetooth connection, USB used in a hub or

general hardware problems.

 

An interruption of your SHIFT press could lose your constrain or not recognize

key press for your inch symbol. I think it is worth to test another keyboard if you have.

Just strange that you say it works well anywhere else outside of VW.

 

If that is the case I would try one of the standard workspaces delivered by VW and even

delete VW settings (after backing up).

0

Share this post


Link to post
Share on other sites
  • 0

Thanks Zoomer, I'll give another keyboard a try & report back about it.

But I do not think the key board is causing the snapping, especially the smart cursor cues to stop along with the constraint of a horizontal direction.

Edited by Dubman
0

Share this post


Link to post
Share on other sites
  • 0

^ Especially it is working outside of VW.

 

Sometimes for me VW also get some hick ups where it doesn't work as expected

and may require a system reboot. (Something Mac users don't do until there is a real reason)

But after that it worked again.

And I also heard people having their ALT/SHIFT/.. keys not working for shortcuts at all in

VW or other Apps.

 

So things can be quite complicated and you have to narrow it down in some way.

 

Having no cursor cues and snapping problems from time to time, especially in sub object modes,

is something I am familiar with in VW 2017 anyway. But never had a problem with SHIFT not working,

at least the way it is designed.

0

Share this post


Link to post
Share on other sites
  • 0

With the different keyboard the foot & inch tick marks stopped working again when typing a note 4" step down, I have to press the key twice to it the tick mark, but then get two of them & have to back space delete one to get a single inch mark.

It is always something with computers!

0

Share this post


Link to post
Share on other sites
  • 0

So if all rebooting, keyboard issues and language settings or connections problems can be excluded

and it runs fine in any other Apps, it will be something with Vectorworks.

But I have no clue what could cause this behavior.

 

I think this is a task for @JimW

0

Share this post


Link to post
Share on other sites
  • 0

I recommend resetting preferences as described here:

 

 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now