Jump to content
  • 1

Viewport content disappears on sheet, only visible when zooming in and out

Kim Vanopstal




I have had this issue happen to me on several occasions, where I place a viewport on a sheet (viewport of just a simple line drawing on the design layer, no symbols or anything fancy, although sometimes it also happens when it's a viewport of a referenced file) and after working on the file for a while all of a sudden the content of the viewport is not visible anymore. It only shows up when I zoom in or out, but disappears when I stop.


It happens completely at random and for several files. I have checked all obvious things, like if all layers and classes are on, etc. I don't think it is a setting that is wrong or if I accidentally gave a wrong command, but more that it is either a bug on my computer or my vectorworks program? I have had someone tell me it might be a problem with the graphic card?






Link to comment

9 answers to this question

Recommended Posts

  • 0

I'm having the exact same problem as described by Kim. I have a 2014 MacBook Air, have not upgraded the graphics card driver since its Apple but this disappearing graphics started soon after I upgraded to vectorworks 18. I changed Navigation to Good but that made no difference. 

Edited by mur57
Link to comment
  • 0

I am having a very similar problem. Right in the middle of my work day on this file. everything on the design layers disappear unless I am zooming.  very weird. I restarted, etc.


The other weird thing is that even in top/plan view my background is green instead of beige.

I must have done something to trigger this. But what?!


Fortunately my backup file was fine...

Link to comment
  • 0

Wondering if anyone found a solution for this problem. I have noticed that If I change the render mode for my viewport to say..."hidden dashed line" then update,  I do not have this problem. However when I use "open GL" I lose part of the drawing - and not a predictable part. For example; a side view viewport of a 3d rectangular cube may give me three of the four lines that should comprise the rectangle appropriate to the view. It doesn't seem to follow a logic as to which objects (or which parts of which objects)  it shows and which it does not. Any related info is always appreciated. 

Link to comment
  • 0

A few things to check are:

1. Whether your graphics card meets the minimum requirements for your VW version.

2. Make sure you have the latest drivers for your graphics card installed

3. Set your navigation settings in preferences one step lower than current to see if that solves the issue, if not take it one more step lower.

4. If  -3 do not solve the issue you may want to look if it is possible to reduce the complexity of your model/document, sometimes there is so much in it that the graphics card has trouble handling the geometry and then a new(er) graphics card may solve the issue. I had that happen with another cad program where display would become very inconsistent despite having the latest drivers etc. It turned out the demands for displaying the geometry were too high for the graphics card and updating it to a more recent model solved the issues.

Link to comment
  • 0

We have this problem too - actually I have noticed it a few times with very large complex files but this file is very simple.  But today it appeared in a very simple file.


We have a baseplan file from the architect.  It's small 200KB you can zoom in and out easily.  It is referenced into our concept file - you only see the line work when zooming in and out.  We built a very simple 3D model., then you could only see any linework when zooming in and out.  I deleted 3D model - no difference. 


After spending about 45 minutes on it I selected unified view and everything worked.  Does anyone know what the underlying issue would have been?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...