Jump to content
  • 0
Mitch_Skelly

Geometry Selectable but not Viewable

Question

Today I have been having an issue with 3D geometry disappearing. IE: When I'm looking at it in Top/Plan it is there, but randomly when viewing it in lets say Front Isometric it is selectable but invisible. I cannot see anything on screen. Im wondering if its a corrupt file or if its an issues others have had or have found a solution to. (Working in Spotlight 2017)

 

Thanks!

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

Please reply. Back with the following from that machine and I can take a look:

 

 

  • Like 1

Share this post


Link to post
  • 0

Try turning its class to invisible & back to visible again - sometimes helps.

Share this post


Link to post
  • 0

Sometimes a restart helps this as well.  I was having trouble the other night with a piece of scenery that was visible but unselectable, not on any class or layer.  I shut down VW, restarted the computer, and all was fine. 

Share this post


Link to post
  • 0
13 hours ago, Mitch_Skelly said:

System Report Attached:

Mitchell's_MacBook_Pro.spx

 

I agree with the above recommendations, however in addition since your machine has dual graphics devices in it (We have seen trouble with Vectorworks keeping the dedicated GPU in use sometimes) you may also want to ensure the following has been done to try and force the dedicated card to be used constantly:

 

 

The OS switching between them while Vectorworks is still actively running can cause all manner of slowness and object visibility problems.

Share this post


Link to post
  • 0
On January 24, 2017 at 6:45 AM, grant_PD said:

Sometimes a restart helps this as well.  I was having trouble the other night with a piece of scenery that was visible but unselectable, not on any class or layer.  I shut down VW, restarted the computer, and all was fine. 

 

Yeah, I have done several restarts over the week and still seem to be having the issue intermittently.

Share this post


Link to post
  • 0
On January 24, 2017 at 7:05 AM, JimW said:

 

I agree with the above recommendations, however in addition since your machine has dual graphics devices in it (We have seen trouble with Vectorworks keeping the dedicated GPU in use sometimes) you may also want to ensure the following has been done to try and force the dedicated card to be used constantly:

 

 

The OS switching between them while Vectorworks is still actively running can cause all manner of slowness and object visibility problems.

 

Awesome, I'll give this a try. (Will probably help with other slowness issues as well. I have found that my 3D geometry disappearing issue seems to be due to a "Working Plane Cube" of sorts randomly moving around. When in a 3D view, if I grab this WP Cube thing and adjust it to be covering the geometry it becomes visible. Or partially visible depending on what geometry it is covering, like a section viewport. Whats weird is that if I set it so that I can see my geometry and then do a task such as adjust the Z heights of an object, it randomly moves the "Working Plane Cube Thing" to a random spot, making my geometry invisible yet again. Is there a way to essentially reset this 3D Working Plane Cube? Or eliminate it? I don't ever recall seeing this in 3D views, even in 2017.

 

I apologize for my incorrect terminology on the "Working Plane Cube Thing"

 

Thanks,

- M

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×