Jump to content

Site Model confused by modifier


Recommended Posts

Can anyone see what we're doing wrong here? Attached screen shots Model - exist & - propose. The 2 test images show that it works for us at a small scale. The existing site model is about 40MB, covers about 35ha. It's only a small part of it that we want to change. Grade Limit poly is hightlighted. You can see VW doesn't want to throw away any rock and builds these little mounds between the contours that include all of the elevation I want to get rid of. Commendable frugality - just not what I want.

Modifying contours created through the Create Objects from Shapes > Site Modifier > Contour dialogue

Of course, the 1st thing we do in these situations is go back to JP's SST manuals. But following instructions meticulously and repeating our methodology on the small sample model produce the same results - correct on the small 1, hopeless on the big. Just hoping it's an obvious and elementary rule we're breaking...

VW 2016. Gear used is an HP quad-core Xeon, 16MB and Quadro K4200, so that shouldn't be a a problem.

test Model-exist.jpg


test Model-proposed.jpg


Link to comment

Ok. I see that the images appear in-line and don't have their file names. Ignore the 2 small examples - they just show when we do exactly the same thing to a small set of contours it works as advertised. Subset of the same site model.


The larger images - if you look a Model - exist.jpg you can see the modifying poly's (red) and the Grade Limit boundary (also red). The existing site model has orange majors (5m) and grey minors (1m).


Model - propose.jpg is the result. 


In the proposed model, looking from left to right, it's almost as though instead of grading evenly from the 1st modifier to the 2nd, VW leaves a hunk of the original terrain in the middle and then tries to make good. The higher modifiers are better, I guess because at this stage there's little original material between contour modifiers, but there's still a bit of the same messiness going on. 


In the early trials we drew the Grade Limit poly from contour to contour ie intersecting each contour with a vertex. This version uses a simplified poly. Result pretty much the same.


In the interim we've manually adjusted  the original model so we can work the overall design, but this doesn't give us eg cut/fill volumes, or a fast way to tweak the reshaping in response to the developing design.


Any light you can throw on matters very, very gratefully received.


Thanks: t

Link to comment

Hi, Tim!


Maybe the grade limit isn’t effective, so needs different shape or location, or is set to exist rather than proposed? Or maybe some or all of the new contours are set to existing rather than proposed? Or z values are not correct?


It kind of looks like the new polys are grade limits or pads rather than contours. Causing the exist contours to connect up or down to the new polys rather than be subsumed by the new ones.


Or the new contours didn’t end up in the correct class? Or the view is set to existing rather than proposed? Anyway, hard to tell without the file.



Edited by Benson Shaw
Link to comment

Thanks Benson. Nice set of questions, most of which I could tick off quickly. Pads v contours and possibly Z looked like where the problem was. Checking the modifiers carefully 1 of them was set to 'angle' instead of 'none'. Ha! I thought, a Z problem. But no. Then I redrew the Grade Limit poly to intersect as much as possible with the existing contours at a vertex. Don't really know why - just thought if it was having trouble figuring out an intersection point and elevation a vertex might be easier to recognise. Call it operator's white magic. And it worked! So is that a rule? (or just a quirk of this particular file, like its size? - 35ha and 40-50MB for the site model itself)


An interesting observation from going through the process in minute detail though was that when you create the modifier (contour) from a poly (as opposed to using the Site Modifier Tool) you enter an elevation. If you then select the modifier the OIP says Z=0. 1 more step to fix it.


Anyway, problem solved. Thanks for the questions ;-)

Link to comment
35 minutes ago, timking said:

Call it operator's white magic.

That's in line with some others' practice of "reading" chicken bones tossed into puddles of leaky oil pan drips left on the driveway. (I think I will stick to tea leaves and coffee sludge in bottom of cup).  Which is to say: NO CLUE!  I think you may be onto something with grade limit points. Needs testing when we all have time.  Shouldn't be file size.


38 minutes ago, timking said:

If you then select the modifier the OIP says Z=0. 1 more step to fix it.

I usually accept the defaults and adjust in OIP.  I think those creation dialogs often reset after close, even though they are supposed to keep the input values and apply to next object created.


Anyway glad your site model is working now.  Whew! That should have been waay faster and waaay easier.



  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...