Jump to content
RedBassett

Boom viewports rendering 3d

Recommended Posts

ADDED: Scroll down to see a video of this issue in action

 

I have a number of booms in my plot. These are shown on my lighting plot layer with viewports created by the Create Plot and Model Views tool. I have the definition and model layers for all of the booms hidden. This setup correctly shows the boom in plan view with instrument symbols. When I pan around the document however (holding down [Space] and dragging with the mouse), the viewports boom viewports all suddenly show the 3D model of their respective booms, including the full width of the pipe and the 3D mesh for the instrument model. If I change the visibility of any non-active layer, the viewports pop back to the (correct) plan view, even if the layer whose visibility I changed has nothing to do with booms (such as my softgoods layer). Toggling the active layer's visibility does not fix the rendering. I assume that this is a bug of some form? If not, what am I doing to cause this behaviour?

 

Edit:

 

I can cause a similar behaviour as well: If I edit the definition layer for one of the booms, then hit the Previous View button to go back, all my default layers get shown (such as lighting, softgoods, venue, notes), however only the selected layer (lighting) is shown on screen. If I toggle the visibility of any other layer, all of the missing layers snap back into being shown.

Edited by RedBassett

Share this post


Link to post

Can you post a picture or better still the file? I have found that the create plot model view works well but takes considerable  practice to get right.

 

mark

Share this post


Link to post
Just now, markdd said:

Can you post a picture or better still the file? I have found that the create plot model view works well but takes considerable  practice to get right.

 

mark

My layers:

Screen Shot 2016-11-14 at 14.43.00.png

 

By default, the viewports render the boom correctly:

Screen Shot 2016-11-14 at 14.39.06.png

 

However if I hold down [Space] and pan, they suddenly snap to 3D (plus plan view):

Screen Shot 2016-11-14 at 14.39.15.png

 

If I change the visibility of ANY layer in that layer list (except the selected one: lighting), the 3D goes away and it snaps back to plan view. I will try to capture a video of this behaviour if I can.

Share this post


Link to post

Yes it seems odd.

 

What I noticed from your layer list is that you have the model layer turned off. It should be turned ON. When you run the CPMV command it creates 2 viewports. One on the layer where the originals used to be and one on the specified model layer. It also changes the original objects to the definition layer. Most of the time you need to delete the first viewport and use the viewport that has been created on the model layer. That viewport is the one that needs to the rotated or "stood up". You will also need to change the 3d hanging orientation of the fixtures that are now on the definition layer if they are going to look right as well - its all quite a process.

 

There is a video on VW youtube channel that that is reasonably succinct. Let me know if anything I have said here helps at all!

 

Mark

Share this post


Link to post
On 11/14/2016 at 3:57 PM, markdd said:

Yes it seems odd.

 

What I noticed from your layer list is that you have the model layer turned off. It should be turned ON. When you run the CPMV command it creates 2 viewports. One on the layer where the originals used to be and one on the specified model layer. It also changes the original objects to the definition layer. Most of the time you need to delete the first viewport and use the viewport that has been created on the model layer. That viewport is the one that needs to the rotated or "stood up". You will also need to change the 3d hanging orientation of the fixtures that are now on the definition layer if they are going to look right as well - its all quite a process.

 

There is a video on VW youtube channel that that is reasonably succinct. Let me know if anything I have said here helps at all!

 

Mark

 

 

I have that layer off because the 3D models are rendered in plot view, which I don't want. I already have boom symbols in the plot, I turn on that layer when I want to visualize them in 3D, but off to keep the plot clean:

 

Screen Shot 2016-11-15 at 19.17.29.png

 

Even with this layer on, the viewports still pop to 3D while in the plot view.

Share this post


Link to post

The viewports that are made by running the CPMV command will not show 2D as they have been rotated about the Y axis or if you like, "stood up" as booms. That is because the lighting pipe and instrument objects are 2D/3D hybrid objects which behave in this way on purpose. So what I can see is correct. What I can see is a Source 4 clamped to a vertical pipe which is what is drawn. If you want it to look more like a boom with fixtures hanging from a side arm and the fixture suspended vertically, then you will need to add a side arm and change the instrument 3D orientation in the object info palette.

 

What is laborious about the CPMV process is that you have to control 3D visibility by turning off and on layers.

 

The behaviour you showed in the video I am not really sure about, but if you post the original or a demo file here I could take a look.

 

Hope that is useful. 

 

EDIT: I have uploaded a file showing the way I use this command.

 

Mark

 

BOOM.vwx

Edited by markdd

Share this post


Link to post
16 hours ago, markdd said:

The viewports that are made by running the CPMV command will not show 2D as they have been rotated about the Y axis or if you like, "stood up" as booms. That is because the lighting pipe and instrument objects are 2D/3D hybrid objects which behave in this way on purpose. So what I can see is correct. What I can see is a Source 4 clamped to a vertical pipe which is what is drawn. If you want it to look more like a boom with fixtures hanging from a side arm and the fixture suspended vertically, then you will need to add a side arm and change the instrument 3D orientation in the object info palette.

 

What is laborious about the CPMV process is that you have to control 3D visibility by turning off and on layers.

 

The behaviour you showed in the video I am not really sure about, but if you post the original or a demo file here I could take a look.

 

Hope that is useful. 

 

EDIT: I have uploaded a file showing the way I use this command.

 

Mark

 

BOOM.vwx

I'm not saying that the models being displayed in top view is incorrect, just explaining why the layer is off in the screenshot of my layers.

 

As per the issue of the 3D rendering in 2D viewports, I do not see this behaviour in the sample file you uploaded.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×