Jump to content
  • 0
shelliej

Exporting to .stl and dimensions change?

Question

Hello community, 

 

I made the attached file and the dimensions of the overall object in vectorworks are 3.25" x 4.25", but when I export it to an stl file and try and view it in any other software (person with the printer doesn't have vectorworks, he's using Autodesk Inventor, but I've seen this in a couple of rendering programs), the sizes change as though it was made in mm, despite the fact that it was definitely made in inches. Meaning the dimensions are off by 25.4. Is this something others have experienced? Is it a vectorworks problem or an importing issue with other software? Specifically the printer uses Autodesk inventor, does anyone know how to deal with this? Thanks!

Top Plate test.stl

Top Plate.vwx

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0

This object looks like it might have been dimensioned with too large a rounding precision. If you switch the document to use mm as it's units and then increase the rounding precision to .001 you'll see the accurate measurement of the object and why it is appearing that way in other applications.

 

Most likely, this was drawn with the documents dimension rounding precision set to only 1/4" but for a part this small it would need to be measured with much smaller units to be accurate.

 

Screen Shot 2016-10-24 at 9.30.36 AM.png

 

Screen Shot 2016-10-24 at 9.33.47 AM.png

Share this post


Link to post
  • 0
14 hours ago, shelliej said:

Is this something others have experienced?

I have seen this with some STL import functions. Often the files are seen as metric regardless of the starting units.

 

14 hours ago, shelliej said:

Is it a vectorworks problem or an importing issue with other software?

Its not a VW problem. Your file imports properly and is the right size in Netfabb Professional.

 

14 hours ago, shelliej said:

Specifically the printer uses Autodesk inventor, does anyone know how to deal with this?

There are three ways to solve this -

 

  1. Change your units in your VW file and export the STL again. This give you direct control.
  2. Or, ask the person importing your file to adjust the import settings for Autodesk Inventor. There must be a way to account for this.
  3. Or, scale the object to the correct size in Autodesk Inventor or the 3d printing software.

Kevin

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×