Jump to content
Sign in to follow this  
Bear Dizzle

Reference Viewport Visibility Issues

Recommended Posts

Hi Everyone, 

 

Ran into a bit of a head scratcher and was hoping someone would be able to provide some insight. I'm working on multi building townhouse project that uses a combination of three standard unit plans to compose 5 building types. We are using a base/master file setup where the 3d model is contained in the base file and the sheet set is contained in the master file. Within the base model, each building type is modeled individually,  but each standard unit plan is modeled only once and we use design layer viewports within base model file to show the standard unit plans in the different buildings (lets call them Units A, B & C). 

 

Meanwhile....in the master file....I create a reference viewport from the base model file which shows all of the unit plans and all of the building plans within a single viewport, but for some reason the design layer viewport created for Unit Type C in the base model does not show up in the master file reference viewport. The design layer viewports for Unit Types A & B are showing up and, for that matter, so is the original model of Unit Type C, just not the design layer viewports used to duplicate Unit Type C. So I end up having the gaps in my building plans and I cant figure out what the problem is. 

 

I've checked and rechecked the layer visibility settings and everything matches up. I've turned on all of the classes within the referenced viewports. I tried deleting then recreating the viewport and it didn't make a difference. I then opened a blank file to create a reference viewport from the base model file and everything came through correctly, so I compared the viability settings between the two and everything matched up. I'm not really sure what else to check for.

 

Any thoughts?

 

 VW 2015 Architect

Share this post


Link to post

Were some of the files conversions from an earlier vectorworks version or were all files made from scratch in VW2015?

The reason I am asking is that there is another topic on this forum about snapping to viewports not working, and when I recreated the viewport it worked. That file was a conversion from an older version if I remember correctly. Though glitches can and do happen from time to time and importing into new files may be the more practical solution in some cases.

Share this post


Link to post

Good Morning, 

 

So I tried using the eye dropper tool but I got an error saying that class visibilities can not be transferred to one or more viewports and it suggested transferring the record through the resource browser. 

 

So, I still dont know what the problem is but I renamed the layer on which the design layer viewports were placed (in the base model). When I updated the the reference file everything came back. 

 

Share this post


Link to post

Bear,  check class visibilities in your "base" file.  Are there any differences between A/B and C?  In the class settings of objects or of the DLVPs themselves?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×