Jump to content
  • 0
rDesign

Custom Title Block - Multi-Line Text Fields Don't Automatically Wrap

Question

I've created a custom title block to be used in conjunction with the Sheet Border object. My sheet titles usually require multi-line text, so I created a Record Field named 'S_Sheet Title_SD#' which ends in _SD# as directed in the Help File, but the Sheet Title does not automatically wrap to a second line. I have to manually 'Edit the Title Block...' from the OIP and type in a 'return' where I want the Sheet Title to break to a second line. Is this how it is intended to function?

 

On a related note - since I've been using the Sheet Border object this afternoon, Vw has been very crash-happy. Three times in the past hour. Has anyone else noticed an increase in crashes when using Sheet Title object? Thanks.

  • Like 1

Share this post


Link to post

16 answers to this question

Recommended Posts

  • 0

I've never had excess crashing when using Sheet Borders, so I'm not sure what's up there, but what you're describing about word wrapping isn't a bug as far as I'm aware, but rather is "working as designed"... or "broken as designed." It definitely needs attention because it doesn't function all that well.

  • Like 3

Share this post


Link to post
  • 0

@Andy Broomell- thanks for the confirmation. BTW - I used your 'Creating a Custom Smart Title Block in Vectorworks' PDF to help me get my Custom Title Block working as well as it is - so thank you for that!

 

I'll have to file a wish-list for the text to automatically wrap, because when you use the OIP 'Edit the Title Block...' to insert carriage returns, the Sheet Title gets truncated in the 'Sheet Layer' Organization window.

 

Like you said 'Broken As Designed'. Thanks again!

 

 

Edited by rDesign

Share this post


Link to post
  • 0

The workflow of using Custom Title Blocks with Sheet Border objects really needs an overhaul.

 

If you modify a multi-line Sheet Title using the OIP so that it fits on your custom title block, the Sheet Title is no longer correctly shown on the Navigation palette and the only way to change the sheet title is now through the Sheet Border OIP. So now I have a bunch of drawings shown as all being named 'Existing', even though they are 'Existing Pool House - First Floor' or 'Existing Main Residence - Front Elevation'.

Edited by rDesign

Share this post


Link to post
  • 0

Yes - this issue has been a nuisance for me as well.  The 'wrap text' feature not working should  be added to the bug list.

  • Like 1

Share this post


Link to post
  • 0

Another user with the exact same issue. Text does not wrap to a second line and goes off the page instead. Hope that there is a fix for this.

Also the features for the title block really need to include additional smart functions like filename and path at least.

Edited by ptoner

Share this post


Link to post
  • 0
On 10/15/2016 at 4:45 PM, rDesign said:

On a related note - since I've been using the Sheet Border object this afternoon, Vw has been very crash-happy. Three times in the past hour. Has anyone else noticed an increase in crashes when using Sheet Title object? Thanks.

 

Yes...all the time. I just try to edit the multi-line sheet title in the sheet border dialogue box and it crashes almost every time...very frustrating!

  • Like 1

Share this post


Link to post
  • 0

There is a reworking of the underlying text wrapping (well, the lack thereof really) in Title Blocks to correct this in the pipe.

  • Like 1

Share this post


Link to post
  • 0

This has been an annoying part of custom title blocks for a long time. The only fix I've found is to type the multiple line as you want it to appear in a normal text box, then copy and paste it into your data field.  This definitely needs to be addressed.

Share this post


Link to post
  • 0

Hi,

I'm having a closely related issue regarding my custom title block "revisions". It's not a wrapping issue, but rather a text line stacking issue. I made this post about it:

I'm hoping someone could take a look and help me figure this out.

 

Thanks!

mg

Share this post


Link to post
  • 0
On 3/13/2017 at 1:09 PM, mgries said:

Hi,

I'm having a closely related issue regarding my custom title block "revisions". It's not a wrapping issue, but rather a text line stacking issue. I made this post about it:

I'm hoping someone could take a look and help me figure this out.

 

Thanks!

mg

 

I'm happy to look at this if you like.  I wrangle titleblocks as part of my job.  crisdopher@mac.com

Share this post


Link to post
  • 0
On 2/27/2017 at 5:31 PM, JimW said:

There is a reworking of the underlying text wrapping (well, the lack thereof really) in Title Blocks to correct this in the pipe.

Hi Jim, is that likely to come in a Service Pack or not till a future version?

Thanks,

Tim

  • Like 1

Share this post


Link to post
  • 0

Yeah, the text wraps if you have spaces between words. If you have labeled a drawing in order to comply with BIM Level 2, no spaces, with underscores instead.... the text keeps going in a line. It should wrap to the text box, but it doesn't. Very problematic.

 

Edited by ptoner

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...