Jump to content
  • 0
line-weight

VW2017 - 3dconnexion navigation jerky

Question

I have a 3dconnexion device which was working completely fine in VW2016. Nice smooth motion in all directions. I used walkthrough navigation pretty much all the time.

 

In VW2017 walkthrough navigation seems to have disappeared so am using "Helicopter" as that seems the most similar.

 

But especially when working close-up the motion is jerky. A bit of fiddling around reveals that this is because the speed of motion, as I gradually push on the joystick, doesn't start from 0 and ramp up smoothly as it does in VW2106. It seems to start suddenly at a certain low speed. This isn't so noticeable when zoomed out from the model, but working on any kind of detail it is - jumping around the place because the lightest touch on the joystick starts it off at a pace. There is no fine control.

 

It doesn't seem to be a problem on all axes. Rotating left and right is ok, as is tilting up and down. But sideways left/right, vertical up/down and movement forwards/backwards have the problem.

 

I've tried fiddling around with the settings in the 3Dconnexion control panel (threshold, speed etc) but no luck. It still happens with the speed set to the lowest possible.

 

This is becoming enough of an issue that I might have to move back to 2016.

 

(By the way I was initially using a "Vectorworks 2016" configuration in the 3D connexion control panel. That seemed to work for both 2016 and 2017. I tried deleting this and adding a "Vectorworks 2017" configuration. But doesn't seem to change anything - 2016 and 2017 both seem to work from this. I also updated to latest version of 3Dconnexion driver, 10.4.1)

 

I'm on a mac, El Capitan

 

Using a 3dconnexion Spacepilot (it's an old model, buttons are not expected to work but the joystick is supposed to be fully supported)

Edited by lineweight (née col37400)

Share this post


Link to post

Recommended Posts

  • 0

I`ve got my  3Dconnexion device since a few weeks and since a  few days it only works on 1-axes at the time.

Very odd.

In SU it works as supposed...

Share this post


Link to post
  • 0

I'm having overshoot issues as well with my SpaceNavigator. Some things work ok and at other times a small movement of the know launches you into outer space on the drawing. I've adjusted the speed settings too and this does improve a bit but I've not been able to pinpoint it. Though I haven't been using the SpaceNavigator that extensively in 2017, also partly because of this issue.

Share this post


Link to post
  • 0
42 minutes ago, Bas Vellekoop said:

I`ve got my  3Dconnexion device since a few weeks and since a  few days it only works on 1-axes at the time.

Very odd.

In SU it works as supposed...

 

Just tried it with SP1.

 

After not reacting very much I switched through all of 3 VW modes a few times.

After that it seams to work for me.

Share this post


Link to post
  • 0

I've just installed SP1. Have also restarted the computer, etc.

 

But I'm still having the same problem I describe in the OP. It's not like what Art V describes - it's not an intermittent problem. It's consistently the case that the minimum speed of movement is set at a speed that makes using the 3d mouse uncomfortable and difficult when working close up to objects. It's a problem on the axes I mention in the OP; on the other axes it's ok.

 

@JimWis this something you can help with at all?

Share this post


Link to post
  • 0

I can not, I had the issue initially upon first using it with 2017 sp1 but after reinstalling the drivers for it it went back to working as normal for me too.

Share this post


Link to post
  • 0

I've just tried reinstalling the drivers too - but no luck.

 

It's only really noticeable when zoomed in quite close to something - and the closer you are the more unusable it is. Do you have smooth movement even when you're zoomed in close to something?

 

I have my drawing set up in millimetres and when I have, say, 100-200mm in my field of view it's an issue. I can post a video if it would help.

Share this post


Link to post
  • 0

I have kind of a similar effect.

 

When I'm in a 3D View, like right isometric, and touch the Spacnavigator the objects diaaspear immediatly and the display coortdiantes are lightyears off.

Before SP1 I could hit "CMD a" and then  "CMD 6" to get to focus on the objects again, and after this the Spacenavigator

worked fine.

 

With SP1 the effect "improved".

The only way to work now with the Spacenavigator ist to start from TOP-View.

From there It works fine.

From all other 3D-Views the focus of the screens jumps to Mars when I touch the Spacenavigator.

"CMD A" and "CMD 6" bring the objects back, but only till I touch the Spacenavigator again :-(

 

any idea how I can get this fixed?

 

best Horst

 

 

 

 

Share this post


Link to post
  • 0

Noticed this today to,

although not touching the Enterprise, just their CADMouse.

 

Maybe it has to do something with their 10.4.2 driver that I installed yesterday ?

 

 

Generally my cursor jumps from time to time by some words when writing answers in the forum,

but that happened since the beginning of using the CADMouse and Enterprise.

Sometimes Enterprise crashed with a black display in 10.4.1. In this case the cursor jumped over

the whole Screen.

(This did not happen so far with 10.4.2)

 

But did the directions change with SP1 or 10.4.2 ?

 

I switched through all modes but don't get a real "Flyover" anymore.

Is there any new recommendation from VW ?

 

 

Share this post


Link to post
  • 0
1 hour ago, Horst M. said:

I have kind of a similar effect.

 

When I'm in a 3D View, like right isometric, and touch the Spacnavigator the objects diaaspear immediatly and the display coortdiantes are lightyears off.

Before SP1 I could hit "CMD a" and then  "CMD 6" to get to focus on the objects again, and after this the Spacenavigator

worked fine.

 

With SP1 the effect "improved".

The only way to work now with the Spacenavigator ist to start from TOP-View.

From there It works fine.

From all other 3D-Views the focus of the screens jumps to Mars when I touch the Spacenavigator.

"CMD A" and "CMD 6" bring the objects back, but only till I touch the Spacenavigator again :-(

 

any idea how I can get this fixed?

 

best Horst

 

 

 

 

What you describe is different to my problem.

 

My problem only really becomes apparent when you are zoomed right in on details of a model - then the movement on certain axes becomes hard to control because it won't move below a minimum speed.

 

So for example if I'm looking at a 40mm wide window frame, and just touch the joystick in the "up" direction for the shortest possible time, my viewpoint will have jumped upwards by maybe 75mm. Not to mars, but enough to make fine control of viewpoint positioning very difficult when working at close details.

 

I've found that it's worse in "helipcopter" mode than it is in "target camera mode" but it's a problem in both.

 

If I'm working in 3D I use a perspective view (not sure why anyone would want to use an isometric view??) but I just tried viewing the model in a "right isometric" for example and something strange does seem to happen when I touch the joystick - I didn't fly off to Mars but I suddenly seemed to be looking at the other side of the model.

 

I've got it on 10.4.2 at the moment.

 

I hope the promised 10.4.3 arrives soon and sorts things out. It's making life quite difficult at present.

Share this post


Link to post
  • 0

Any hope of any progress on this?

 

There was no improvement with the 10.4.3 driver.

 

I've been using my 3DC device quite a bit over the past few days and this jerkiness is very irritating.

 

It's worst when zoomed in to details but I am noticing it also when I'm just doing a walkaround of a building. It's frustrating because it was ok in VW2016, so it must be possible to fix it.

 

Please??

Share this post


Link to post
  • 0

I unfortunately can not replicate the jerkiness here, when I'm incredibly close to objects they move quickly, but not jerkily. There is no way I know of to alter the movement speed relative to how close you are to what size geometry, since there is no zoom factor in perspective view and no other way to indicate to the device how close you are to objects of any kind.

Share this post


Link to post
  • 0

For me the problem is, that opposed to fly over tool,

the center settings are ignored for Enterprise or my old 3D bubble.

 

It always rotates around file origin for me.

Very seldom it accepts a selection but only for one time. I can't use an other selection again.

 

What I want is to use object mode only and I want only rotate about view center or selection as an alternative.

Share this post


Link to post
  • 0
3 hours ago, JimW said:

I unfortunately can not replicate the jerkiness here, when I'm incredibly close to objects they move quickly, but not jerkily. There is no way I know of to alter the movement speed relative to how close you are to what size geometry, since there is no zoom factor in perspective view and no other way to indicate to the device how close you are to objects of any kind.

 

Hi JimW,

 

When you say incredibly close, how close do you mean? Are your drawings set up in metric or inches; could that make a difference?

I notice it particularly when I'm doing a slow-speed "fly-through" where I'm combining several axes of input at once, so say rotating whilst also moving up/down or left/right. The rotation is fluid but the up/down/left/right is jumpy when I'm trying to move at the threshold of the "minimum speed" where it either moves at that speed or stops dead. It's noticeable when moving past objects that are, say, 1 metre away from me... I wouldn't describe that as incredibly close; it's the sort of distance that's common when moving around an architectural model. If it would be any help I can post a screen recording. This is in "helicopter" mode.

 

I draw in millimetres, but I can't fly smoothly around something that's 1000 drawing units away from the camera viewpoint...this doesn't seem right to me.

 

I don't understand the technicalities of the device "knowing" how close it is to objects...but it must somehow be aware of unit size because if I scale the entire model up by a factor of 10, doing the equivalent flythrough is then smooth.

 

Is there no way to adjust how the motion is related to drawing units? ie. if the device could treat one drawing unit as if it were 10, then it would be fine.

 

Testing just now, moving upwards at the minimum speed (that is, the very slowest it'll move if I just nudge the joystick ever so slightly) it takes me approximately 4 seconds to move the camera eye level from floor to ceiling in a 2.5m high room. So that's a speed of about 0.6m per second which is about 1.4 miles per hour. That's only about half of what would be a moderate walking pace ... it seems way too high to me... obviously accelerating from zero to half walking speed instantaneously would be impossible in real life so that's why the motion doesn't feel natural.

 

If the "minimum speed" you can replicate is a lot lower than that then I'll have to accept that it might be a problem with my setup here.

 

 

 

 

Share this post


Link to post
  • 0

TA further observation:

 

- In "helicopter mode", it's an issue, as described above.

- "Target camera mode": the movement speed is ok. If I do the same test as above, seeing how long it takes me to rise at minimum speed from floor to ceiling, it takes 2 or 3 times as long. The jerkiness only becomes apparanet when zoomed right in on a detail. *BUT* it's glitchy and sometimes just goes mad, and I have to unplug/replug the device to sort it and 

- "Camera mode": same issue as Helicopter mode

- "Object mode": something goes wrong and I jump into space

 

So something is implemented differently comparing helicopter mode and target camera mode, where the up/down movement minimum speed is set differently. Is it possible to find out what makes the difference? Are these different modes determined by Vectorworks or do they take advantage of different modes built in to the device?

 

Share this post


Link to post
  • 0


...and as I said previously, it was ok in VW2016.

 

So it seems to me that there must be something within the VW implementation that affects this?

 

Edited by line-weight

Share this post


Link to post
  • 0

Something I've just discovered:

 

The speed of navigation seems to be relative to the "scale" of the design layer you are viewing.

 

Most of my design layers are set at 1:50.

 

Working on a new file where the scale was set to 1:5, I found that the 3DC navigation speed was much slower, looking at close details and therefore the "miminum speed" threshold ceases to be an issue at close quarters.

 

Maybe I should start setting up drawings with design layers at larger scale. I expect it will mess up something else somewhere though.

 

Why do design layers have a "scale" anyway? I suppose it comes back to top/plan view somehow.

 

In a proper 3D modelling world surely design layers should be scale-less. Everything that needs to be drawn at a certain scale should be determined by viewport scale or in annotations.

Share this post


Link to post
  • 0

I generally work in 1:1 in the design layer for 3D modeling and then only scale viewports so they'll fit on the page. Unless you have a referenced layer or some kind of outside information you need to match the rest of your document's layer scales to, then the layer default scale of 1:1 is normally the easiest to work in.

Share this post


Link to post
  • 0
13 minutes ago, JimW said:

I generally work in 1:1 in the design layer for 3D modeling and then only scale viewports so they'll fit on the page. Unless you have a referenced layer or some kind of outside information you need to match the rest of your document's layer scales to, then the layer default scale of 1:1 is normally the easiest to work in.

Jim: can you clarify why 1:1 is easiest for 3D modelling?

Share this post


Link to post
  • 0
29 minutes ago, line-weight said:

The speed of navigation seems to be relative to the "scale" of the design layer you are viewing.

 

Most of my design layers are set at 1:50.

 

Working on a new file where the scale was set to 1:5, I found that the 3DC navigation speed was much slower, looking at close details and therefore the "miminum speed" threshold ceases to be an issue at close quarters.

 

 

^ This is one of the reasons. Others include texture mapping being exported properly to other 3D modeling software, importing 3D models from external sources (This is becoming rarer however, Vectorworks can now understand the units or overall dimensions of most imported geometry from most sources) and since it's the default, it is more of a question of "Why would you change the scale away from 1:1?"

 

I most commonly see non-1:1 design layers either as a matter of old habit, or it's done when printing directly from a design layer and not utilizing viewports which have their own scaling and sheet layers which give you greater control of page layout. However, if you place text directly on the design layer instead of in the annotations of viewports, the scaling has to be altered or you have to use extremely large font sizes. There are pros and cons to both lines of thinking but in raw 3D modeling generally 1:1 is more beneficial than not.

Share this post


Link to post
  • 0
3 minutes ago, JimW said:

 

it is more of a question of "Why would you change the scale away from 1:1?"

 

 

When i am editing floorplans in top/plan view I like to get a bit of a preview of line weights, hatches etc as they'll appear at the scale it will most likely be printed at. In my case I set it to 1:50 because I tend to have 1:50 GAs and so on. If I set it to 1:1 this ability will disappear.

 

In an ideal world perhaps instead of design layers having an intrinsic scale there would be a dropdown somewhere called "view at ... scale". Maybe saved as a property of saved views.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...