Jump to content
  • 0
ronster08

Temporary switch to pan tool with spacebar not working correctly

Question

Has anyone else experience issues with the temporary activation of the pan tool by pressing the spacebar? I use this shortcut all the time, but it's recently stopped working correctly for me. At present when I try to temporarily activate the pan tool with the spacebar it flickers on briefly and then switches back to whichever tool I originally had selected. I haven't done any software upgrades in the last couple months, and the spacebar/pan tool was working just fine a few days ago. When I activate the pan tool with (H) or by selecting it from the tools palette, it works. I'm working on an iMac with OS 10.11.5 (with 16GB of RAM). I'm using VW2016 SP4. (And I just did a check for updates, and my version is currently up to date.)

 

Thank you for any advice you may be able to offer!

  • Like 1

Share this post


Link to post

13 answers to this question

Recommended Posts

  • 0

I've been having the same problem and I just discovered that if I hold down the center scroll button on my mouse it has the same function as holding down the spacebar. This doesn't answer the question as to why spacebar no longer activates the pan tool but if you are using a mouse it is a good alternative.

Share this post


Link to post
  • 0
On 5.10.2016 at 2:25 AM, ronster08 said:

Has anyone else ....

 

Indeed, Space Bar does no more work as view drag in VW 2017.

Share this post


Link to post
  • 0

Not able to confirm this here. Shut the machine down, restart it launching ONLY Vectorworks and no other applications, then test the space bar. If it works, open your other commonly used applications like your browser and email clients and see if the spacebar ceases to work after launching any of them in particular.

Share this post


Link to post
  • 0

You are right, it works.

You just have to click in the view window to activate before using SPACE+Dragging.

 

It will also show then the hand icon again.

Share this post


Link to post
  • 0

I have also been having this problem, starting only a couple of days ago. Rebooting as per JimW works, but is there a bug fix in the works?

Share this post


Link to post
  • 0
24 minutes ago, Paul Stapp said:

I have also been having this problem, starting only a couple of days ago. Rebooting as per JimW works, but is there a bug fix in the works?

 

For what OS and what version of Vectorworks? We would have to be able to replicate the cause specifically in order to file a bug.

Share this post


Link to post
  • 0

What other applications do you have running at the moment? Does it always stop working around the same time or does it seem random? 

 

We used to have an incompatibility with some versions of Office but those were resolved (also Im running 2017 SP2 on macOS Sierra here with 4 office v15 products open and can't reproduce it) 

Share this post


Link to post
  • 0

This morning I think I just had Safari (10.0.1) and maybe Acrobat Pro DC (2015.020.20042). Yesterday I think I also had Photoshop CC (2017.0) and Illustrator CC (2017) open. I just now re-opened all of those, and the spacebar+mouse works just fine. I don't even have Office on my machine.  

Share this post


Link to post
  • 0

For me it just needs a Click into VW Window, to re-activate VW after you switched from an other View.

As long as you just activate VW from the Dock, it is just in a sleep state and doesn't react to inputs.

(Maybe only when you use Screen Spaces for your Apps)

 

When VW in an active Mode, SPACEBAR PAN works reliably.

Share this post


Link to post
  • 0

No, the Vectorworks window was definitely active. All the other keyboard and mouse commands (or at least the ones I regularly use) worked perfectly, just not the spacebar pan.

Share this post


Link to post
  • 0

Still SPACEBAR or middle Mouse Button work fine here for me.

 

But the last half year I often read on forums, no matter what software, that people suddenly

miss things like their ALT key or other important short cuts do not work for any reasons in

one single App, while everywhere else there is no problem.

Share this post


Link to post
  • 0

Had the same problem (spacebar-pan ceasing to work suddenly) this morning after always working fine. I also had Safari running and prompted by one of the ideas above, I quit Safari. That did the trick! The spacebar-pan shortcut was working fine again. Rebooted Safari and spacebar-pan still working fine so looks like it's possible that something in Safari scuppers that invaluable shortcut at random?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×