Jump to content
  • 24
Kevin McAllister

Fix editing within all container objects

Question

22 answers to this question

Recommended Posts

  • 0

THIS IS LITERALLY MY BIGGEST PET PEEVE WITHIN VECTORWORKS. YES YES YES PLEASE WORK ON THIS.

 

I encounter the types of things described above every single day and it really slows me down. It's something I've always wanted to wish for but there's just so much weirdness and it's so inconsistent I've never said anything about it. But it seriously needs to be addressed.

Share this post


Link to post
  • 0

Regarding Paste in Place... The only time where it makes sense for something to paste into a "different place" than on the designer layer is when Pasting-in-Place into a Symbol. This is because Symbols have their own origin (the insertion point) which is the 0,0 when editing the Symbol. OIP coordinates are based off of this insertion point, and I would expect Paste-in-Place to also be in relation to this origin (even if it's sometimes not as convenient).

 

However, I've noticed other types of objects save their own "origin" when they really should not, such as within Solid Additions, Solid Subtractions, sometimes even Extrudes randomly. These / everything else should be in relation to the world origin.

 

Note also that it's not just an origin offset that's the issue, but also rotation.

Edited by Andy Broomell

Share this post


Link to post
  • 0
8 hours ago, Andy Broomell said:

Regarding Paste in Place... The only time where it makes sense for something to paste into a "different place" than on the designer layer is when Pasting-in-Place into a Symbol. This is because Symbols have their own origin (the insertion point) which is the 0,0 when editing the Symbol. OIP coordinates are based off of this insertion point, and I would expect Paste-in-Place to also be in relation to this origin (even if it's sometimes not as convenient).

Yes and no. If I'm pasting from outside a symbol to within a symbol this makes sense. But if I cut and paste in place all from within a symbol it should work. The same should hold true when editing within an extrude. I should be able to cut and then paste in place in the same editing space and have it work reliably. I should also be able to cut, switch from one edit space for a symbol (eg. the 3d component to the 2d component) and then paste in place with reliable results.

 

KM

Share this post


Link to post
  • 0
2 hours ago, Kevin McAllister said:

 I should also be able to cut, switch from one edit space for a symbol (eg. the 3d component to the 2d component) and then paste in place with reliable results.

 

Definitely. In this case, one would assume the origin/insertion point are the same since it's the same Symbol, so it should work reliably. Should.

Share this post


Link to post
  • 0

I'm bumping this thread and adding -

 

More time needs to be spend beta testing editing within container objects. There are currently a number of forum threads about disappearing objects and graphics issues when editing within containers. Hopefully analytics show that this type of editing is common in most workflows and that this merits significant attention.

 

Kevin

  • Like 1

Share this post


Link to post
  • 0

It might help a little if there would be an option that allows you to select the copy origin for an object so that when you paste it you can control the exact paste location. Somewhat similar to AutoCAD's copy with origin where you can select the origin point of your copy so that you have more control over exact placement when pasting it elsewhere or in another document (or in VW's case in a symbol container)

Edited by Art V
  • Like 2

Share this post


Link to post
  • 0

Agreed, this issue makes autohybrids almost unusable for me - the paste-in-place problem plus the fact that they can't contain groups makes editing them very difficult in anything other than a very basic model.

Share this post


Link to post
  • 0

I have to tear this into its component parts. I COMPLETELY get you folks and what you mean, I see the same things myself, but I have to break it up into bites for this one since it functionally touches similar items but on the back end they're handled by completely different engineering teams.

 

First attempt at pulling it apart, I will hold off a bit to get some feedback before I file them, feel free to torch and pitchfork:

 

For the purposes of this list, "Containers" refers to: Groups, Auto Hybrids, Symbols, Solid Subtractions/Additions/Sections, Viewport Crops, Path or Profile containers, 

 

1) Paste in Place within a container should paste at the coordinates of the copied objects relative to the location of the container being edited, NOT relative to 0,0 in the document and 0,0 in the containers internal coordinate system.

 

2) Rendering of all geometry within Containers should match rendering outside a container (these are bugs and will be separately filed as bugs not wishes)

 

3) Snapping should work within Containers should behave identically to snapping outside containers unless geometry outside the container is not being shown.

 

4) Align/Distribute and Array commands that work relative to the current view should work relative to the user's current view within the Container, not to what the view was before editing the Container.

 

5) 2D geometry added to the 3D component of a symbol should remain visible until the symbol edit is complete and have a permanently-dismissible alert informing the user of this change.

 

Let me know what I've missed or detailed incorrectly.

  • Like 1

Share this post


Link to post
  • 0

@JimWyou're wearing your super hero cape again today, aren't you?

 

Just so the related wishes in the other thread don't get lost -

 

Quote

When editing in symbols and switching between the 2d component and 3d component the position of the view on screen shouldn't shift. Also, the symbols origin point should be visible and snap-able at all times regardless of which component you are editing.

When editing the 3d component it should be possible to draw 2d objects as guidelines and not have them disappear. They're still there but not visible for some reason. These 2d objects shouldn't jump to the 2d component for any reason (ie. switching to top/plan) other than when you exit the symbol or chose Edit 2d Component from the right click contextual menu.

Kevin

 

5) The screen view shouldn't shift when switching between components of a symbol for editing (2d component, 3d component, wall hole component).

6) The symbol origin should be visible and snap-able at all times while editing within a symbol regardless of view or the component being edited.

 

I'll give your other list some though to make sure nothing has been missed. Basically the overall design is to have working within container objects feel the same as working directly within the design layers.

 

If wish threads are being judged based on number of "votes" note that the other thread has 9 votes too :-)

 

Kevin

  • Like 1

Share this post


Link to post
  • 0

I ate my wheaties!

 

5 minutes ago, Kevin McAllister said:

If wish threads are being judged based on number of "votes" note that the other thread has 9 votes too :-)

 

I refuse to admit how long I poked at it this morning to get merging two threads to merge the vote count, but currently it just takes the vote count of the older thread (it should totally merge the votes and just remove duplicate votes from the same user accounts) so for now I just locked the old one and referenced it to this one until I can get a better method established.

 

I will post an updated list after some feedback with the needed changes.

  • Like 2

Share this post


Link to post
  • 0

There's the containers-in-containers thing too but maybe that's a separate issue.

 

eg. I can't have groups within autohybrids. This is one of the things that's led me to decide they are basically of no use to me, for now.

 

Also, re. the paste-in-place thing, it also applies to pasting between layers with different Z heights. Again, maybe this should be considered a separate issue.

Share this post


Link to post
  • 0
1 minute ago, line-weight said:

There's the containers-in-containers thing too but maybe that's a separate issue.

 

eg. I can't have groups within autohybrids. This is one of the things that's led me to decide they are basically of no use to me, for now.

 

Separate from the individual items listed above but totally within the overarching topic, I will add this.

Share this post


Link to post
  • 0

Sorry, I don't find the correct Thread again.

 

Just want to point out,

I am not completely sure if Extrudes may need an internal own Coordinate System/Workplane + Rotation or not

because of any dependencies. It is just me who does not see a reason for now.

 

But anyway, own rotation needed or not, as I see now Currently for Extrudes - it is just completely broken in VW 2017 !

When Pasting in Place it behaves completely irrational and arbitrary.

Also when you go into edit mode, the 2D geometry is shown at a totally different place as the environment.

 

Even if nothing was moved or rotated, just from one Extrude into a copy of it at a differen Z height.

And I can't remember that I had any problems or annoyances with internal Extrude's geometry until 2016.

Maybe there is just something broken with 2017.

Edited by zoomer

Share this post


Link to post
  • 0

After SP3 I want to bump this again and reiterate.

 

 

It is ONLY about Extrudes that include multiple 2D Objects.

 

Like when you have multiple 2D rectangles that you Extrude at once to get your Columns.

Those kind of "grouped" Extrudes that you can ungroup to get single separate Extrudes again.

So I see these as a Group.

 

Symbols have their own origin - I think that is OK.

Groups have no internal origin. They are just a virtual net that keeps including geometry together.

Therefore Groups have also no Z value in OIP. (Why do they have X aynd Y ?)

 

I can't oversee if an internal origin make sense for Extrudes that contain only 1 single 2D Object

like Symbols do. But I want that Extrudes behave like Groups when including multiple 2D Objects.

 

And I want to be able again like in previous VW versions,

to cut and paste objects between different Extrudes or from outside

related to the global User Origin.

No matter if I moved or rotated the Extrude any time before.

 

 

Currently in VW 2017, all Objects are forced to sit on a "Plane : Extrude #1", wherever that may be located.

It is also broken because, if you use vertical copied Extrudes, they should have the same internal origin,

but it does not work either as some of the former translations or rotations may get lost while duplication.

(Or maybe the coordinates get mixed between internal and user origin WHILE the Cut And Paste process ???)

 

The next problem is that the Location of visible Geometry outside of the Extrude is not displayed correctly

when you had moved the Extrude at one time !

(Same for Grid display)

This way you can't even snap to underlying geometry because you will be off with your geometry after you

left Extrude Edit Mode.

 

 

 

 

Share this post


Link to post
  • 0

There is still a problem with the refresh of the position of the internal Extrude Plane.

 

Steps :

 

1. In Iso View, create some 2D Rectangles anywhere and Extrude them

2. Go to Top Plan View

3. Show Grid and activate Grid Snap

4. Drag an Extrude from one of its corners to a Grid intersection

5. Edit Extrude and see >>> the Grid is OFF

----------------------------------------------------------------------------------------------------------------

6. Drag the Rectangle from one of its corners to a Grid intersection

7. Exit Extrude  and see >>> the Extrude is now OFF the Grid again.

 

 

The funny thing is that after editing other Extrudes,

the former Extrudes internal Plane will finally refresh and match the

VW Layer Plane again at one time.

 

Edited by zoomer

Share this post


Link to post
  • 0

Bumping this thread. Editing container objects in VW2018 is even worse than ever. Sigh... I wish I didn't need symbols. Editing within them has become so frustrating.

 

Kevin

Share this post


Link to post
  • 0

For a Symbol I am fine with that.

 

But those Extrudes, just very comfortable to edit.

And my special Extrudes, by a bunch of 2D Objects extruded, are only needed because

otherwise in VW I could only edit one object at a time only + Selection is limited

and/or simply there is a proper parametric Cube/Slab Solid missing in general.

Edited by zoomer

Share this post


Link to post
  • 0

Thanks for articulating this one Kevin. Very frustrating. And, frankly, a bit amateurish for advanced CAD software.

  • Like 1

Share this post


Link to post
  • 0
Posted (edited)

The only items I might add to this list of containers are wall recesses and projections. 

Edited by cberg
  • Like 1

Share this post


Link to post
  • 0

This might be in this thread already or in some other topic, but I've recently noticed that when rendering inside a container, RW backgrounds don't appear. I assume it's a bug, but I can't remember if it's always been this way / working as designed.

 

One would expect that if your render style has a RW background assigned to it, the background would show up even if rendering inside a Group.

Share this post


Link to post
  • 0

Hopefully the fixes requested above are part of the 1300 that @JimW mentioned. (yes this is a hint for a small leak on VW2019 😉)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×