Jump to content
  • 0

Exporting non English characters to DWG format

joey altalef


I'm not sure if this happens with all non English letters, but when you print a document or create a PDF from a file exported to Autocad containing Hebrew letters, the letters will be mirrored in each word. If I create a Pdf using Vectorworks it will be fine, but using Autocad the letters will be alterated...and that makes our technical consultants angry :) ..(they all use autocad..>:()

I uploaded here a Vectorwork file containing a hebrew word, its Dwg exported file, and the PDF created by Autocad.

Is this a problem in Vectorworks or Autocad? 

Any ideas how to deal with this?



joey - Vectorworks 2017



Test 2.pdf

Link to comment

8 answers to this question

Recommended Posts

  • 0

It can be solved in Autocad. Unfortunately Vectorworks still does not export text styles to dwg files, so it take a bit of searching to find the correct text style in AutoCAD.


The text style in your dwg is Arial, and it is set to Western in the language column, which makes it a left to right text order. When you set the language to Hebrew then the text will show up correctly.

Link to comment
  • 0
1 hour ago, joey altalef said:

Hi Art V


It still doesnt work.. in your free time could you try to convert the Test2.dwg that I uploaded before to pdf?



Attached are the PDF and dwg file renamed to test2a with the update in the dwg file to set the Arial style to be a Hebrew font instead of Western. Now the Hebrew text shows the same as in VW2017.




If I wouldn't change the language in the Arial text style from Western language to Hebrew language in the dwg file I'd get the same result as you did.

Edited by Art V
Link to comment
  • 0

Thanks ArtV!


What version of Autocad do you have? I have Autocad2013 and cant find that language setting window you showed. 


I found out that if you use the "export to pdf" option in autocad, it will always give a good result on the language issue.. but if you use the "print" and chose your pdf printer, it will always mirror the hebrew letters, same as creating a plot file.


I'll have to convince my consultants to creat PDF files and not Plot files.






Link to comment
  • 0

The above screenshot of the text style was from Bricscad. Since I normally don't have to deal with right-to-left fonts I had assumed that AutoCAD would have a similar setting for language since Bricscad attempts to be feature compatible with AutoCAD as much as it can.

Just checked in AutoCAD 2016 and nope, no language setting. There is an option for backward but that also mirrors the text instead of just changing the reading direction.


If the consultants insist in printing to PDF instead of exporting to PDF your best bet might be to have them either switch the locale of the computer to Hebrew or install Hebrew fonts and probably shx versions instead of TTF as shx fonts seem to work more reliably in AutoCAD than TTF fonts for non-western languages, supposedly. That way Hebrew text should show up properly.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...