Jump to content

VW2017: Open to full width, migrated workspace

Recommended Posts

Every time I open Vectorworks it only fills about half of the screen. Then I double click the title bar to maximize its size (I'm on a Mac). Why doesn't it remember this from session to session? I know it's a small thing but it's annoying to have to resize it every time I open the program.

Looking into this further I see that it's not a problem with the default workspaces (which open full width), but only my custom workspace which was migrated from 2016. I've tried "Save Palette Positions" but that doesn't help.

I hope the answer isn't to rebuild my workspace in 2017 because I have a metric ton of customizations...

Link to comment

Do you work in "full" Full Screen Mode ?

I do only work with the "Soft Full" Screen Mode,
meaning I "ALT+Click" on the Green Light,
to maximize the App Window only on normal screen.

That Size will be kept by OS X.

(I have set double click the title bar to hide App in Dock)

Edited by zoomer
Link to comment

Perhaps there is a little difference between title bar double click and ALT+GREEN "zooming" ?

Have you tried to resize the window from standard mode manually to max the size ?
Perhaps that way the size is kept ?

For me it works by ALT+GREEN.
But I remember having had smaller V Window when same file was saved on my Macbook in between.

Link to comment
  • Vectorworks, Inc Employee

Does anything else reset to default settings after restarting Vectorworks? Or just the workspace positioning?

In either case, this article is designed to fix a separate issue but if the problem is related to permissions this will guide you through manually fixing them:


This will not damage your workspace or other customizations.

Link to comment
  • Vectorworks, Inc Employee

If you close Vectorworks, (and any other apps, since we're going to poke something that might mess with their positions) then go to Apple menu > System Preferences > Display, pick a different resolution or scaling option, anything other than it's current setting. Then, relaunch Vectorworks and expand it, then restart Vectorworks, does it keep it's position? If not, does it look the same way off as it does in your screenshot or does it do something different? You can put your resolution/scaling back the way it was after the test in any case.

It seems odd to try, but it might narrow down which thing is messing with it's location memory, since Save Palette Positions and/or closing Vectorworks is supposed to write that setting to your VW prefs folder and permissions with that folder wasn't the issue.

Link to comment
  • 3 months later...

Has there been a fix to this issue?  I have experienced the same thing ever since upgrading to VW2017.  I used to think it was because I was running an external monitor with a Macbook Pro.  However, I've since upgraded to a Mac Pro, and the issue still persists.  Vectorworks 2017 was installed as a fresh install on the new machine, so there shouldn't be any issues with importing an old workspace.  When I open the application, the window only covers the left 4/5 of the screen.  I option-click the green button in order to maximize the window and all is fine.  Not a huge issue at all, but if there's a fix, I'd love to know.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...