Jump to content
  • 0

Package Manager / Library Issue



Just installed VW 2017, and installed the libraries I needed with the package manager.  All of them are showing up, however, the Lighting Instrument Libraries are not showing up.  The package manager says they are installed, but they are not anywhere under the resource browser.  In checking the library folders, the files are not even there.  Is there a way to force the package manager to re-download the libraries?



Link to comment

15 answers to this question

Recommended Posts

  • 0


Having a similar issue.  Trying to install the libraries with package manager and install hangs/freezes on certain libraries. Most of the Building Services libraries won't install, and neither will the spotlight libraries.  Status just says "Downloading....." and progress bar is at full, but it just hangs there.  I've tried uninstall and reinstall of VW2017, deleting the 2017 Library folder, deleting cache folder, and problem persists.  Please help!!

  • Like 1
Link to comment
  • 0

Hi all, My first post in this forum so please excuse any mistakes in the format. I have the same problem as  APoe. 
My setup is as follows:

  • MacBook Pro (Retina, 15-inch, Late 2013)
  • macOS Sierra Version 10.12.3 (16D32)
  • VW 2017 SP3
  • Vectorworks Site Protection Server

Where there a lot of changes to the VW Spotlight library or can I copy the library over from a backup of SP2?


Thank you for your help

Edited by lampie
Link to comment
  • 0
  • Vectorworks, Inc Employee

If you are on a Mac and experiencing the issue where libraries do not install, try the following:


1) Close Vectorworks.

2) In your Application folder, right click on the Vectorworks 2017 folder and choose "Get Info"
3) Set the permissions so that each listed user (System, YourUsername, etc) is allowed to Read and Write.

4) Then, click the lock at the bottom right, unlock it with your admin password if prompted

5) Click the gear and choose "Apply to enclosed items" like so, it may take a few moments to finish:




6) Reboot your machine, then restart Vectorworks and try installing the libraries, let me know what happens please.

Link to comment
  • 0

I tried your suggestion, but it still won't work. In the packet manager some items have a little picture next to them and these are the ones I can download, but none of the spotlight libraries have a picture next to them and they fail. Status starts as on the picture below, but never finishes...





Link to comment
  • 0

I'm having the same issue as @lampie,@APoeand @trodman. Package manager gets stuck at some specific libraries while downloading. I did a clean install of Vectorworks 2017 with all of its subsequent service packs up to SP3 and the package manager still gets stuck at "Sanitary Fixtures from: American Standard and Bradley"  I tried changing the permissions of the application folder but it didn't work, I don't have any backups of the library either. Any suggestions?


System specs:

MacBook Pro (Retina, Mid 2012)

2,7 GHz Intel Core i7

16 GB 1600 MHz DDR3

NVIDIA GeForce GT 650M 1024 MB

macOS Sierra 10.12.3

Vectorworks 2017 SP3


Link to comment
  • 0
  • Vectorworks, Inc Employee

Users that were having difficulty downloading the entire resource libraries should reboot their machines and try again. I have been informed that a server side issue with that system has been corrected. If the same behavior occurs, please let me know.

Link to comment
  • 0



I have helped three or more users to date with this issue, all were using macOS Sierra. 


I discovered that when fixing the permissions of the entire 'Applications' folder (as instructed above), the 'Apply to enclosed items' doesn't affect the Vectorworks subfolders. But when I selected the actual Vectorworks application folder, made sure the permission were set right, then used 'Apply to enclosed items' this DID then apply to all subfolders. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...