Jump to content
Andrew Davies

3DConnexion Mouse

Recommended Posts

Yes, it's the Touch version.

2 Finger Touch Zoom would(*) work fine(**) to Zoom in VW.

 

Unfortunately the "Scroll by Pen Movement" that simulates a scroll wheel does lag in VW,

also it would cost my "MMB"

 

(*)

Touch is off for 3D/CAD as I lay with my whole arms on my screen.

I would need long sleeved arms and gloves with finger cut outs to do so

 

(**)

Even a real mouse wheel zoom lags sometimes in VW (2017) for me, with crowded files,

as long as the cursor hovers over potential snapping points.

This does not happen 2 Finger Touch Zoom - I assume as there is no cursor hovering to snap points

Share this post


Link to post
1 hour ago, zoomer said:

(*)

Touch is off for 3D/CAD as I lay with my whole arms on my screen.

I would need long sleeved arms and gloves with finger cut outs to do so

 

So palm/arm rejection doesn't work or isn't good enough for you?

 

1 hour ago, zoomer said:

 

(**)

Even a real mouse wheel zoom lags sometimes in VW (2017) for me, with crowded files,

as long as the cursor hovers over potential snapping points.

This does not happen 2 Finger Touch Zoom - I assume as there is no cursor hovering to snap points

 

Yes, this is a good point!!

 

Share this post


Link to post
1 hour ago, Chih-Pin said:

So palm/arm rejection doesn't work or isn't good enough for you?

 

It works ok but for one hand only, either left or right side.

But about every 20 minutes I may accidentally start any arbitrary App from my Dock with my elbow.

(mostly Solibri Model Checker)

 

Should keep my sleeves down ....

(Paint artists use it upright and with a glove)

But I do not have the typical flexible Cintiq stand. I like it as flat as possible.

 

Therefore no Space for the keyboard. I have it on top of the display. And therefore both arms on screen
 

 

Edited by zoomer

Share this post


Link to post

Hi All

 

I just thought I would take the time to post something that might help some people.

 

I am using a 3dconnexion spacepilot with VW 2017. I just purchased an Elecom trackball mouse which has been an absolute revelation in terms of accuracy and control, as with all new bits of kit I spent a bit of time allocating functions to buttons etc which led me to thinking that although I love my Space Pilot, it's always felt a bit limited in VW never working quite as well as I would hope, therefore reducing the amount that I used it, anyway today I decided that it was time I got this resolved. 

 

Issues I was having - 

 

2d and orthagonal navigation - useless - move the puck left or right up or down  and the geometry would disappear and then either if lucky reappear to the left or be miles away. in front views a rotation of the puck would result in a 90 degree change in view - front, right, back etc.

 

3d perspective views - significantly better but target view would regularly lose its fixed rotation point and other modes were less than satisfactory. 

 

I updated the driver for the Space Pilot and have the latest service pack for VW, but to no avail, so out of interest I opened up a file in VW 2016 and all the above issues weren't present.  So I went back into 2017 and went through all the preferences to see what could be causing the difference in performance and at last my Space Pilot is working as I always felt it should and as its price tag says it should!

 

Under the display tab in VW preferences at the bottom of the page is heading - NAVIGATION GRAPHICS: a drop down for this allows you to choose  - Best Compatibility through to Best Performance. By changing to best performance all the issues above were solved.

 

I'm sure many people have figured this out, but I was stumped so maybe this will help some other people.

 

Cheers

 

matt

  • Like 1

Share this post


Link to post

Hmmh,

as promised a gave the Helicopter (?) Mode a try and set my old Space Navigator Axes back

to@Luis M Ruizsettings.

But it still "Spins" (*) around file origin instead of my camera.

 

(* Spin = what's not supported and has to be set to "Roll" for VW)

 

 

Am I in any wrong 3D Mode ?

Are there still 3DConnection 3D Mode options - and how do I get their setting from VW Menu ?

(I need the 2 buttons for Selection Tool and Fit View)

Share this post


Link to post

Hi Zoomer

 

I haven't been following this thread very closely apart from posting my experience with navigation quality settings above, which made a huge difference to the usability of my Space pilot for me. I have attached my 3d Connexion mouse settings here which I won't bother going through as it gets complicated but these settings for my Space Pilot on my machine do exactly what I would want the controller to do, including

SPINNING AROUND MY CAMERA in Helicopter mode which sounds like what you want to get it to do. Apologies if this is how you already have yours set up, but this definitely works for me. 

 

Good luck with your problem.

settings.jpg

Share this post


Link to post

Yes, that is exactly what I have.

Same as what Luis postet some pages above.

 

And it looks reasonably (as long as one thinks a helicopter mode is reasonably)

beside the spinning around camera.

It always spins/rotates my model around the file origin here for me.

(And so the helicopter in that case)

 

That was also the only problem in my preferred standard 3D Object Mode too.

 

So I seem to have any strange setting in VW that causes that behavior.

Maybe in Unified View or VW Pref settings, but I don't find it.

 

For Example I deactivated "Center View on activated Layer" as it always made

my geometry jump out of focus when I switch active Layer,

by jumping to file or page origin.

Edited by zoomer

Share this post


Link to post

Ouch !

9_9

 

It works for you as you work in a Perspective Mode !

I always(*) work in Orthogonal Isometrics.

That is where it rotates about the file origin.

 

 

(*)

And why do I always work in Orthogonal Mode ?

- because a "perspective" Front/Left/Right/Back and even Top View is totally meaningless

- because I hate any "Cropped" perspective or camera Mode, which VW even re-activates

from time to time without being asked.

 

Sorry,

but I find that whole VW View System with its 2D/3D mixed up and arbitrarily unwanted view

changes in so many occasions so bad, tedious, irritating and just annoying.

Edited by zoomer

Share this post


Link to post

Yes I see what you mean just tried in isometric - I don't even get the option of helicopter mode just Target and as you say it rotates around the origin.

 

Sorry I don't have anything else I could think of. 

Share this post


Link to post

Found it.

 

1 - Set Perspective to "Normal" .. THEN choose your view modes. You get a whole new set:

  • Camera
  • Target Camera
  • 2d
  • Ojbect
  • HELICOPTER

 

Quote

 

Sorry  -- what is "Helicopter Mode" ??

 

I get options

  • 2d
  • Target
  • Object

??

 

 

Edited by Ethan R.

Share this post


Link to post

I think Target Mode is Helikopter.

 

Where do you get the option to switch between these ?

Depnding on current View Mode only or a menu ?

Share this post


Link to post
6 minutes ago, zoomer said:

I think Target Mode is Helikopter.

 

Where do you get the option to switch between these ?

Depnding on current View Mode only or a menu ?

 

I set the one of the SpaceNavigator buttons to "Switch Navigation"  and the other to "Switch Projection"

 

This is allowing me to experiment with all the different permutations quickly.  All sorts of new modes ! LOL!

 

The switching from Ortho to Perspective seems to be key in getting the 3d to work happily?

Edited by Ethan R.

Share this post


Link to post

Thanks.

 

Ok, the menu is still there.

Somehow the modes are flipped between Orthogonal vs Perspektive.

And maybe even "Roll Axes" mixed up for Object Mode.

 

And pity that it will not keep the mode when switching Views.

Share this post


Link to post
8 minutes ago, MRD Mark Ridgewell said:

Hi,

Looking to buy one of these...I see the thread is from a while back.....is it worth buying one?

 

SpaceMouse® Compact

https://www.3dconnexion.co.uk/spacemouse_compact/uk/

 


That's essentially the one I use, though I have an older model. I personally find the axis knob to be the most useful part so it's plenty for me, but I've spoken with others that like having the multiple mappable buttons on the more advanced models.

Share this post


Link to post

Only if you are serious about 3d.

I typically spend min 30hr per week on projects and at this point, I can't see myself without it. A couple of years back I started with the small navigator but now I use the space mouse enterprise. I need my shortcut buttons.

  • Like 1

Share this post


Link to post

I've used an old model of the "compact" SpaceMouse you linked to. I wasn't a huge fan, as it seemed too lightweight and would shift around as I tried using it.

 

Instead, I have the SpaceMouse Wireless which I love - the base is a bit heavier so it feels sturdier to use. Yet it's still fairly small and easy to toss in a bag. The battery lasts a very long time as well.

 

In general the SpaceMouse was one of the best investments I've made and I can't imagine navigating 3D interiors without it.

Share this post


Link to post
4 hours ago, Andy Broomell said:

 

In general the SpaceMouse was one of the best investments I've made and I can't imagine navigating 3D interiors without it.

 

Same. I have the spacemouse pro.

Share this post


Link to post

2 simple questions :

 

Does 3DConnexion Enterprise works for you with VW 2019 ?

 

Does VW 2019 offer Tool Icons on Enterprise Display - or just Text ?

Share this post


Link to post

After migrating my super workspace and update it with all the cool new features in v2019, my 3d enterprise works as usual. Although, I assigned new macros to some of those buttons, for example, activate clip cube seems to be one of my new favorites.

Share this post


Link to post

 Thanks Luis,

 

so it should work in VW 2019 without any special user interaction.

I also migrated my super Workspace from 2018 to 2019 - on my Mac,

without problems. But I copied that plus a few other settings from

Mac to PC recently. Maybe that destroyed something.

 

But the promised about 50 VW Commands are finally there for me too.

 

Are there any Tool VW icons delivered for Enterprise‘s Display ?

If there are, I have to go on trying to find them, if not,

everything is ok already.

Edited by zoomer

Share this post


Link to post

And a small thing made me wonder,

if I add Selection Command to a button, and hammer on it,

a second push will not De-Select.

But when I create a Macro with X Key, it will.

Edited by zoomer
  • Like 1

Share this post


Link to post

Hi All

 

I have often read this thread but never had the need to post a question as all the answers I have ever needed have been in here which has always been so helpful. I do now have a question and I really hope that someone out of all the experienced people on here can help me with this.

 

Today I upgraded from 2017 to 2019 (Architect) previously in 2017 I had my Space Pilot Pro working like a dream thanks to the configurations that have been posted on here over time and also with a bit of programming of macros and buttons. 

Anyway today when I launched 2019 after using migration manager to bring over my workspaces and templates I  noticed that my settings that had worked with the Space Pilot weren't working as usual - I like to swap a lot between 2d plan views and open Gl perspectives and as such have the central Iso and top left roll view button programmed to Ortho / Perspective and Wireframe/ Open GL. The other thing that didn't work is that I have programmed the Menu button to switch between navigation modes - Target / camera/ object etc. This also wasn't working and instead just brought up the default 3d Connexion menu. No problem I thought that didn't migrate over I will go into the 3d connexion properties and reprogramme the relevant buttons.

 

So I decided in the 3d Connexion properties to reprogramme my buttons. and this is where it gets weird and dare I say it as a long term VW user - unsurprisingly frustrating!

When I tried to re assign the menu button or any other button and selected from the vectorworks drop down list there are only about 8 items in the list, all view related - when I do the same in 2017 there is a 20 plus long list of varied VW tools that can be assigned to the chosen button. 

Its like having switched to 2019 the 3d connexion driver doesn't recognise VW properly and can't offer all the options that were available in 2017. On my mac you could add an application to the list in the 3d Connexion properties on Windows it's just there

 

I have uninstalled and installed the latest windows driver from 3d connexion but this has not resolved the situation, I do hope that someone might have encountered this and have a solution, as it stands it means that after 3 years of using my Space Pilot it has now become unusable as without being able to switch between navigation options I just go back to flying around in 3d space.

 

 

 

 

Share this post


Link to post

An update to my situation - I pressed 'restore defaults' in the 3d Connexion properties and now the long list of Vectorworks specific tools appears when I click on a button to reassign, however when I select for example Switch Navigations (or any other tool) to assign to a button, it initially appears as assigned to the button and then immediately the text disappears leaving the box next to the button blank. This is just weird and frustrating. As a question I have heard that migration manager has caused issues in other ways and I am wondering whether it might be causing this, I remember reading that you can delete something in the VW program folder that forces VW to create a fresh version of itself next time it's launched does this sound familiar to anyone.

Share this post


Link to post

@Mattsaxon

Since you mentioned you had v2017, here is my troubleshooting first recommendation.

 

Plan A-

Download the latest 3dconnexion driver.

Migrate your custom workspace

Edit custom workspace, now, since you skipped two versions, plenty of new tools and menus are missing from your 2017 workspace.

 

Plan B - Start a new custom workspace from scratch but pay attention to those shortcuts that you are used to.

 

For me jumping from 2018 to 2019 was all about adjusting my workspace, from 2017 to 2018, I created a new and fresh custom workspace, typically for me is a copy of Architect.

 

Is it tedious? Well, I find it to be not an immediate task, but it is something I take care of only once a year. Is it worth it? totally.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×