Jump to content

Bug: Keyboard Shortcut for Rotate Not Working with Move By Points Selected

Recommended Posts

I submitted a bug for this behavior, maybe a couple of years ago. At least I'm pretty sure I did, so many bug submits I can't remember them all. Anyway, never fixed, so just hit the "X" key to activate the selection tool before trying to activate the rotate tool, it's a habit by now.

Jim, whenever we say we would like VW to work with fewer glitches as a priority over new features, this is the kind of thing we are talking about.

Link to comment

Had similar issues with the mirror hot key.

Try to replicate this create a rectangle,

hit = and mirror

hit atl+= to rotate (it defaults back to the mirror tool)

Have to use the OIP cant use the hot key.

Do again and hold tab down it pops to the select tool

keep holding alt and hit = and it brings up rotate object angle selection.

Seems to be a few shortcuts by sequencing key selection I am not aware of.

Link to comment

Yes, it must be a bug, I have trained to hit X a few times before using the rotation tool, meanwhile I don't notice it anymore. But letting custumers learn the workaround should not be the way for programmers to solve a bug...

I'm working with a german keyboard on the english version of Vectorworks, and there is as well the problem that shortcuts are simply not translated and cause confusion, because they do not correspond with the mouseover-tipp-text. Too bad to say that, but I don't expect bugs like these to be solved within my lifetime...

Link to comment
  • 8 months later...
  • Vectorworks, Inc Employee

Apologies, I'm not able to reproduce this on 2017 SP2.

My exact steps:

1) Create a new blank document

2) Select an object (Rectangle in my case)

3) Activate Move by Points tool

4) Alt-= to activate the Rotate tool

5) Attempt to rotate the selected Rectangle


This worked for me, recorded it so that others can correct me if I'm misunderstanding the problem or to see if I am not replicating the steps properly:


Link to comment

I've remapped nearly every key stroke as I was an illustrator user, nipping between the two.


ive found that some shortcuts stop working after a while until a restart.

its always the same ones.... rotate, callout and sheet border.


cant replicate though. Happens on its own. Mainly to tool palette tools. 


when it happen to menu tools, alt+something I find that all menus are greyed out. Even save has gone. But in fairness, this is very very rare. 


not as frequent in this version but has been an issue in the past.


And, no... I don't import or migrate settings, I always set up from fresh on a new install.

Edited by RussU
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...