Jump to content

Extrude objects in group


RuudB

Recommended Posts

Hello all,

I am building an element with Marionette. This element contains a lot of control geometry that is used for the script. Because many objects within the element need the same handling, I divided it in groups. But the script is not working for these groups.

I added an example that shows the desired result (unwrapped) and the not working result (wrapped). Am I making a mistake, or is it a bug in Marionette?

Ruud

Link to comment
  • Marionette Maven

Ruud,

At a first glance, I don't believe you're using Control Geometry properly.

Control geometry is defined with the "Control Geometry" node in the Input category. This node will look for objects in your defined control geometry (where you put your group and rectangle objects)

At this time, there is no simple support for multiple control geometry objects.

Link to comment

Thanks for the quick answer Marissa! I also had contact with the support, same answer.

In my real model I am using an element with a lot of objects in the control geometry. I can use all the objects by calling their names, except for the groups. So I am amazed this works somehow.

Link to comment
  • Marionette Maven

No problem!

The reason you're still able to call objects by name is because that node will look through your entire document drawing area for objects that are of the same name. I'm actually surprised that groups aren't being recognized, to be honest.

So regardless of you putting those objects in Control Geometry, leaving them on your Design Layer, or even copy-pasting them into your wrapped script, they should be located by the Name node.

I'll try to do some further investigating as to why groups aren't being manipulated, since I really think they should have worked just as they would have in your unwrapped script.

Link to comment

I'm trying to understand Marionette better. This information helps a lot!

You're mentioning three options where to put the objects used by the wrapped script. Groups aren't recognized in any of them. Even one group in the Control Geometry calling with the "Control Geometry" node won't work.

Hope you will find the answer. If you want to see why I need to use a group and to wrap the script, I can sent you my full model.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...