Jump to content
  • 0
Peter King

DWG import overwriting class definitions

Question

Hi

When importing a DWG file into a VW model, I am finding that if any layers in the DWG file have the same name as any of my VW classes, the settings for the DWG layer are overwriting my class settings.

I am currently getting around the problem by doctoring the DWG file first in Autocad LT 2010 and putting everything on Layer 0. This works OK for the particular job I'm working on currently but isn't an ideal solution as it is time consuming and if I forget to do it then all my classes get corrupted!

Is there an import setting that I can change to avert this problem?

Many thanks,

Pete King

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

Some use Layer/Class Mapping and have created special tables that let

them even import whole projects to completely work in their own Class Standards

and change it back to their customers Class Standards when exporting the project

at the end.

And there is an option to add a Prefix to the imported Clases (ACAD Layers) in

Graphics Attributes. Like adding a "DWG_......"

So the Classes will never have the same name as own Classes.

Another recommended way is to import the DWG data into a new blank file and

reference the VW DWG Import File only.

This will avoid any foreign Classes in your project.

Share this post


Link to post
  • 0

Many thanks for your help. You have some interesting sounding solutions there. I have tried your suggestion of adding an 'ACAD' prefix to imported DWG layers and that works a treat. Don't know why I hadn't spotted that!

Thanks again and best wishes,

Pete

Share this post


Link to post
  • 0

You're welcome.

A prefix isn't that bad as it will also help sorting the classes and keeps the imported

classes together. And the import geometry is fully accessible that way.

Share this post


Link to post
  • 0

Peter,

 

Just came across your post.  There is a very simple way of importing dwg files without corrupting your VW datasets.

 

First - Save your work and close the VW file (just in case the AutoCAD file is c**p and crashes VW) then do the following:

  • Open a new black VW file (No template)
  • Import the dwg file - You may have to try a couple of times to get the scales, geo-referencing  etc. correct
  • Go into the Organisation palette and change the fill and pen settings to what you want them to look like - As a rule I always switch the fill off and make everything a single colour (usually black).
  • Change all the objects attributes to "by Class" - My preference as there is nothing worse than working in a file that has multiple objects with different settings in the same class.
  • Save the file

There are two options to import the data.

 

Option 1

  • Open your VW file
  • Create a new layer and make it active
  • Go back to the file you created for importing the dwg file - copy everything (cmd+c)
  • Tab back to the VW file and "Paste in Place"

Option 2

  • Open your VW file
  • Create a new layer by using the "import Design layers" function and choose the new file you have just created.
  • Select the layer in the file (it will be the dwg file name - unless you changed it)
  • Make sure "import layer objects" is selected
  • Click OK

 

Doing it these ways, you will be given the option of accepting or over-riding you VW settings for everything that you are importing and over-rides the undo lock that happens when you import a dwg file

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×