Jump to content

Vectorworks Will not import a DWF

Recommended Posts

We have tried this in 2014-2016 with no luck. We have been sent files in a DWF format. Vectorworks shows this as an import option but Ive tried with multiple files and continue to get the same error. I have attached the error that shows up along with the File Im trying to import.

Any idea why the DWF wont import?

Note: I attempted to upload the file but it will not allow me as it states the extension is not allowed (DWF) I have changed it to a dwg just to upload. You would have to switch it back top DWF.

Any help would be appreciated.

iMac (Retina 5K, 27-inch, Late 2014)

3.5 GHz Intel Core i5

16 GB 1600 MHz DDR3

Link to comment

It looks like there is an error in the implementation of the DWF import. You may want to file a bug report.

Another program that I have also uses the Teigha libraries and can import dwf files, there it worked so I have saved it back as a dwg file that you can import into vectorworks. (see attached file below)

If you know what this file should contain you can check if the import went correctly or that something is missing.

Link to comment
I get a report that the file has an error or corrupt.

Try getting another file, never normally have any issues with this task.

My other cad program imports the DWF, so there are two possibilities:

1. The file itself is ok but it contains something that VW cannot handle.

2. There is an error or an object that the Teigha library cannot handle but the other cad program ignores it and imports the rest of the objects.

If it is the former then getting a new file will not solve the issue. If it is the latter then getting a new file may or may not help depending on whether it is an error or an unsupported object that is causing the import to fail.

Which is why I suggested to the OP to check the converted to dwg file to see if the contents are as it should be.

Maybe it could be possible to have an option to ignore (yet) unsupported objects in dwf (and other) files to at least have something imported. Especially if it is a limited number of objects that are not relevant that cause the import to fail.

Link to comment

What was the other program you tried? We even tried this with AutoCAD 16 LT. and still no success? Ive tried a few different files and they all seem to react the same. We have over 30 of these a client has sent us and we can't view them, let alone open them.

I an try and post another file, But I expect the same results. I also tried this in VW 14,15,16

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...