Jump to content
  • 1

Undo issues




Recently I have been having trouble with my "Undo" command. randomly, when I undo, it goes back 10 or more steps instead of 1 step backward, essentially sending me back entirely too far back in time.

Glitch? Setting I can't find?

anyone else have this issue?



Link to comment

Recommended Posts

  • 0
On 11/22/2017 at 1:31 AM, Lars Tuxen said:

VW2018 SP2...the issues still continue with:

1) the undo command that freezes for a second and then jumps back performing the entire undo history

2) the OIP palette stops showing any info for a selected object be it a wall, polygon or door symbol.


iMac 27" Late 2014

32GB memory


This started to happen to me yesterday. I lost hours of work with one single undo. Automatic or manual saving is not saving!  Other annoying behaviour also affecting my productivity like after customising a curtain wall by deleting some transoms if I change the texture the whole things go back to the original setting...

Started to have problems after 2018 SP1 and project sharing.

Link to comment
  • 0
On 13-12-2017 at 10:14 AM, rovasli67 said:



I also have the undo-issue. I use the VB Quick align plugin from VectorBits. When I remove that plugin the undo-issue seems to be gone.





I have contacted VectorBits about this issue. See reaction below:


hi Ronald,
thanks for reporting this issue.
I have recently updated versions of all of my plugins.
I have solved the issue terminating my code with the end-undo events, even though it wasn’t necessary in earlier versions, and the SDK manual doesn’t force developers to explicitly end undo events.
Anyhow the issue is now solved, and you may now download updated plugins from my site.
Sorry for the inconvenience.
Please let me know if you can post a comment to the forum to make clear that the issue is fixed.
best regards
This is what the SDK manual says (see unnamed.png) about ending the undo events, but for sure this part of the manual is not updated for VW2018.




Link to comment
  • 0

Reviving a dead thread, in case the following helps someone.


VW 2020 undo stopped working.  Didn't go back 100 versions as above, just no abiity to undo.  Seemed to be related to having two or more drawings open at the same time.

Similarly, couldn't copy and paste between open drawings, but could copy and paste within any one drawing.


I deleted the file Vectorworks Preferences.xml


C:\Users\windows user folder\AppData\Roaming\Nemetschek\Vectorworks\2020\Settings\Vectorworks Preferences.xml


This obviously meant having to set all my preferences again and switch back to my preferred Workspace, however the undo and copy paste now works once more.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...