Jump to content
  • 1

Undo issues




Recently I have been having trouble with my "Undo" command. randomly, when I undo, it goes back 10 or more steps instead of 1 step backward, essentially sending me back entirely too far back in time.

Glitch? Setting I can't find?

anyone else have this issue?



Link to comment

Recommended Posts

  • 0
  • Vectorworks, Inc Employee

Actually, given the problems you just described above as well as in this thread:


I recommend performing a preference backup and reset as described here:


Link to comment
  • 0

I'm having similar issues at times with some drawings recently when I use "ctrl-z" to undo, it is as if a keyboard key is "stuck" and it repeats the command several times in a fraction of a second.

Now I am typing this, it does make me wonder about something. Are you using a mechanical keyboard with fast rollover? (though I do seem to have the issue with a non-mechanical keyboard as well)

Link to comment
  • 0

I can confirm that this issue is currently still actively happening for a select few of my students.

It seems that something (unknown) causes a single press of Command + Z to change from a single instance undo to performing the entire undo history.

The issue is worst than just a potential 50 undo actions. Although the Redo option is available it does nothing. Holding the action causes the menu to flash as though the command is being executed but nothing actually occurs.

I've had this occur on 3 of 16 student's computers over the last month. All using either VW2016 SP2 or SP3 on MacBook laptops of various ages and specs.

Once the issue has occurred it seems to lock the Command + Z to always perform this mass undo. Restarting the program has fixed it in the past but it's almost guaranteed to reoccur on the computer later in the lesson seemingly unpredictably.

I can't as yet replicate the problem on my own machines but I would love to know if anyone has some preventive ideas. I have performed a preferences reset as above on a student's computer two days ago in our previous class and the problem has reoccured today.

Hope you're all well otherwise.


Link to comment
  • 0

We are also having this problem (or very similar problem) with VW 2017. Hitting the Undo shortcut key once wipes out all recent work - many steps back.


Still trying to figure out if it is undoing everything back to the last save or all work during the current session but in some cases we suspect it actually undid work past the last save (reverting it to prior condition before save).


In our office at least two of us have had the exact same problem. At first we both thought we were imagining it. It's an infuriating problem as usually no means of recovering the lost work - not even from the backup file.

Link to comment
  • 0

Just had a repeat of this problem. Lost about 2 to 3 hours of work. This needs to be fixed very very badly! Was hoping the recent upgrade to Service Pack 3 would fix it but apparently not.


With software this buggy and unreliable which can lose hours of work in one step (even undoing past saves) it seriously makes me question why we continue to use it. The negatives seems to be surpassing the positives. Once again (Vectorworks) please fix this problem! This is not a productive method of working.

Link to comment
  • 0
On 29/10/2017 at 5:10 AM, Lars Tuxen said:

The problem continues in VW2018/ SP1 on mac 10.13 High Sierra.

It still jumps back 5-10 steps.

Same with me. I had no problem with 2017, but 2018 and now 2018 with SP1 on mac 10.13 this happens a lot.

I reset preferences.

I have reinstalled VW2018.

Still happens - random jumps back 5-10 steps.

Undo preferences doesn't seem to affect the behaviour.


iMac Retina 5K, 27-inch, Late 2015
Core i5 3.2 GHz 
Memory    24 GB

AMD Radeon R9 M390

Link to comment
  • 0
6 hours ago, Lars Tuxen said:

VW2018 SP2...the issues still continue with:

1) the undo command that freezes for a second and then jumps back performing the entire undo history

2) the OIP palette stops showing any info for a selected object be it a wall, polygon or door symbol.


iMac 27" Late 2014

32GB memory


Do you mean VW2018 SP1?

That's what I have.


Yes the Object Info palette does the same for me.

It shows no info until I save, then it often shows the info on the object.

If it doesn't work after a save I have to move the selected object - then the OIP shows the object, but of course I have to move the object back to its original position.

And if I use the undo command to move it back in position then I might get the behaviour that you mentioned earlier, that it jumps back to a random post in the undo history.


Restarting the computer helps for a short while, then the behaviour happens again.

I can't work for more than three-four hours without it happening.

This is on a new file started in VWA2018, as well as files updated from VWA2017.


Frustrating. For me VWA2018 is the buggiest release ever.


I wonder if anyone at vectorworks is listening?



Link to comment
  • 0

It is very discouraging to hear this problem is still recurring. I was hoping at the very least an upgrade to VW2018 would resolve this once and for all. VW2018 has been installed on our workstations but most of us have not started using it yet. Sounds like maybe we should stick with VW2017.


One thing I did when having frequent recurrences of this problem in VW2017 was to change the default shortcut for undo to the most complicated combination of keys possible so I wouldn't use that command by habit and inadvertently lose absolutely everything I worked on since last opening the file. In disabling the default shortcut it would force me to stop for a moment and ask myself "is it really worth the risk?" and consider just deleting what I worked on in the last few steps and repeating the work again. Anything to avoid initiating an undo command.


I know that's an incredibly archaic method no one using any CAD software developed since the early 80's should have to resort to but it seems to have worked. Now I may need to change the "shortcut" combination to something even more difficult to remember as i've already memorized it and sometimes accidentally use the undo-command without stopping everything to conduct proper "cost-benefit analysis".


Fortunately I've been lucky the last few times I used that command and it actually did what it was supposed to rather than wipe out every single thing I've worked on.

Link to comment
  • 0

Brian that sounds absolutely maddening.

I have found that, if, when I have the undo problem, I immediately redo (command Y), then I usually don't lose all that work.

It has to be immediately after the undo.

I still have to go back and replace the item, or relocate it or whatever I wanted to undo in the first place.


Yes it's ridiculous that your work around is necessary 


But for me this has only started in VWA2018 – it was never an issue with VWA2017.


If I had already had your problems last year I would be very wary of the upgrade.

Link to comment
  • 0

hi peterhill,


Yes it's incredibly maddening but even more maddening is losing everything I worked on since last opening the file. At least if it happens while working on file using project sharing (as far as I know) it will never undo past the last 'save and commit' operation.


I may give the "immediate redo" method a try again but the last I remembered it just re-did one step forward which is the typical limit of the 'redo command'.

Link to comment
  • 0

another workaround method I've tried is instead of just 'saving' my work I will periodically close the file and reopen it to make sure the backup is up to date and provide safeguard against any undo commands undoing past that point. Others in our office experiencing this problem noticed that the backup file does not always reflect the most recent saves.


That is unless using project sharing where I would just need to 'save and commit' instead. Maybe it makes sense to just always use project sharing even if no one else needs to work on the file.

Link to comment
  • 0

Hi peterhill /brian-rwc

Yes I mean VW2018 SP2 and upgrading to VW2018 is when I started having problems with OIP and UNDO command. I was really looking forward to this SP2 release as it was mentioned that the problem had been solved.

I have used VW since 1994 and allways felt it was one of the most stable programs in the market but today I tend to agreee with you that VW218 is the most buggiest release. The problem is that the UNDO command and use og the OIP is so critical for everyday workflow that it is a pain now to work. On top of having lost several hours of work I have also spent many hours on searching and cleaning my system for any possible connection. The obvious presence of 3 party extensions, 3D connection mouse,  menu items that could interfere with VW2018 has not changed anything. I also used the workarounds that brian-rwc mentioned.

I have read somewhere that it might be connected to Apple MacOS 10.13.1- is anyone experiencing the problems on a windows version?

Regards Lars

Link to comment
  • 0
2 minutes ago, Lars Tuxen said:

I have read somewhere that it might be connected to Apple MacOS 10.13.1- is anyone experiencing the problems on a windows version?

It happened to me in the past very sporadically on Windows but so far have not encountered it in VW2018, so it happens on Windows too but perhaps not as often as on Mac.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...