Jump to content
Riffus

VWX Fundamentals 2016 - Autosave Back-up function ... not backing up!

Recommended Posts

I was happily working on a VWX drawing yesterday and the software crashed.

As I always have my preferences set to "Autosave every 15 minutes" and "Autosave a Back-up copy" I thought no problem.

But it turned out that the whole document was not saved for several hours. Much time lost.

Why is this happening please? Any ideas?

VWX Fundamentals 2016 v.SP1

On Mac OS X El Capitan v.10.11.3

Edited by Riffus

Share this post


Link to post

Where do you have the file saved originally? On the local machine, on a server, or in a cloud sharing folder like Dropbox?

Did you perform an original save to start with once you set the document up? Or was it never saved manually?

Share this post


Link to post

Thank you for your quick reply.

You have slightly got me there on both questions:

- I am not on a server, but I have been moving things from my computer to and from Dropbox - so that is a possibility.

- The "original save" is also a good question - I take it this is 'a must'.

Your questions may be leading me to the answers so if you could clarify - particularly re: using Dropbox - I would be most grateful.

Best regards

Share this post


Link to post

I have had a number of users reporting issues when saving (especially auto saving) to dropbox, but these were mainly crashing or long save time problems that COULD have been related but I think it wasn't the main cause of the problem here. I suspect your issue was the lack of the first save, the first save is indeed mandatory or autosave does not start.

I believe this incident could have been avoided on our end by making autosave prompt the user for the first manual save of the document at the first interval, I'll add this thread to that existing feature request now.

Share this post


Link to post

Can I revive this item .. because I just worked on a VWX file on my computer (i.e.: not on Dropbox) and did an hour of work.

It then crashed (often crashes on saving - does anyone know why??)

And left no "back-up" version (anywhere) even though my preferences are set for auto-backup every 10 minutes.

All suggestions most welcome.

Share this post


Link to post

When was the first time you performed a manual save in that file in that session? Is that the modified date and time on the original or is it different?

Share this post


Link to post

Thanks Jim,

I have to say I am baffled because I am a regular manual saver but somehow I had lost an hour's work.

I had secured some saves on that session because some of my changes are there.

Then there is this business of the crashing itself. Which happens very frequently and it happens when I do a manual save. But not every manual save.

Any thoughts much appreciated.

Share this post


Link to post

You can often get crashes with a big file saving to a memory stick

Share this post


Link to post

I too have had this happen - today I worked on a survey till midday saved then "saved as" to a new document (to start separate sketch drawings on top of the survey) worked on it all afternoon and had a crash about 4:00. I have lost the survey drawing work (from the morning) and the sketch drawing does not even exist! The back up has the survey from Friday's work (none from today) and there is no backup for the sketches.

Now the really confusing thing is I "saved as" and worked on the sketch drawing for an hour then closed it, shut down VW and went for lunch. Came back opened VW  AND my sketch drawing with NO problems. So it definitely was there!

So the only conclusion I can come to is that VW has crashed and then deleted the sketch, survey and back ups!!

my settings - back up every 5mins, save to folder in same place, don't ask to save, no Dropbox etc

 

any help would be welcomed!

Share this post


Link to post

I have seen some weirdness with Autosave at times. I personally would recommend using number of operations rather than time. This guarantees you're not in the middle of a tool/command when it saves. Mine is set to "Autosave every 20 Operations". I also recommend saving the backups to a different folder/location. All of my backups go into one central folder for a couple of reasons - so I can see at a glance that autosave has been saving when working on multiple projects/files, so i can easily delete backups when they are no longer needed and so I don't need to hunt around to find a backup.

Kevin

Share this post


Link to post

Something I have noticed at times when trying to save/copy/delete files is that if Windows is indexing files or generating a preview it may not (auto)save etc. depending on the autosave settings. (e.g. if there is only one backup copy used), until Windows releases/unlocks the file.  It is similar as if the file would be in use by another application/Vectorworks instance or be read only. Autosave will fail but not always provide a notification.

Maybe Vectorworks should get an option to notify the user if an autosave could not be performed/completed?

Edited by Art V

Share this post


Link to post
On 3/12/2016 at 4:43 AM, Jim Wilson said:

I believe this incident could have been avoided on our end by making autosave prompt the user for the first manual save of the document at the first interval, I'll add this thread to that existing feature request now.

 

I've just verified this feature has not yet been added to Vectorworks. (As at Vectorworks 2019 SP2)

  • Like 1

Share this post


Link to post
1 hour ago, Jeremy Best said:

 

I've just verified this feature has not yet been added to Vectorworks. (As at Vectorworks 2019 SP2)

thanks for the heads-up

Share this post


Link to post
On 12/12/2018 at 5:08 PM, Jeremy Best said:
On 3/12/2016 at 4:43 AM, Jim Wilson said:

I believe this incident could have been avoided on our end by making autosave prompt the user for the first manual save of the document at the first interval, I'll add this thread to that existing feature request now.

 

I've just verified this feature has not yet been added to Vectorworks. (As at Vectorworks 2019 SP2)

 

Hey @Jim Wilson, if you think it might help, can you please reignite or bump this feature request? It seems like a pretty small/easy think to implement and offers great potential benefits / time savings of work lost. 

Share this post


Link to post
16 hours ago, Jeremy Best said:

Hey @Jim Wilson, if you think it might help, can you please reignite or bump this feature request? It seems like a pretty small/easy think to implement and offers great potential benefits / time savings of work lost. 


This should already be happening, I think I had Vectorworks prompt me about this the other day. Let me check and make sure. 

Share this post


Link to post
5 hours ago, Jim Wilson said:

This should already be happening, I think I had Vectorworks prompt me about this the other day. Let me check and make sure. 

 

Cool, thanks. I'd prefer to be wrong in this instance! 😁

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×