Jump to content
Sign in to follow this  
kmead

10.1.2 update doesn't take

Recommended Posts

On the two computers I have so far updated (or more correctly attempted to update) I have not had good success.

On my at work system, a Mac G4 500 OS10.2.6, with VW Architect installed I tried several times to update and it never actually installed the change. I ended up doing a clean install of VW this time with Mechanical and then ran the updater and it took the first time.

On my home machine a Mac G4 Dual 867 MDD, OS 10.2.6 I also have Architect installed and am unable to get the update to take.

It runs, appears to install a few things and then finishes with the message that you should update the name of the application directory (a decidedly MSW statement). So does the update work with Architect? I have serial numbers to try Standard, Architect and Mechanical. I would rather not reinstall (even though it is easy) but what I use at home is Architect and would rather not reinstall it just to find that the updater doesn't actually work with Architect.

Many thanks;

[ 05-24-2003, 06:00 PM: Message edited by: kmead ]

Share this post


Link to post
Guest

If you go to about this program or get info and the version does not reflect the new updated version, the updater didn't work.

THere are two things that can cause this problem.

1. - CHanging the name of the application you are trying to update.

If at any point in time you changed the name of the application, the updater will say it's updating but really fails. This is a bug in the updater sotware itself from what I understand.

You should never change the name of the application.

YOu can change the name of the application folder or application aliases, but never the application.

2. Permissions. OS X has all kinds of wierd permission and other internal OS conflicts if the OS is not tuned on a regular basis. We have seen cases where out of whack permissions have cuased updates to fail.

You can try to correct permissions by running DIsk Utility First Aid, and then try the installer.

However, that more than likly will still fail and you will need to reinstall the previous version of VW 10 to get this updater to work.

IN either event, you will probably need to reinstall the previous version of VW 10 to get hte update to work. I have yet to see a case where renaming the application or running first aid will then allow the update to take.

Share this post


Link to post

Thanks Katie. I suspected as much. I regularly run Cocktail to fix permissions and run the cron scripts for general maintenance so that wasn't the problem.

I may have changed the name as I have several versions of VW on my machine at any one time (8.5.2, 9.5.3 and now 10.1) and the two latest icons look virtually identical on the dock. So it is my error in all likelyhood, I wish that OS10 was more tolerant of the user, but Unix is Unix. I have had to change the ownership several times in the past on a file to get things to work properly. I may try changing the ownership from System to myself, this worked with another update I had trouble with from another vendor.

I suspect I will be reinstalling and hopefully I won't be back for a followup. [big Grin]

Thanks again;

Share this post


Link to post
Guest

Karl,

You can create an alias, rename the alias and throw that in the dock instead.

That way you can keep track of the version in the dock.

I have a hard time myself since I have back to MC 7 on here. I just renamedt he aliases and put them in the dock.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×