Jump to content

Walkthrough Cuts through walls

Mike Banks

Recommended Posts

I am trying to set up some views inside a building looking out the window. I am using the walkthrough tool to position the view. The problem is that walls are being section-cut at a specific distance from where the viewer is positioned, let's say at 8 feet forward. I need to figure out how to eliminate this cutting through walls, floors and ceilings so that I can get a view of the area.

Using Vectorworks 2016.

Any ideas?

Link to comment

Hi Mike, Not sure exactly what you are seeing(?). The Walkthrough Tool will walk right through walls, so you have to be careful as you navigate. If you are setting up static views you might try using the Renderworks Camera. Check it out and post back with follow up questions.

Also, it is generally helpful if you create a signature (in your profile) which lists your Hardware, OS and VW's versions.

Link to comment

Is there a way to get rid of the 4 corner marks on the camera view?

One disadvantage of using the camera is that you place it in Top Plan view but it might not be just right when you see the view. Adjustment is more difficult than with the Walkthrough. There is no setting to decrease the distance at which the walkthrough tool cuts away walls?


Link to comment
  • 1 year later...

Hey I also have this issue with Vectorworks 2018 (it also happened with 2017) - basically when I'm doing a walkthrough with open GL it seems to cut into objects before I actually reach them. 

I've attached an example where I'm at about 1.5m above the floor level and it still cuts through to reveal beneath.

Super annoying!!

Any help would be very gratefully received!

My specs are:

i7-7700k, GTX 1080, 16 GB Ram

Running Windows 10 v1703

Vectorworks 2018


Link to comment
  • 5 months later...

For anyone who comes across this thread in future, the cause (as was the case for @sandii) is due to things being too far away from other things. Like, hundreds or thousands of kilometres away, however 8km is the recommended maximum span for all objects in a drawing. As I understand it, is a limitation common to all CAD programs. To find and correct the items causing these symptoms: 


First, turn on all Layers and Classes with 'Show/Snap/Modify' on for both... Then using logical sequences of 'Select All > Fit to Objects > ...' etc, find and correct: 

  • Any objects (typically extraneous) far away from their model (first), then; 
  • Any object/s more than 8km away from the Internal Origin. If the main drawing is itself more than 8km away from the Internal Origin, centre it on the Internal Origin. See: Tools > Origin > ... 
  • User Origin that is more than 8km away from the Internal Origin. This alone can cause the symptoms described by user Sandii. EDIT: (I no longer believe this to be true as the User Origin is often used where massively-offset reference points are involved). 


This situation often occurs as a result of importing a site survey file (including DXF/DWG files) that can contain far out objects or reposition the User Origin. Paying attention to and understanding all the import settings may prevent this outcome. It is also recommended that these files are first imported into a 'new, blank document' where you can check for this phenomenon and purge unneeded items in the Resource Manager. 


EDIT: I've since produced a step-by-step guide to remedy 'far out objects.' See the document below/attached: 


Tech Support Tutorial; Rectifying 'far out objects' - Written Guide.pdf

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...