Jump to content

VW 2016 SP2 Custom Stair Bug? Story Height problem?


Recommended Posts

I use the old-fashioned "custom stair" tool in all of my files. Since upgrading to VW16, SP2, any edit to the stair causes it to disappear. Not just invisible type disappear - simply vanish into the ether(net).

And when trying to edit a story height, I get a warning that the "structure must be set to greater than zero". Given that the project is just 90' above sea level, everything is greater than zero. The computer churns for a while then seems to accept my change in story height.

My biggest concern is the custom stair. I can easily work around the story height changes, but the custom stair is like oxygen to me!

Thanks for any help!


OS X Yosemite 10.10.5

iMac, Retina 5K, 4GHz i7 w/ 16GB 1600 MHz DDR

AMD Radeon R9 M295X 4096MB

Link to comment

That's the problem. I have a 90% set of residential CD's that I have converted to 2016. I'm having a lot of trouble with editing anything that ties to story heights, like structural columns and the stairs simply vanish. I can see that it works in your file--maybe it is a translation issue--but I'm hoping it is something I'm doing wrong so that I can at least fix it!

The only reason I'm changing story heights so late in the game is for value engineering--but it should still be able to be done.

Thanks for your help!


Link to comment

Hi, I see the issue. Opened VW2015 and created 2 new storeys, Had my design layer set to the default "Design Layer 1" and not Ground Floor, so when I created a stair it put the stair start on design layer 1.

So I go to the stair OIP and change the lower storey to Ground and back to page and stair disappears. Even if design layer are set to show all. It is not until I click on the Ground floor class does the stair show.

So in the attached file click on Design Layer 1 and the stair disappears. Click on Ground and it appears.

So there must be an issue in 2015 and the stair tool.


and NO your not going mad.

Link to comment
  • Vectorworks, Inc Employee

"Legacy" as we use the term normally means that the tool or command is still included in Vectorworks as a plugin, but if at any point it happens to stop working a few versions down the line, it would be removed.

We call this "Legacy" because thats the name of the section in the workspace editor where no-longer-supported tools reside, generally these tools are also not added to the default workspaces by us, same with "Cut 3D Section" and "Export PDF Quartz Only". It's sort of a retirement home state before tools are officially removed from the software, but the amount of time they spend there can be anywhere from a single version to a decade. Its all a matter of how long they stay functional without special treatment for them to remain so.

Link to comment
  • 1 month later...

Hi Jim

Just tried this in VW2016.

Attempt 1: Halfway through creating the stair I get a message saying: 'A Script error has occurred. Refer to the file "Error Output" for a further explanation' and lost all ability to edit the stair settings in Vectorworks, even a new stair.

Attempt 2: Following rebooting of VW, it now seems to have worked, and can edit the stair without it disappearing. Few issues with some classes not showing through where supposed to but eventually got it looking like the original 2015 drawing.

Is the custom stair tool due to be updated for next service pack of VW2016? As said before, it has better control (winders, angles etc) than the basic stair tool.

Link to comment
  • 1 month later...
  • 3 weeks later...

Hello, I too have had an issue with disappearing custom stairs. I don't get any script or error messages. Everything looks fine, until I want to do ANYTHING to the stairs. Anything from moving them, mirroring them, rotating, and also when I make any changes to the stairs.

I have already re drawn these stairs, and don't want to resort to redrawing over and over again everytime it happens.... :(

Everytime I redraw the stairs it will allow me to make adjustments, until well, I don't know until what, it just suddenly disappears again.

Has anyone encountered the same issue?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...